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Installing and 
Configuring MapInfo 
Professional
This chapter helps you install and set the basic preferences for MapInfo 
Professional®. In addition, there are instructions for fixing problems that come 
up as part of the installation process. We also cover starting and exiting the 
product.
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System Requirements
System Requirements
Below are the guidelines for minimum and recommended system requirements. Please note that 
hardware requirements do vary based on your use of the product and your system. In general, a 
higher processor speed, larger memory (RAM) and industry leading graphics cards provide a better 
user experience and result in better responses from MapInfo Professional. These are the minimum 
system requirements for MapInfo Professional 9.5:

* MapInfo Professional is not currently Windows Vista certified.

These are the recommended system requirements for MapInfo Professional 9.5:

Note For Windows 2003 Server Users: Remember that some of the options you choose for the 
server can limit the options available to the client system.

Operating Systems  Memory Disk Space Graphics  Monitor

Windows 2000 Professional SP 4

Windows XP Professional SP 2

Windows XP Home SP 2

Windows XP (64-bit)

Windows Vista Ultimate

128 MB of RAM 
with a minimum 
of a Pentium PC

Application 103 MB 
Data 450 MB

16- or 24-
bit Color 

800x600 
Display

Windows 2000 Server SP4 

Windows 2003 Enterprise Server 
SP 1 with 
Terminal Services/Citrix 4.0

64 MB of RAM 
with a minimum 
of a Pentium PC

Application 103 MB 
Data 450 MB

16- or 24-
bit Color

800x600 
Display

Operating Systems  Memory  Disk Space  Graphics  Monitor

Windows 2000 Professional SP 4

Windows Vista Ultimate

Windows XP Professional SP 2

Windows XP Home SP 2

Windows XP (64-bit)

256/512 MB of 
RAM with a 
minimum of a 
Pentium PC or 
better

Fast EIDE 2 
or SCSI 
Interface with 
2GB or better

Data 450 MB

Mid to High 2D/3D 
card with 128MB 
or better

Greater than 
1024x768 
resolution or 
better

Windows 2000 Server SP4 

Windows 2003 Server SP 1 with 
Terminal Services/Citrix 4.0

Same, PLUS 
memory 
sufficient to 
support each 
connected user

Fast EIDE 2 
or SCSI 
Interface with 
2GB or better

Data 450 MB

Server: Same

Client: Choose 
based on 
resolution/speed 
requirements

Greater than 
1024x768 
resolution or 
better
8 MapInfo Professional 9.5



Chapter 1: Installing and Configuring MapInfo Professional
Quality Assurance has exhaustively tested MapInfo Professional under the following Microsoft 
Windows Desktop Operating Systems:

• Windows 2000 Professional
• Window XP Home Edition
• Windows XP Professional

Quality Assurance has exhaustively tested MapInfo Professional under the following Microsoft 
Windows Server Operating Systems:

• Windows 2003 Server
• Windows 2003 with Terminal Services with Citrix Meta Frame technology. To learn more about 

this installation option see Windows 2003 Server with Terminal Services/Citrix Support on 
page 10.

Quality Assurance has performed Installation and validation testing on the following 64Bit Windows 
Operating System:

• Microsoft's 64-bit Windows XP Professional with 32 Bit compatibility mode. 

Note There are no special installation instructions for installing MapInfo Professional on a 64-bit 
Windows Operating System. Please follow the instructions designed for your installation type 
(Typical Workstation Installation on page 15, or Custom Workstation Installation on 
page 16) presented in this chapter.

MapInfo Professional and Operating System Support 
This section provides additional detail on the operating system support for MapInfo Professional, 
including:

• Windows 2000 Support on page 9
• Windows 2003 Server with Terminal Services/Citrix Support on page 10

Windows 2000 Support
MapInfo Professional supports Windows 2000 (SP 4) features as described in the Application 
Specification for Microsoft Windows 2000 document (available at 
/http://technet.microsoft.com/en-us/windowsserver/2000/default.aspx).

The key aspects of Windows 2000 support with regard to MapInfo Professional are:

• Supporting multiple users on a single machine, each having their own application settings.
• Supporting use of MapInfo Professional on a secure Windows 2000 computer (one where users 

have very limited access rights).
• Using an installer based on the Windows Installer Service.

In order to support these requirements, we have changed the location of many application data files 
(for example, files containing information used by MapInfo Professional during execution (for 
example, the projection file, mapinfow.prj). The installer places the files under the current user's 
Application Data folder. Likewise, some registry entries have been moved from 
HKEY_LOCAL_MACHINE to locations under HKEY_CURRENT_USER. In both cases the current 
Supplement 9
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MapInfo Professional and Operating System Support
user is guaranteed to have write access to the folder or registry key. Also, since the files and registry 
entries are stored in user specific locations, each user of the computer has their own application 
data files (e.g. each has their own copy of the preference file, mapinfow.prf).

Note The changes described above apply to all versions of Windows supported by MapInfo 
Professional. The exact location of the Application Data folder varies depending on the 
version of Windows: 

Windows 2003 Server with Terminal Services/Citrix Support
MapInfo Professional supports Windows 2003 Server with Terminal Services through Citrix to allow 
any member of the group Users to be able to use MapInfo Professional via a Terminal Services 
session. The Terminal Services feature is essential to the operation of the Citrix Access 
Infrastructure.

We recommend that you consult with your Citrix administrator in the Citrix configuration guidelines 
PDF. That document includes both questions and answers about RAM and CPU requirements. This 
document is available by clicking this link. 
http://support.citrix.com/servlet/KbServlet/download/4257-102-
11011/Load_Manager_Guide.pdf.

We have tested MapInfo Professional with a standard install of Citrix v4.0 and Microsoft Terminal 
Services 2003. We verified the testing of MapInfo Professional on CITRIX v4.0. MapInfo 
Professional does not require any client side technology, however, Citrix requires the Citrix Client to 
be installed. We tested against Version 6.20.985 of the client.

The recommended RAM amount is based on the general guidelines from Citrix and uses this 
formula:

RAM required for the application x the number of concurrent users

Our testing of MapInfo Professional running Citrix on a Pentium CPU suggests these guidelines:

64MB of RAM X the number of concurrent users

We have modified our installation process to ensure that MapInfo Professional operates successfully 
in a Terminal Services/Citrix environment. When the installer detects that the user is installing locally 
in a system running Windows 2003 Server with Terminal Services through Citrix, the installer adds 
the necessary files and components to that machine. Once the user connects for the first time to the 
Terminal Services/Citrix computer and runs MapInfo Professional, a user configuration process 
begins to copy the per-user files needed to run MapInfo Professional. This works in the same way 
for Windows 2003 Server/Citrix clients as any other MapInfo Professional windows client.

OS Application Data Folder Location

Windows 2000 (SP 4) c:\Documents and Settings<user name>\Application Data

Windows XP Professional (SP 2) c:\Documents and Settings<user name>\Application Data

Windows XP Home (SP 2) c:\Documents and Settings<user name>\Application Data
10 MapInfo Professional 9.5
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Chapter 1: Installing and Configuring MapInfo Professional
During the installation process, if you decide that the default installation locations are not appropriate 
for your implementation, you can change these locations using the MODE.INI file. For more 
information about constructing a custom MODE.INI file, see Controlling the Location of 
Application Data Files During Installation on page 37.

All Citrix testing we have done has been accomplished using the standard Citrix server and client 
installations. We used Citrix Server version 4.0 and the Citrix Client version 6.20.985. Installing 
MapInfo Professional on the Citrix Server

Citrix users follow the Typical Workstation Installation instructions to install MapInfo Professional. 

Note While we expect to work with ODBC and OCI technology on Citrix, we recommend that your 
Citrix administrator consult with database vendor documentation to configure their respective 
drivers on Citrix.

MapInfo Professional Database Connectivity and Support
MapInfo Professional supports the following spatial database servers:

• SQL Server 2000/2005
• Informix 9.x
• Solaris 32-bit 
• HPUX
• Oracle Spatial 10G, 9iR2, 9iR1

Further, using ODBC drivers, you can access your data from MapInfo Professional using:

• Oracle ODBC Driver 9x
• SQL Server 2000/2005
• Informix 3.x

You can also open tables of data from the following databases and make them mappable but only for 
point data:

• Oracle 9iR2
• Oracle 10G
• Oracle 11G
• MS Access XP
• MS SQL Server 2000/2005
• Informix 9.4

For more about working with remote database information, see Accessing Remote Data and Setting 
your Database Connection Preferences in the Help System.

A Note about SQL Server 2005 Support

MapInfo Professional supports the changes in the MS SQL Server 2005 schema concept. Microsoft 
has enhanced SQL Server 2005 to use schemas to organize database objects into namespaces. In 
the past the schema was part of the owner/user construct, so when you deleted a user, you deleted 
the objects associated with that user. 
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Using SQL Server 2005, objects are associated with a schema, which can be associated with many 
users and each user can be associated with many schemas. 

The old fully qualified name of a database object was:

Server.Database.User.Object.

The new fully qualified name of the object is:

Server.Database.Schema.Object 

If you leave out the server and database name identifiers, MapInfo Professional uses the current 
server and database names. If you do not explicitly specify a schema for a user, the server assumes 
any unqualified object names are in the default schema. Therefore, if you are accessing a SQL 
Server 2005 database, you need to update any features/functions, tools, and test scripts accessing 
the objects, including the metadata in the MAPCATALOG, to use the new fully or partially qualified 
object name. 

To make this version of SQL Server work, you must have this 8.5.1 (or later) version of MapInfo 
Professional. There is a work around for MapInfo Professional 8.5 and earlier versions that 
accesses a server table with the form, Database.Owner.Object. Review the MapInfo Professional 
8.5 User Guide for these instructions.

Before You Install MapInfo Professional
Before installing MapInfo Professional, record your serial number and access code in an easy-to-
remember place, such as the title page of the User Guide or Supplement. You need a valid serial 
number and access code to complete an installation or an upgrade. Also, please complete the 
postage-paid registration card and return it to Pitney Bowes MapInfo Corporation. Additionally, you 
can register online by accessing the Contact Info option on the CD Browser.

If the MapInfo Professional installer detects a current version of the product, 6.0 or earlier, or detects 
that the product had been installed at some time, the installer copies the MAPINFOW.WOR, 
STARTUP.WOR and MAPINFOW.PRF from the operating system's system directory to <user profile 
root>\Application Data\MapInfo\MapInfo.

Application data (appdata) files are the non-executable data files that MapInfo Professional uses 
during operation.

To use a silent installation procedure, see Silent Installation Procedures for System 
Administrators on page 30.

Navigating the MapInfo Professional CD Browser
The initial screen of the MapInfo Professional CD Browser includes these options:

• Install Products
From this option you can install MapInfo Professional (including DBMS support and 
translators), free data, access to the documentation, and Install Utilities, including: ECW 
Compressor and GPS.
12 MapInfo Professional 9.5
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• What’s New
Displays a list and description of new and enhanced features.

• Online Reference
MapInfo Professional provides the following online reference documents: The MapInfo 
Professional Supplement, MapBasic Reference, Crystal Reports User’s Guide, the MapInfo 
Professional Printing Guide, as well as the Adobe Acrobat Reader. The MapInfo Professional 
and Crystal Reports documentation are copied into the Documentation subfolder of your 
installation directory during the installation process.

• Run MapInfo Tutorial
From this option you can access the MapInfo Professional Tutorial from the Pitney Bowes 
MapInfo web site to learn more about the basic features of the product.

• Other Products
Displays information about MapBasic, MapInfo Discovery, and MapInfo Professional for SQL 
Server.

• Contact Information
Where ever you are, Pitney Bowes MapInfo is there to help you. Contact us at any of these 
locations or visit us on the world wide web at www.mapinfo.com!

• Register Online
We have simplified the registration process. Simply click this entry and the wizard walks you 
through the registration process quickly.

• Browse CD
From this option you can review the contents of the CD. There are additional utilities that may 
be useful to you that are only available when you browse.

• Exit
From this option you can close the CD Browser application.

Installing MapInfo Professional
CAUTION: We strongly recommend that you exit from all Windows programs before 

beginning the installation process. If you are upgrading from an earlier version 
of MapInfo Professional, we recommend that you uninstall before upgrading.

You must have Administrator rights to run the Installer on Windows XP.

If your Windows Start menu does not have a MapInfo program folder, the installation process 
creates this folder. If your Windows Start menu already has a MapInfo program folder, this process 
creates a new MapInfo icon within that folder.

MapInfo Professional provides its application data files to each user. Called a Per-User install, this 
functionality runs the first time you run MapInfo Professional or MapInfo Professional client on a 
machine, and each time the MapInfo Professional Installer is run thereafter. The application data 
files include, among others, the Pen Styles file, Custom Symbols files, Graph Support files, and 
Thematic Legend templates. These files allow different users to have custom settings.

Note The Installer requires that your TEMP variable be set to a valid directory.
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Installing MapInfo Professional
To install MapInfo Professional:

1. On the Launcher menu, click Install Products from the MapInfo Professional CD Browser.
2. Click MapInfo Professional Installer. The Install Shield Wizard dialog box displays. Click Next 

to continue the process and display the License Information dialog box and accept the terms of 
the agreement.

3. Click Next to continue. The Customer Information screen displays.

4. Type your name, organization name, serial number, and access code in the corresponding fields. 
The serial number and access code are listed on the Product Activation Information Card in the 
product box and are used to activate your product. Click Next to continue.

5. Do one of the following: 
• If your organization purchased node-locked licenses, the third character of your serial 

number is "N". Skip this step and go to step 6. For more information, see Node-Locked 
Licenses on page 18.

• If your organization purchased concurrent licenses, the third character of your serial number 
is "S". In those cases, the License Server Name and Port dialog box displays on the screen. 
14 MapInfo Professional 9.5



Chapter 1: Installing and Configuring MapInfo Professional
If you know the license server name and port number, enter them here. If you do not, you can 
continue with the installation without filling in the license server name and port number. You 
will have another opportunity to supply this information when you start MapInfo Professional. 
For more information, see Concurrent Licenses on page 27. Click Next. 

6. Review the following installation types and determine which instructions are appropriate. Click 
one of the following and click Next to continue:
• Typical Workstation Installation. Click this option if you will be using MapInfo Professional 

as a desktop application including remote database access and connectivity. See Typical 
Workstation Installation on page 15 to continue these instructions.

• Custom Workstation Installation. Click this option to restrict the components that are 
installed by the installation program. For example, you can prevent the installer from adding 
the help system and tools. See Custom Workstation Installation on page 16 to continue 
these instructions.

Typical Workstation Installation
Choose this option to install MapInfo Professional program files, Online Help, Tools, Universal 
Translator, and Crystal Reports. The ArcLink translation utility is not installed with this option.

CAUTION: Make sure you have completed the directions in Installing MapInfo Professional 
on page 13 before beginning these instructions.

To continue installing MapInfo Professional on a workstation:

1. In the Setup Type dialog box, click Typical Workstation Installation; the Destination Folder 
screen displays. If you have an earlier version (or versions) of MapInfo Professional installed and 
you do not want to overwrite that version, create a new directory name in the next step.

2. Do one of the following:
• Click Next to accept the destination folder indicated
• Click Change to create a new path in the Change Current Destination Folder dialog box. 

Type the new path in the Folder name field and click OK to continue. Click Next to continue.
The Ready to Install the Program screen displays. Review your selections to ensure that the 
path is correct before moving on. Click Back to make changes.

3. Click Install to begin. A progress bar indicates the status of the process.

Note If you are using ODBC or Oracle Spatial for database connectivity, we install ODBC 
Connectivity and Oracle Spatial support by default to simplify the connectivity process.

4. When the InstallShield Wizard Complete screen displays, choose Finish to return to the Install 
Products screen.

Note When you open MapInfo Professional for the first time, the final installation and configuration 
process takes place automatically. See MapInfo Licensing and Activation on page 18 
before you begin using MapInfo Professional.
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Custom Workstation Installation
Choose this installation type to select components and drivers within the MapInfo Professional 
installation program. This is particularly useful if you want to save disk space by not installing the 
Help System, the documentation, or the MapInfo Professional tools.

CAUTION: Make sure you have completed the directions in Installing MapInfo Professional 
on page 13 before beginning these instructions.

To continue installing using the custom workstation instructions:

1. In the Setup Type dialog box, click Custom Workstation Installation; the Custom Setup dialog 
box displays. A feature description, and the space required for the feature and its sub-features 
displays in the Feature Description area. 

2. In the Custom Setup dialog box you decide what components are to be installed and the 
directory you want them to install to. Click the feature icon to select the feature for installation. 
The options for a Custom Setup include:
• MapInfo Program Files 
• Tools (which refer to the MapInfo Utility Tools, Crystal Reports etc.) 
• Translators (Universal Translators, ArcLink, etc.) 
• Help Files 
• Documentation

3. To select a feature, click the Down Arrow beside it; a menu displays.

4. For each feature you want to install, select one of the following:
• This feature will be installed on local hard drive.
• This feature, and all subfeatures, will be installed on local hard drive
• This feature will not be available

Note For some features, there are additional options pertaining to the use of the feature from 
the network. Choose the option that describes your systems implementation of this 
feature.

When you select the first or second options in the bullets described above, the feature installs on 
your local hard drive in the default folder. This path displays in the Install To: entry below the 
Custom Setup list pane. To specify another path, select Change button. When you do the 
Current Destination folder dialog box displays allowing you to choose a new path.
To see if you have enough space on your hard drive or other mapped resources, click the Space 
button. The Disk Space Requirement dialog box displays the disk size, the amount of available 
space, and the amount of space the selected install would take. 

Note To avoid installing a subfeature, select This feature will not be available. 

5. After you select all the custom options click Next to display the Ready to Install the Program 
dialog box. 
16 MapInfo Professional 9.5



Chapter 1: Installing and Configuring MapInfo Professional
6. Click the Install button to begin the installation of MapInfo Professional with the features you 
selected. The Installing MapInfo Professional screen displays with a progress bar indicating the 
status. 

7. At the end of the installation, the prompt: “Would you like to check our web site for any current 
updates to our product?” displays. If you have an Internet connection, click Yes to access the 
Pitney Bowes MapInfo Corporation web site containing information about product updates.

8. When the InstallShield Wizard Complete screen displays, choose Finish to return to the Install 
Products screen.

Note When you open MapInfo Professional for the first time, the final installation and configuration 
process takes place automatically. 

Setting up MDAC

When installing MapInfo Professional, you can choose whether or not to install MDAC (Microsoft 
Data Access Components). Microsoft Data Access Components include various components: 
ActiveX Data Objects (ADO), OLE DB, and Open Database Connectivity (ODBC). If you are unsure 
whether or not to install the MDAC, consult with your network administrator. This choice allows IT 
administrators to manually install their own replacement modules for the MDAC. You must have 
MDAC, or a replacement, to connect to any databases.

Adding ODBC and OCI Drivers

After you add the ODBC and OCI drivers as part of the Typical Installation process, you can use the 
instructions in Setting your Database Connection Preferences in the Help System to set your 
database connection preferences.

You must have the OCI and ODBC drivers installed for MapInfo Professional to connect to remote 
databases. If you see the following messages, then you have installed the MapInfo DLLs for these 
features correctly but the drivers are missing:

OCI (Oracle Call Interface)
The MapInfo Oracle OCI Database driver (MIDLOCI.DLL) failed to load.
This is most commonly caused by not having an installation of Oracle's OCI 
driver, which is necessary for the MapInfo Oracle OCI Database driver to 
load.
To fix this issue, please install the Oracle OCI Database driver or rerun 
the MapInfo Professional Installer to remove the MapInfo Oracle OCI 
Database driver.
Clicking "OK" will allow you to run MapInfo Professional without the 
ability to open Oracle tables through Oracle's Oracle Call Interface.
If you need more information, please contact Technical Support.

ODBC (Open DataBase Connectivity)
The MapInfo ODBC Database driver (MIDLODBC.DLL) failed to load.
This is most commonly caused by an incomplete installation of MapInfo ODBC 
Connectivity Support. To fix this issue, please rerun the MapInfo 
Professional Installer to repair or remove the MapInfo ODBC Connectivity 
Support.
Clicking "OK" will allow you to run MapInfo Professional without the 
ability to open remote database tables through ODBC.
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If you need more information, please contact Technical Support.

A combined message displays if you attempt to add both of these options and neither of them have 
access to the appropriate database drivers.

MapInfo Licensing and Activation
This section describes the licenses available for MapInfo Professional and how to get started with 
the product according to the type of license your organization purchased. 

MapInfo products have the following licensing schemes: 

• Node-locked
• Concurrent
• Distributed

The serial number and access code that you enter during the installation indicates to MapInfo 
Professional what type of license you have. Depending on the license type, MapInfo Professional 
will guide you through activating the product (if your organization purchased node-locked licenses) 
or connecting to a license server (if your organization purchased concurrent licenses). 

Node-Locked Licenses
Node-locked licenses enable you to run MapInfo Professional on a specific computer. If you 
purchased node-locked licenses, your installation of MapInfo Professional must be activated before 
you can use it. Activation is the process of acquiring a license from Pitney Bowes MapInfo. This 
section explains the activation options available for node-locked licenses. 

Product Activation

MapInfo Professional uses the serial number and access code you supplied during the installation to 
activate the product. If you need to refer to these numbers again, the serial number and access code 
are located on the product box and on the Product Activation Information Card. 
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To activate MapInfo Professional: 

1. Install MapInfo Professional, if you haven’t already, and start the product. When you start 
MapInfo Professional for the first time after installation, the Activation Wizard launches. The 
MapInfo Professional Activation dialog box displays on the screen. 

2. Select when you want to activate MapInfo Professional. Select one of the following:
• Activate Now–Select this option to start activation now. 
• Activate Later–Select this options to start a 30-day courtesy period in which you can use 

MapInfo Professional without activating the product. 

3. Click Next. 
If you selected Activate Now, go to step 4.
If you selected Activate Later, the Activation Wizard closes and the courtesy period begins. The 
courtesy period enables you to use MapInfo Professional immediately and activate the product 
at a time that is convenient for you. Each subsequent time you start MapInfo Professional, a 
dialog box displays informing you of the time remaining in the courtesy period and giving you the 
opportunity to activate the product. 
You must activate MapInfo Professional sometime during the courtesy period to avoid 
interrupting your work. When the courtesy period ends, you will not be able to use MapInfo 
Professional until you activate it. 

4. If you selected Activate Now, the Select Activation Method dialog box displays on the screen: 
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:

5. Select one of the following activation methods: 
• Automatic Activation– Select this option if you have an Internet connection. The Activation 

Wizard will make a one-time connection with a MapInfo server. Using the serial number and 
access code you provided during the installation, the Activation Wizard will retrieve one of the 
licenses your organization purchased and associate it with your computer. 

• Email Activation– Select this option if you do not have an Internet connection. The 
Activation Wizard will guide you through the creation of an Activation Request file that you 
must then email to Pitney Bowes MapInfo. 

6. Click Next. 
If you selected Email Activation, go to step 7.
If you selected Automatic Activation, the Activation Wizard takes a few moments to transfer the 
activation credentials to Pitney Bowes MapInfo and perform the activation. A MapInfo Activation 
message displays on the screen to tell you that the activation was successful. 
Click OK. The Activation Wizard closes, and MapInfo Professional is ready to use. You are 
finished.

7. If you selected Email Activation, the Verify Activation Credentials dialog box displays on the 
screen:
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Double-check that your serial number and access code are correct. Click Edit if you need to 
make any corrections. 

8. Click Next. The Specify location to save Activation Request file dialog box displays on the 
screen: 

Select a folder in which to save the Activation Request file. Click the Browse button to navigate 
to the desired location. Click OK. The path and filename of the Activation Request file appear in 
the box. The Activation Request contains your serial number and access code, plus information 
that identifies the computer you are activating on. 

9. Click Next. The Save this important Information dialog box displays on the screen. 
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This dialog box provides the information to send your Activation Request file to Pitney Bowes 
MapInfo. The full path and filename of the Activation Request file is displayed in the Activation 
Request File box. The email address to send the file, activation@mapinfo.com, is displayed in 
the Email address box. 
Take a few moments to write down the location of the Activation Request file and email address 
to send the Activation Request file. 

CAUTION: Please do not edit the Activation Request file in any way. If you do, Pitney Bowes 
MapInfo may not be able to process it and your activation will be delayed. 

10. Click OK. The Activation Wizard closes and the courtesy period automatically starts. 
11. Email your Activation Request to Pitney Bowes MapInfo at this address:

activation@mapinfo.com

You can finish email activation when you receive an Activation Response file from Pitney Bowes 
MapInfo. You should receive the Activation Response file within one business day. 

Finishing Email Activation

When you receive the Activation Response file from Pitney Bowes MapInfo, you are ready to finish 
activating MapInfo Professional. 

To finish email activation:

1. Copy the Activation Response file you received from Pitney Bowes MapInfo to an accessible 
folder on your computer and make note of the location. 

2. Open MapInfo Professional. If MapInfo Professional is already open, exit and restart the 
program. A dialog box displays asking you if you want to finish activating MapInfo Professional. 

3. Click Yes. The Process Email Activation Response dialog box displays on the screen. 
4. Click Browse to navigate to the location of the Activation Response file. Click Open in the 

Locate Response file dialog box when you have located the file. 
5. The path and filename of the Activation Response file appear in the box. 
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6. Click Next. 
7. A MapInfo Activation message displays on the screen to tell you that the activation was 

successful. Click OK. The MapInfo Professional Activation Wizard closes, and MapInfo 
Professional is activated and ready to use. You are finished.

Note Once you have seen the confirmation message stating that your product has been activated, 
you can delete the email response file from your system. 

To check the status of your activation, choose Help > About and review the contents of this dialog 
box.

Using MapInfo Professional While You Wait

While you are waiting for Pitney Bowes MapInfo to send you the Activation Response file, you can 
continue to use MapInfo Professional under the courtesy period. To ensure uninterrupted use of 
MapInfo Professional, we encourage you to activate before the courtesy period expires. 

Each time you open MapInfo Professional subsequent to initiating email activation, a dialog box 
displays asking if you want to finish activating MapInfo Professional. When you receive the 
Activation Response file from Pitney Bowes MapInfo you are ready to finish activation.

To continue using MapInfo Professional under the courtesy period: 

1. Click No in the dialog box. 
2. A dialog box displays on the screen that provides information about the courtesy period and asks 

you how you would like to proceed. 
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Select one of the following: 

• Use MapInfo Professional–Select this option if you have not received an Activation 
Response file yet and you want to use MapInfo Professional under the courtesy period.

• Start Activation Over–Select this option if previous activation attempts have failed. 
If you selected Use MapInfo Professional, click Finish. The Activation Wizard closes and 
MapInfo Professional is ready to use under the courtesy period. You can finish the activation at a 
later time. 
If an earlier attempt to activate MapInfo Professional failed, and you selected Start Activation 
Over, click Next. The Activation Wizard restarts, giving you the opportunity to try the activation 
again.

Transferring a Node-Locked License

Node-locked licenses are associated with a particular computer. To use MapInfo Professional on a 
computer other than the one on which you have it activated, and without consuming another license, 
you can transfer your license from one computer to another. For example, you received a new 
computer at work and you want to run MapInfo Professional on the new computer instead of on the 
old one. 

Before making any hardware changes to your PC (such as disk re-formatting) please 
remember to transfer your activated license back to Pitney Bowes MapInfo. After your 
hardware has been changed you may then re-activate your license. 

Note Your organization is limited to two license transfers per year, regardless of the number of 
licenses. 
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Transferring Your License to Another Computer

To transfer a node-locked license:

1. Open MapInfo Professional. 
2. Choose Help > Licensing > Transfer license. The Transfer License Now dialog box displays. 
3. Click Yes. The Select Transfer Method dialog box displays. 

Select one of the following transfer methods: 
• Automatic Transfer–Select this option if you have an Internet connection. Your license will 

be automatically transferred to Pitney Bowes MapInfo. You can retrieve the license by 
activating MapInfo Professional on another computer.

• Email Transfer–Select this option if you do not have an Internet connection. You will be 
guided through the creation of a Transfer Request file, which you must then email to Pitney 
Bowes MapInfo. 

4. If you selected Email Transfer, go to step 6.
If you selected Automatic Transfer, the License Transfer Wizard takes a few moments to 
transfer the license to Pitney Bowes MapInfo. When this process is finished, a message displays 
on the screen informing you that the transfer was successful. 

5. Click OK. MapInfo Professional closes and can no longer be run from this computer. The license 
is now available for you to activate MapInfo Professional on another computer. 

6. If you selected Email Transfer, the Save Transfer Request File dialog box displays on the 
screen. 

Select a folder in which to save the Transfer Request file. Click the Browse button to navigate to 
the desired location. Click OK. 
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7. Click Next. The Save this important information dialog box displays on the screen. 
This dialog box provides the information to send your Transfer Request file to Customer Service.
The full path and filename of the Transfer Request file is displayed in the Transfer Request File 
box. The email address to send the file, activation@mapinfo.com, is displayed in the Email 
address box. 
Take a few moments to write down the location of the Transfer Request file and email address to 
send the Transfer Request file. 

CAUTION: Please do not edit the Activation Request file in any way. If you do, Pitney Bowes 
MapInfo may not be able to process it and your activation will be delayed. 

8. Click OK. MapInfo Professional closes and can no longer be run on this computer unless you 
activate it again. 

9. Email the Transfer Request file to Pitney Bowes MapInfo at the following address: 
activation@mapinfo.com

10. Customer Service will send you an email reply confirming that the transfer was successful. You 
should receive this confirmation within one business day. 

The license is now available for you to activate MapInfo Professional on another computer. 

Uninstall Transfer Options

If you have a node-locked license and you uninstall MapInfo Professional, you have the option of 
transferring the license to Pitney Bowes MapInfo. 

Note Before making any hardware changes to your PC (such as disk re-formatting) please 
remember to return the activated license back to Pitney Bowes MapInfo. After the hardware 
has been changed you may then re-activate your license. 

If you intend to install MapInfo Professional on another computer, transfer the license to Pitney 
Bowes MapInfo so that the license is available. When you install MapInfo Professional on the 
desired computer, you will be prompted to activate the product. 

If you intend to reinstall MapInfo Professional on the same computer, do not transfer the license. 
When you reinstall, you can reuse the same license without activating.

When you begin an uninstall of MapInfo Professional, the Transfer License Now? dialog box 
displays on the screen:

Do one of the following: 

• Click Yes to transfer the license to Pitney Bowes MapInfo. The License Transfer Wizard will start 
and guide you through the transfer process. See Transferring Your License to Another 
Computer on page 25.

• Click No to keep the license on this computer. The uninstall operation continues. When you 
reinstall MapInfo Professional, you can reuse the license without activating. 
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Concurrent Licenses
Concurrent licenses enable you to install MapInfo Professional on any number of computers. A 
license server, installed and maintained by your organization, limits the number of computers that 
can run MapInfo Professional at any given time to the number of concurrent licenses purchased by 
your organization. 

In the concurrent licensing scheme, you must connect to a license server on your network to check 
out a license before you can run MapInfo Professional. Checking out a license is the process of 
obtaining a license from the license server. You will need to supply the license server machine name 
and port number to connect to the license server. You can do this either during installation or the first 
time you run MapInfo Professional. After you have established a license server connection, the 
check out occurs automatically. 

A license server administrator from your organization installs and maintains the license server. The 
license server administrator must also perform the following tasks: 

• Activate the license server to make licenses available for check out.
• Inform users of the license server machine name and port number.

Connecting to a License Server

If your organization purchased concurrent licenses for MapInfo Professional, you will need to 
connect to a license server to run the product. 

To connect to the license server, MapInfo Professional must have the license server name and port 
number. Your license server administrator will provide you with this information.

Connecting During Installation

The installation program will ask you for the license server name and port number. If you know them 
at install time, enter them. When you start MapInfo Professional, you will be connected to the license 
server and a license will be checked out automatically. 

If you do not have this information at the time you install MapInfo Professional, the installation 
program will enable you to continue with the installation without filling in the license server name and 
port number. You will have another opportunity to connect to the server when you start MapInfo 
Professional. 

Connecting After Installation

If you did not specify the license server name and port number during product installation, you will be 
prompted for that information when you start MapInfo Professional. You will also be prompted if 
MapInfo Professional cannot connect to a running license server using the server name and port 
number you provided at install. 
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To connect to the license server after you install MapInfo Professional:

1. Start MapInfo Professional. The Connect to License Server dialog box displays on the screen.

If you have the license server name and port number, proceed with these instructions. If you do 
not, see Starting the Courtesy Period on page 28.

2. Enter the license server name in the Server name box. 
3. Enter the port number in the Port number box. 
4. Click Connect. MapInfo Professional takes a few moments to connect to the license server and 

check out a license. 

When the license is checked out, the Connect to License Server dialog box closes. You are finished. 
MapInfo Professional is licensed and ready to use. After you successfully connect to your license 
server once, a license will be checked out automatically when you start MapInfo Professional. 

Starting the Courtesy Period

If you do not have the license server name and port number, but you want to start using MapInfo 
Professional, you can start a 30-day courtesy period during which you can use MapInfo Professional 
without connecting to the license server. 

To use the courtesy period to run MapInfo Professional: 

1. Open MapInfo Professional. The Connect to License Server dialog box displays on the screen.
2. Click Courtesy Period. A MapInfo Activation message displays telling you that the courtesy 

period started successfully. 
3. Click OK. MapInfo Professional is ready to use under the courtesy period. 

You can connect to the license server and check out a license when you receive the license server 
name and port number from your license server administrator. 
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Connection Failures

Failure to connect to the license server can occur for several reasons. 

First, although you may know the license server name and port number, the license server 
administrator may not have had an opportunity to install it yet. In this case, MapInfo Professional 
cannot find the license server you specified. To use MapInfo Professional, you can start the courtesy 
period, and then connect when you know that the license server has been installed and is running.

Failures can also occur if the license server has been moved to a different computer. In this case, 
you were previously able to connect to the license server, but the license server was moved since 
the last time you used MapInfo Professional. MapInfo Professional is looking for the license server in 
its previous location. If MapInfo Professional cannot connect to the license server at startup, the 
Connect to License Server dialog will display on the screen. See Connecting After Installation on 
page 27 for information. See your license server administrator for the correct license server name. 

Finally, if all licenses have been checked out, you will not be able to run MapInfo Professional. You 
are able to connect to the license server, but you cannot check out a license because they are all in 
use. You will need to wait until a license becomes available before you can check out a license. 

Borrowing a Concurrent License

Some concurrent licenses can be borrowed. Borrowed license enable you to use MapInfo 
Professional when your computer is not able to connect to your license server. For example, if you 
have MapInfo Professional installed on a laptop computer and you are going to be away from the 
office, you can borrow a license to use MapInfo Professional while you are away. Check with your 
license server administrator to find out if your concurrent license includes borrowing. 

When you borrow a license, be sure to specify a borrow period that gives you sufficient time to use 
MapInfo Professional before the license expires. If the license expires before you have an 
opportunity to return it, the license is automatically returned to the license server. MapInfo 
Professional is unusable until you can connect to your network again and check out a license.

To borrow a license, the computer that you want to put the borrowed license on must have MapInfo 
Professional installed and be connected to the license server. 

To borrow a license: 

1. Open MapInfo Professional. 
2. Choose Help > Licensing > Borrow license. The Borrow MapInfo Professional License dialog 

box displays on the screen. 
3. Specify the number of days that you want to borrow the license. You can specify from one to 365 

days. 
4. Click Borrow License. After a few moments, MapInfo Activation message displays on the 

screen to tell you that the license was borrowed from the server successfully. 
5. Click OK. 

You can use MapInfo Professional on this computer while not connected to your network for the 
borrow period that you specified. 
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Returning a Borrowed License

To return a borrowed license, you must reconnect the computer that is using the borrowed license to 
your network. If it is not connected, the Return borrowed license command will not be available.

Note Before making any hardware changes to your PC (such as disk re-formatting) please 
remember to return your activated license back to Pitney Bowes MapInfo or to the License 
Server. After your hardware has been changed you may then re-activate your license. 

To return a borrowed license: 

1. Reconnect the computer to your network. 
2. Open MapInfo Professional. A dialog box displays to tell you on what date the borrowed license 

is going to expire. 
3. Click OK. 
4. Choose Help > Licensing > Return borrowed license. The Return borrowed license to license 

server dialog box displays on the screen.
5. This dialog box explains how a license is returned. Click OK. 
6. A MapInfo Activation message displays on the screen to tell you that the license has been 

returned to the license server. 
7. Click OK. 

Silent Installation Procedures for System Administrators
Silent installations allow you to repackage MapInfo Professional for deployment within your 
company so your users do not have to enter user- or company-specific information, path information, 
a serial number, or an access code. 

Note You may also be interested in reviewing the new Workgroup Installation Supports File 
Sharing on page 76 to use this installation model for deploying MapInfo Professional.

The MapInfo Professional installation setup.exe indicated in the steps below can be found on the 
installation CD (d:\) in this directory:

\Install\MI_PRO\DISK1

In general, the silent installation process goes like this:

1. Place the installation CD in the target computer’s disk drive.
2. From the command line on the target computer, type: 

[drive and path to setup exe]:setup.exe /s /v"[Parameters for MSI]" for
a silent installation"

where PARAMETERS for MSI are the parameters you set to populate the msiexec .
For example:
d:"\Install\MI_PRO\DISK1\setup.exe /s /v"/qb
INSTALLDIR=\"[PathTo]\MapInfo\OtherThanStandard\Professional 9.5\"
USERNAME=\"MyUser\" COMPANYNAME=\"MyCompanyName\"
PIDKEY=MySerialNumber ACCD=MyAccessCode"

Note The command line parameters for the installer can not contain "~","/". 
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The parameter /qb tells the msiexec command to launch the install with a basic interface. That does 
not require any user action and allows the user to respond to the UAC in Vista.

There should be no space in between Variable=Content. A space is used as a separator in between 
parameters.

Parameters for user information:

USERNAME=User Name
COMPANYNAME=Company Name

Parameters for installation target information:

INSTALLDIR=Install Directory
ADDARC=True (Use this parameter to install ArcLink with application, not installed by default)
NOMDAC=True (Use this parameter to decline the installation of MDAC 2.8, installed by default)
CRYSTALRINST=False (Use this parameter to decline the installation of Crystal Reports, 
installed by default)

Parameters for licensing information:

PIDKEY=Serial Number
ACCD=Access Code
LSNAME=License Server Name
LSPN=License Server Port Number

Parameters for activating node lock and distributed licenses silently:

ACTLIC=True - for silent automatic NODE LOCK and DISTRIBUTED activate licenses
RETLIC=True - for silent return licenses
LICLOG=Filename for log files
BORROW=#days or True (If no specific  number of days are entered, True is a valid input and 
results in a # of days) 
SDRLYN=False (Use this parameter to see no license transfer dialog when the user uninstalls. 
The license stays on the system if not RETLIC=True).

Note Parameters ACTLIC and RETLIC are False by default. 

For concurrent licenses the parameters for the license server name and license server port number 
must also be included: 

1. Place the installation CD in the target computer’s disk drive.
2. From the command line on the target computer, type: 

"d:\Install\MI_PRO\DISK1\setup.exe /s /v"PARAMETERS"
where PARAMETERS are the parameters you set to populate the msiexec.
For example:
"\Install\MI_PRO\DISK1\setup.exe /s /v"/qb 
INSTALLDIR=\"[PathTo]\MapInfo\OtherThanStandard\Professional 9.5\"

Note All of the Microsoft supported parameters for working with the MSIEXEC command are 
documented on the Microsoft web site. Search the term "MSIEXEC command line 
parameters" to find this detailed information.
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Look for the type of installation you want to perform from the options below and follow the 
corresponding instructions. In each of the install scenarios described below, the serial number and 
access code parameters are given in the following format: 

• PIDKEY=MI##############

• ACCD=######

Substitute the appropriate serial number and access code when you perform the silent install.

Installing MapInfo Professional Silently on Vista Operating System

You cannot perform a completely silent install of MapInfo Professional on Windows Vista computers. 
The command-line options /q and /qn do not work on Vista. These options turn off the user interface 
during the installation, which suppresses the Windows Vista User Access Control (UAC). Users 
must interact with the UAC to provide the necessary credentials to run the installation as an 
administrator. If the user interface is turned off, the installation is terminated without warning 
because the UAC cannot gather the appropriate credentials.

To work around the problem, use the /qb option in the command line when you run the silent install. 
This option gives the installation a basic user interface and allows the UAC to display on the screen. 

To perform a silent install on a Windows Vista computer using the /qb option: 

1. Place the installation CD in the target computer’s disk drive.
2. From the command line on the target computer, type: 

"d:\Install\MI_PRO\DISK1\setup.exe" /s /v"/qb USERNAME=\"MyUser\"
COMPANYNAME=\"MyCompanyName\"PIDKEY=MI############## ACCD=######" 

where: 
PIDKEY=MI############## is the product serial number
ACCD=###### is the access code

3. When User Access Control displays on the screen, click Allow. 

For concurrent licenses, the license server name and port number parameters must be included: 

LNAME="LicenseServerName"
LSPN="LicenseServerPortNumber"

Substitute the appropriate license server name and port number when you perform the silent install.

Installing ArcLink Silently with an Initial Dialog Box Only

To initiate a silent install with an initial dialog box that installs ArcLink:

1. Place the installation CD in the target computer’s disk drive.
2. From the command line on the target computer, type: 

"d:\Install\MI_PRO\DISK1\setup.exe" /s /v "/qb PIDKEY=MI##############
ACCD=###### ADDARC=TRUE"

This process runs the Smartupdate at end of installation. If you do not want the Smartupdate to run, 
type:

set RUNSU = FALSE

at the end of the command line.
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For concurrent licenses, the license server name and port number parameters must be included: 

LNAME="LicenseServerName"
LSPN="LicenseServerPortNumber"

Substitute the appropriate license server name and port number when you perform the silent install. 

Installing Data 
To help you get started, Pitney Bowes MapInfo provides you with some United States-based and 
world-wide maps you can use as a background to your data. Use these instructions to install this 
free data.

To install the free data provided with MapInfo Professional:

1. Choose Install Products from the CD Browser.
2. Choose Free Data to display the MapInfo Professional Data screen. In this screen, you can also 

review the data specifications, access new data over the web and learn about what data is 
available from Pitney Bowes MapInfo Corporation.

3. Choose Install Free Data. The Welcome screen displays. 
4. Choose Next to continue. The License Information screen displays. 
5. Choose Yes to accept the terms of the agreement and to continue the installation process. The 

Choose Destination Location screen displays. 
6. Select the product for which you will be installing the data and click Next to continue:

• MapInfo Professional 
• MapInfo Run Time

7. Specify the directory where the data will be installed. Use the Browse button to select a directory 
if necessary or accept the default directory. Click Next to continue.

8. Choose one of these options: 
• Custom Install: Choose which datasets to install. Select the check box beside each dataset 

you want to install. The size of each dataset displays, as well as space required and space 
available. 
To see the subcomponents of the data you selected, click Change.

• Typical Install: Install all datasets. 
Choose Next to continue. Respond Yes to the “Would you like setup to display workspace 
Icons” prompt if you want to create an icon for each data set you choose. 

9. The Select Program Folder screen displays if you chose to set up Workspace icons. Select the 
program folder where the icons will be created. Choose Next.

10. The Start Copying Files screen displays. Review the selections you have chosen and click 
Back to return to any screen to change your selections. When you are ready to begin the 
installation, click Next.

11. The Setup Complete dialog box displays; click Finish. 
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Getting More Data

To learn more about our data products, click the Get More Data option in the MapInfo Professional 
Data screen during the Data Installation process or click MapInfo Data Products on the Web in the 
Help Menu. If you have a Browser installed, you will be automatically connected to Pitney Bowes 
MapInfo Corporation’s web site, where we provide detailed information about our World Wide Data 
Products. We have over 350 data products to choose from—products that provide both reliable and 
current information.

Installing Related Programs, Hardware, and Resources
This section contains the instructions for installing the ECW Compressor, the Blue Marble GPS, and 
the documentation associated with MapInfo Professional. We also include information about the 
Microsoft IntelliMouse and how to use it.

Installing the ECW Compressor

The ECW raster handler allows you to open and display raster images compressed in the ECW 
format. We recommend that you exit all Windows programs before installing.

1. Choose Install Products from the MapInfo Professional CD Browser.
2. Choose ECW Compressor. The Welcome screen displays. Choose Next to continue the 

installation process.
3. The Software License screen displays. Choose Yes to accept the terms of the agreement and to 

continue the installation process.
4. The Choose Destination Location screen displays. Specify the directory where ECW 

Compressor will be installed. 
5. The Select Program Folder screen displays. Select a folder. Choose Next to continue. 
6. The Setup Complete screen displays: choose to display the ReadMe file and/or create a shortcut 

on your desktop. Choose Finish. 

Using the Microsoft IntelliMouse™ to Move Around the Windows 

MapInfo Professional supports the Microsoft IntelliMouse™ as follows:

Document Scrolling: In the Map, Layout, Browser, and MapBasic windows, hold down the Ctrl key 
and move the wheel to scroll the document vertically; the effect is the same as clicking on the arrow 
at the end of the scroll bar.

Document Panning: In the Map and Browser windows, hold down the Wheel button on the 
IntelliMouse™ and move the mouse to pan the document. Release the button to end the panning. 
There are three panning speeds. The speed of the panning is based on the cursor’s distance from 
the starting point, indicated by the origin mark. In the Map window, the distance moved at each 
speed is a percentage of the zoom distance. 

For example, the amount to move at slow speed is. 005 * ZoomDistance, medium speed is. 01 * 
ZoomDistance, and super speed is .1 * ZoomDistance. In the Browser, the window is scrolled by 1, 
3, and 7 lines or columns for slow, medium and super speeds. When the cursor is within 15 pixels of 
the starting point, there is no panning.
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AutoScroll: In the Map and Browser windows, click and release the Wheel button to activate 
AutoScroll. When the mouse cursor is moved away from the starting point the document starts to 
scroll in whatever direction you move the mouse. When the cursor is returned to the starting point, 
scrolling stops. AutoScroll is turned off by any mouse click or key stroke. AutoScroll is also turned off 
when MapInfo Professional loses the focus, for example, when you Alt-Tab to another application. 

Zoom: In the Map and Layout windows, move the wheel forward to zoom in on the document. Roll 
back the mouse wheel to zoom out on the document. The wheel has a series of settings; each “click” 
is the same as one click with a zoom tool. The mouse wheel does not recenter the view. There are 
other keyboard commands that allow you to zoom in and out more precisely.

Installing Global Positioning Software (GPS)

To install Global Positioning Software from Blue Marble: 

1. From the CD menu, click Install Products and then Free Utilities.
2. Click Install GPS Support. You will be prompted to exit all applications before installing. Choose 

OK.
3. The MapInfo Special Edition dialog box displays. Choose OK.
4. The Select Destination Location screen displays. Specify the directory where GPS will be 

installed.
5. The Software License screen displays. Choose YES to accept the terms of the agreement and to 

continue the installation process.
6. The Add to the Start Menu dialog box displays: click Yes to add a shortcut to the Start menu.
7. The ReadMe displays; choose OK to exit the ReadMe. 

Installing the Online References

MapInfo Professional provides the following online reference documents: MapInfo Professional User 
Guide, MapBasic Reference Guide, Crystal Reports User’s Guide, ArcLink, and EasyLoader 
documentation, as well as the Adobe Acrobat Reader. These documents are installed in the 
Documentation subfolder of your installation directory.

Note If you have any questions about the use of the Acrobat Reader, contact Adobe support at 
www.Adobe.com.

Troubleshooting your Installation
The Installer must be run from a drive with a letter such as G: and not from an explicit UNC path. For 
example, you might have the MapInfo Professional CD in your computer as USERSPC. Other users 
may share this device as USERSPC; however, it would not contain a drive letter. The MapInfo 
Professional Installation program requires a drive letter. 

To remedy this situation, map your network drive to a specific drive letter: 

1. In Windows Explorer, right-click the shared directory or CD-ROM that contains the MapInfo 
Professional SETUP.EXE and select Map Network Drive. 

2. Choose a drive letter to map. 
3. Run the Installation Program again from the newly mapped drive letter. 
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Modifying or Removing MapInfo Professional
Use the Program Maintenance feature of the CD Browser to modify, repair, or remove MapInfo 
Professional.

To access Program Maintenance:

1. Click Install Products from the MapInfo Professional CD Browser.
2. Click MapInfo Professional. The Welcome screen displays. Choose Next. The Program 

Maintenance screen displays.
3. Choose modify, repair, or remove MapInfo Professional based on your needs. 

• Click Modify to display the Custom Setup dialog box. 
• Click Repair to repair installation errors in the program.
• Click Remove to remove an existing copy of MapInfo Professional from your system. The 

installer displays the Remove the Program dialog box. Click Remove to uninstall the 
product’s programs from your system.

You can also access the Program Maintenance screen from the Start menu by clicking Control 
Panel and then Add/Remove Programs and finally MapInfo Professional.
For information on node-locked license transfer options at uninstall, see Uninstall Transfer 
Options on page 26.

Controlling Advanced System Settings 
MapInfo Professional has some advanced system settings that cannot be configured through a 
dialog box. These settings allow you to control several low-level, technical aspects of how MapInfo 
Professional runs. Most users do not need to worry about these advanced settings.

For example, MapInfo Professional has a Dynamic Data Exchange (DDE) time-out setting, which 
controls how long MapInfo Professional tries to communicate with other applications during DDE 
communications. If you run a MapBasic application, and that application encounters time-out errors 
during DDE, you may want to increase the DDE time-out setting. To modify one of MapInfo 
Professional’s advanced system settings (such as the DDE time-out setting), use this procedure.

Modifying the Windows Registry

MapInfo Professional stores system settings in the Windows registry. To edit the Windows 2000 
registry, use the REGEDT32 program.

CAUTION: Be very careful when editing the registry; damaging the registry can cause 
serious problems in your operating system.

For example, to set MapInfo Professional’s Dynamic Data Exchange (DDE) time-out setting, locate 
the following key in the registry:

HKEY_LOCAL_MACHINE\SOFTWARE\MapInfo\MapInfo\Common

Within that key, edit the DDeTimeout value. If there is no value by that name, create a new value of 
type string, and assign the name DDeTimeout to the value. Set the value’s data to be a number, 
representing the number of milliseconds (for example, enter 30000 to specify a time-out of 30 
seconds). For more on editing the registry, see the online help for REGEDIT or REGEDT32.
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Descriptions of Advanced Registry Settings 

This section describes advanced settings that are stored in the registry.

DDeTimeout = number
This setting controls MapInfo Professional’s time-out setting in DDE conversations where MapInfo 
Professional is the client (the application that initiates a conversation). The number represents 
milliseconds. The default value is 10,000 milliseconds (ten seconds). If you run a MapBasic 
application that attempts to initiate a DDE conversation, but the conversation fails because the 
server application does not respond within the time-out period, you may need to increase the 
DDeTimeout number.

OffscreenBitmap = number
The number is 0 (zero) or 1 (one). A value of 1 (the default) indicates that MapInfo Professional will 
process off-screen bitmaps when drawing a map. This means that if you cover a Map window, and 
then bring the Map window to the front again, the map redraws instantly. If you set this setting to 
zero, MapInfo Professional will not process off-screen bitmaps. This means that when you bring a 
Map window to the front, MapInfo Professional will redraw the map. If you are using a video driver 
that is problematic, and encounter video problems with Map windows, you may eliminate those 
problems by setting the OffscreenBitmap number to 0.

MaxFiles = number
This setting must be an integer from 10 to 507, indicating how many files MapInfo Professional can 
open simultaneously. This setting does not limit the number of tables you can open, but it does limit 
the number of tables you can edit at one time (the number of tables that have unsaved edits). The 
default value is 29. If you need to work with more files simultaneously, set number to 507.

MaxORACLETILES = number
A value from 0 = unlimited tiles to infinity.

Improving Performance for MapInfo Professional 

To improve MapInfo Professional’s performance, you can increase the speed of the processor in the 
machine. A video accelerator card will increase the speed of the redraw. It will not speed up the 
initial draw of the map, but all subsequent redraws will be faster. A faster disk cache will also 
improve performance, as will adding memory.

Controlling the Location of Application Data Files During Installation 
By default, the setup program for MapInfo Professional installs application data files to locations that 
make sense for the typical user. After installing the product, the user is free to move one or more of 
the application data files to another predefined location and MapInfo Professional will find that file. 
For example, the administrator of a machine might move MAPINFOW.PEN from the per user area 
(its default location) into the install directory so all users on that machine will share the same set of 
pens. For IT personnel responsible for a large number of MapInfo Professional installs it is not 
practical to manually move application data files to realize the desired configuration. 

To solve this problem, create a setting file, MODE.INI, to specify the location of application data files 
prior to installing MapInfo Professional. 

1. Copy the installation files to a read-write location.
2. Create a MODE.INI file in the root directory of the installer. 
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3. Open MODE.INI into any text editor.
4. Edit MODE.INI, modifying the code associated with the application data file/folder whose location 

you wish to change.
5. Install MapInfo Professional.

The following is a list of predefined locations for application data files supported by MapInfo 
Professional, and the corresponding numeric code to be used in MODE.INI.

The following is a list of application data files/groups and their default locations:

Code Description Location

1 per user, roaming <Current User>\Application Data

2 per user, not roaming <Current User>\Local Settings\Application Data

3 per machine <All Users>\Application Data

4 program directory <Install Dir>

Filename Default Location

MAPINFOW.CLR per user, roaming

MAPINFOW.PEN per user, roaming

MAPINFOW.FNT per user, roaming

MAPINFOW.ABB program directory

MAPINFOW.PRJ program directory

MAPINFOW.MNU program directory

CustSymb per user, roaming

ThmTmplt per user, roaming

GraphSupport per machine
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MODE. INI File Example

Create a text file with the following syntax:

GraphSupport = 3
CustSymb = 1
ThmTmplt = 1
MAPINFOW.CLR = 1
MAPINFOW.FNT = 1
MAPINFOW.PEN = 1
MAPINFOW.ABB = 4
MAPINFOW.PRJ = 4
MAPINFOW.MNU = 4

Removing MapInfo Professional from your System using Control Panel 
Remove MapInfo Professional by accessing the CD Browser, Program Maintenance screen, or by 
choosing the Add/Remove Programs option in the Control Panel in Windows 2000 or Windows XP. 

• For more information, see Removing MapInfo Professional from your System using the CD 
Browser in the Help System.

Configuring the MapInfo Professional Preferences
Preferences allow you to change a number of default settings, enabling you to customize certain 
aspects of the program’s behavior. Preference files are stored on a per-user basis. As you gain 
experience with MapInfo Professional®, you will probably want to change some of these settings. 
This chapter discusses the various preferences and what they control.

Here is a brief description of the preference categories: 

System Settings – Controls what information is copied to the clipboard, color defaults, aspect ratio, 
paper and layout units, the number of Undo objects permitted, how symbol types used prior to 
version 4.0 are drawn, and how MapInfo Professional handles 2-digit years.

Map Window – Sets the default Map window options; moving duplicate nodes; snap tolerance; units 
for distance and area; display of scroll bars in the Map window; display of degrees in either decimal 
or degrees, minutes, seconds form; and the display of InfoTips. 

Layout Window - Sets the Layout window preferences to display Rulers, Page Breaks, and to 
determine the display options of frame contents.

Legend Window – Sets the legend frame default settings.

Startup – Controls whether the program saves the MAPINFOW.WOR upon exiting and loads it upon 
start up; whether queries are saved in workspaces; and the display of the Quick Start dialog box 
upon startup.

Address Matching – Controls the house number placement when specifying street addresses.
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Directories – Specifies default directories for opening and saving tables, workspaces, MapBasic 
programs, import files, ODBC SQL queries, theme templates, graph support files, saved queries, 
new grids, and Crystal Report files. Also specifies the directories MapInfo Professional searches for 
tables without fully qualified paths referenced in workspaces or MapBasic programs.

Output Settings – Controls the on-screen display of a raster file, the printer output, and exporting 
choices.

Printer – Controls which printer information is used for all new windows. This printer can be the 
Windows default printer, or a printer you designate as your MapInfo Preferred printer. This choice 
can be overridden on a per window basis using either the Print or Page Setup dialog boxes.

Styles – Sets the default object styles for region, line, symbol, and text objects.

Web Services – Sets refresh, timeout values, server options and other default settings for Proxy 
Servers, WMS, WFS, Geocode Servers, and Drivetime server web services.

Image Processing - Sets the rules for raster reprojection allowing you to choose whether 
reprojection is allowed, when, and allows you to select resampling options.

Setting the Preferences
To set a preference:

1. On the Options menu, click Preferences to display the Preferences dialog box.

2. Click one of the preference buttons to display the specified preferences dialog box.
3. Set your preferences in that dialog box and click OK to save them and return to the Preferences 

dialog box.
4. Click OK to close the Preferences dialog box.

What follows in this section are details to assist you in setting your preferences.
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Setting your System Preferences 
Use the System Settings Preferences dialog box to control the default settings that affect how 
MapInfo Professional interacts with your system.

To set your system settings preferences:

1. On the Options menu, point to Preferences and click System Settings to display the System 
Settings Preferences dialog box.

2. Select the appropriate system preferences for your implementation of MapInfo Professional. 
Click OK to save them.
Setting the Units
• Paper and Layout Units — Specify the Paper and Layout Units used when you measure the 

size of objects in a Layout window and the size of paper in the Print dialog boxes. The 
default is set to inches. You can choose: inches, picas, points, millimeters, and centimeters.

• Distance Units — Specify the units that you want to use to indicate distance in the 
application by selecting US Survey feet, yards, rods, chains, miles, nautical miles, 
millimeters, centimeters, meters, or kilometers. 

• Area Units —Specify the area units you want to use in the application by selecting square 
inches, square links, square feet, square yards, square rods, perches, square chains, 
rods, acres, square miles, square nautical miles, square millimeters, square 
centimeters, square meters, hectares, or square kilometers.

Copying to the Clipboard
• Copy Text/Bitmap/Metafile to Clipboard — Click the Copy to Clipboard check boxes to 

specify whether to copy text, bitmap, and metafile items to the Clipboard. All three are copied 
to the Clipboard by default. Clear the appropriate check box(es) to prevent the item from 
being copied to the clipboard.
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Setting the Undo Options
• Number of Objects — You can only undo the last action. Set this option to the number of 

objects in the last action you want the system to undo. For example, if you moved 10 objects 
at the same time and enter 10 in this field, MapInfo Professional restores all 10. 

Note You cannot use the Undo capability for the following operations: Revert, Save, Save As, 
or Modify Table, or any operations whose effects are primarily cosmetic.

The default is 10 objects. You can set it from 0 to 800. Setting the number of objects to 0 
deactivates the system. After you use the Undo option, the system toggles to Redo.

• Memory Size for Undo — Type the number of bytes of memory you want to set aside for the 
Undo feature. This entry is set to 1,000,000 bytes by default. You can enter up to 10,000,000 
bytes into this field. Increasing this entry may result in slower response time.

Setting the Color Defaults
Select one of the Color Defaults preferences described below to control how MapInfo 
Professional shades thematic map layers.
• By default, Monitor Setting is selected. MapInfo Professional uses the color settings of the 

monitor to shade the map when this option is selected.
• Click the Black & White radio button if you are using a color monitor and want to shade your 

thematic map in gray-scale.
• Click the Color radio button if you are using a black and white monitor and want to print a 

thematic map in color on a color printer.
Display Pre-Version 4 Symbols using the True Type font — Select this check box to indicate 
how you want to draw symbols from early versions of MapInfo Professional (before 4.0). Select 
this check box to draw vector symbols with characters from the MapInfo Professional Symbols 
font. By default, vector symbols are drawn.
Window Export and Clipboard Resolution — To set the image resolution for exporting and 
Clipboard purposes, type the resolution in this field. MapInfo Professional uses this preference 
whenever you copy windows to the Clipboard, export your work to metafile and raster formats 
and the Save Window As export process as well. If you do not set this resolution manually, the 
product assumes 96 DPI. The maximum setting for this field is 1200 DPI.
Display Vertical Mapper grd files as — Use this option to determine how to display Vertical 
Mapper GRD files within MapInfo Professional. These options allow you to display your Vertical 
Mapper GRD maps as grid files and not as raster files. Vertical Mapper creates GRD\TAB files 
that display using the raster handler. This preference contains a Grid option, so that Vertical 
Mapper grid files use the Info tool and displays file information in 3D windows.
• Click Grid to display GRD files as grid files and get the added support of the MapInfo 

Professional toolbar features.
• Click Raster to display the GRD files as raster images.
• Click Default to treat the GRD files as rasters or grids depending on existence of the 

Rasterstyle 6 1 code in the TAB file. If the code does not exist, the file opens as a raster file, 
if the code does exist, the file opens as a grid file. 
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Date Window for 2 Digit Years — Select the appropriate Date Window for 2-Digit Years option 
for your purposes:
• Click the Turn date windowing off radio button to use the current century for all 2-digit 

years. This option is selected by default.
• Click the Set date window to radio button to refer to dates in both the current century and 

the previous century. You need to use this setting if your data uses dates in the 1900s.
For example, if you type the number 30 in the Set date window field, 2-digit years from 00–
29 are set in the 21st century (2000-2029), and 2-digit years from 30–99 are set in the 20th 
century (1930-1999). 

Setting the Aspect Ratio Adjustment
• Aspect Ratio Adjustment — Select the Aspect Ratio Adjustment options so that your map 

maintains the appropriate aspect ratio on your screen. Enter the dimensions of your screen in 
these fields.

Setting your Map Window Preferences 
The Map window preferences control the default settings for any new Map window created in 
MapInfo Professional. You can override some of these preference settings for the current Map 
window in the Map Options dialog box (on the Map menu, click Options). These include the settings 
for resizing Map windows, specifying distance/area calculations, and displaying coordinates in 
degrees, minutes, seconds.

To set the Map Window preferences:

1. Choose Options > Preferences > Map Window to display the Map Preferences dialog box.

2. In the Display tab, select from these options:
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• Set the When Resizing Map Window options to control the default behavior of Map windows 
when you resize them. Select one of these options:
• Click the Fit Map to New Window to draw the map to fit the resized window. You see the 

same view of the map that you saw before you resized the window. This is the default setting.
• Click the Preserve Current Scale button to change the view of the map when the Map 

window is resized. As you shrink or enlarge the window, you will see a smaller or larger area 
of the map. 

This setting does not affect Map windows that are already open. To override the preference 
settings for the currently open Map window, make different selections in the Map Options dialog 
box. 

• Select the Apply Clip Region Using settings to specify how you want the product to clip 
regions. Select one of these three choices:
• Windows Device Clipping (all objects) – The clipping is controlled by the Windows Device 

Display. All objects (including points, labels, text, raster and grid images) will be clipped at the 
Clip Region boundary. This is the default setting.

• Windows Device Clipping (no points, text) – Use this method to emulate the Erase 
Outside clipping method. All objects are clipped using Erase Outside except points and 
labels. Points and labels will be completely displayed only if the point or label point lies inside 
the Clip Region object. Text objects, raster files, and grid files always display and are never 
clipped. 

• Erase Outside (no points, text) – This method uses the Erase Outside functionality. The 
Clip Region object is the Cutter object, and all other objects are Target objects for this 
operation. All objects are clipped using Erase Outside, excepts points and labels. In addition, 
points and labels will be completely displayed only if the point or label point lie inside the Clip 
Region object. Text objects always display and are never clipped. 

• Other display options include
• Scrollbars — To display scrollbars, select the Scroll Bars check box. By default, MapInfo 

Professional does not display scrollbars in Map windows.
• Autoscroll — To scroll the layout automatically, select the Autoscroll check box.
• Show InfoTips — To display one or two word tips when you cursor over a button, select the 

InfoTips check box. By default, MapInfo Professional displays InfoTips. Clear the Show 
InfoTips check box to deactivate their display.

• Show ToolTips in Layer Control Dialog — To display detailed layer information in the Layer 
Control dialog box, select this check box. If you do not want to see this level of detail, clear 
this check box. 

• Automatic Raster Zoom Layering — To choose the default mode for automatic zoom 
layering for raster layers, select this check box. Raster zoom layering is turned on by default.

• Automatic Grid Zoom Layering — To choose the default mode for automatic grid zoom 
layering when adding a grid layer to the map, select this check box. Automatic Grid Zoom 
Layering is turned off by default.

• Use Cartographic Scale — To display your maps in Cartographic Scale automatically. 
When you make this change, the options that display in the Change View, Map Print Options 
and Frame Object dialog boxes use the cartographic scale on which the selected map is 
based and a scale indicator displays in the Status Bar.

• Draw Layers Under Themes — This option sets the default behavior for the Replace Layer 
Style check box in both the Ranges and Individual Value Theme dialog boxes. Select this 
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check box to clear the Replace Layer Style check box by default. Clear this check box to 
select the Replace Layer Style check box by default. 

• Automatically Open Default Theme — This option saves the theme to the table’s metadata 
so that the theme displays each time you open the table. This check box is cleared by 
default. 

• Enable Hardware Acceleration for 3DMap Windows — Select this check box to use your 
video card acceleration capability to display 3DMaps. Clear the box to display the 3DMap 
without using your video card acceleration capability. Turning the acceleration off reduces 
performance, but it avoids failure with certain graphic adapters and drivers.

• Handler for New Grids — Select the output grid file format. By default, MapInfo Professional 
uses the MapInfo Professional handler (*.MIG). The available formats depend on which grid 
handlers are installed. When you change the grid file format, the file extension on the grid file 
name changes to reflect the selected format. 

3. In the Editing tab, select from these options:
• Set the Warn Prior to Loss options to display warning messages before you leave the currently 

open map window and lose cosmetic objects, map labels, and thematic layers you have created. 
After the warning, you can save these objects, labels and layers as part of a table or workspace. 
These boxes are selected by default.
You can turn off the display of these warning messages by clearing the desired check boxes 
from the Warn Prior to Loss of group.

• Select the Move Duplicate Nodes in settings to specify whether MapInfo Professional will move 
duplicate nodes when you use the Reshape command (on the Edit menu, click Reshape) to edit 
objects that are adjacent to each other, such as regions. Select one of these options:
• Select the None of the Layers button to prohibit the product from moving duplicate nodes. 

This is the default setting
• Select the Same Layer button to move duplicate nodes that are in the same layer when one 

of the connected nodes is moved. 
• Digitizing Options include:

• Display Snap Radius — Select this option to set the Snap Tolerance and Auto Node 
Tolerance to make the snap radius larger or smaller. If you clear the Display Snap Radius 
option, the radius does not display when the snap mode is turned on.

Type the appropriate Snap Tolerance and Auto Node Tolerance settings to specify the default 
tolerance in pixels within which Snap to node and Auto Node features operate. You use these 
settings when you draw objects (click the S key to turn Snap to node on). The default is 5 pixels. 
Enter a smaller value to obtain a tighter tolerance, and avoid snapping to other objects’ nodes as 
you draw. Enter a larger value to obtain a looser tolerance, when you want to snap to a node 
even though you are relatively far away from it. 
For more information about Snap Tolerance, see Using “Snap To” to Select Nodes and Centroids 
in the Help System. 

• Find Selection Options include:
• Zoom on Find Selection — Select this option to zoom to the selection each time you 

perform a Find Selection for single and multiple objects. Clear this check box to prevent 
zooming when performing a Find Selection.

• Find Selection after Paste — Select this option to turn on the Find Selection feature in the 
Map window only after you Paste an object. If you have an active Browser, and the selection 
is in that Browser window, the browser still scrolls to the selection. Clear this check box to 
prevent zooming after pasting an object.
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4. In the Projection tab, select from these options:
• Table Projection — To set the default projections for the current map, designate a default 

table projection for creating new tables, importing GML 2.1, MIF, MBI, and IMG files, and for 
Choose Projection options in dialog boxes. 

Note You can override the table projection defaults by accessing the Choose Projection 
button throughout MapInfo Professional except when you use the Universal Translator, 
ArcLink, or when you import DXF files.

• Session Projection — To set the option to designate a default MapBasic projection for 
returning coordinate values using a MapBasic window or Update Column. Compiled 
MapBasic applications are not affected by this preference. 

• To change the format in which coordinates display, select one of the options in the Display 
Coordinates group. You can select only one:
• Decimal Degrees — By default, MapInfo Professional displays coordinates in decimal 

degrees. MapInfo Professional displays coordinates of objects in the Object Info dialog 
boxes, and of the cursor location in the status bar if that display option is selected. 

• Degrees, minutes, seconds — Choose this option to display your Map using the degree, 
minute, seconds format.

• Military Grid Reference System — Choose this option to display your Map using the 
Military Grid Reference System format. Coordinates are converted to the Military Grid 
Reference System format using the World Geodetic System (WGS) of 1984 Ellipsoid.
To override this preference in individual maps, use the Map Options dialog box (on the Map 
menu, click Options). Overrides to the default coordinate setting will be saved to your 
workspace.
Selected in either the Map window preferences or the Map Options dialog boxes, the format 
will display in the status bar, but not in the Object Info dialog boxes. If you display any Object 
Info dialog box for an object on a map that uses the Military Grid Reference System, the 
coordinates will be displayed in decimal degrees. 

5. Select the Distance/Area using settings to specify the default type of distance/area calculation 
that MapInfo Professional uses for new Map windows.
• Spherical — The Spherical calculations measure distance according to the curved surface of 

the Earth. Spherical is the default. The data is first converted to Latitude/Longitude and then 
a calculation is produced. Lat/Long data will always use spherical calculations.

• Cartesian — The Cartesian method performs calculations on data projected onto a flat 
plane. Cartesian coordinates (x,y) define the position of a point in two-dimensional space by 
its perpendicular projection onto two axes which are at right angles to each other. Long/Lat 
projections cannot use Cartesian calculations.

Note To specify a calculation method for the currently active Map window, use the Map Options 
dialog box (on the Map menu, click Options). 

6. Click OK to save these settings and return to the Preferences dialog box.
7. Click OK to close the Preferences dialog box.
• For more information, see Scrolling through a Map, Specifying Options in a Map, Changing the 

Default or Preference Setting for Calculations, Centering a Map Using Military Grid Reference 
System (MGRS) Coordinates, and Setting Default Clip Region Options topics in the Help 
System.
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Setting your Layout Window Preferences
To set the global default preferences for Layout windows:

1. Choose Options > Preferences > Layout Window to display the Layout Window Preferences 
dialog box.

Use this dialog box to set the preferences for Layout windows. Completing the entries 
in this dialog box ensures that your layouts will have a uniform look and feel.

2. Complete the selections in this dialog box and click OK to save your Layout window preferences.

Show Rulers
Select this check box to display rulers in your Layout window. Rulers can be useful to help 
you line up elements of your layout on the page. This option is selected by default.

Show Page Breaks
Select this check box to display the page breaks in your Layout window. Showing the page 
breaks ensures that the elements of your layout are consistent from page to page. This 
option is selected by default.

Show Frame Contents
The options in the Show frame contents box allow you to specify when the contents of frames 
display. 

Always
Allows you to have the contents of a frame display all the time even when it is not active. 

For example, if you are changing the contents of a Map window that is also in the layout, you 
might want the Always option. That way you can see the effect of the layout as you make 
your changes. This option is selected by default.

Only when Layout window is active
Allows you to display the contents of a frame only when the Layout is the active window.

Never
Allows you to display only the file name and frame type, even when the Layout is the active 
window. For example, choose Never when you are resizing and repositioning frames. That 
way the contents of each frame will not redraw every time you make a change.
Supplement 47



Configuring the MapInfo Professional Preferences
Prompt to Save Workspace Prior to Close
When this check box is selected, MapInfo Professional prompts you to save before you close 
windows with layout changes. Clear this check box if you do not want to be prompted to save 
your changes. This option is selected by default to prevent accidental loss of information.

Note The prompt only displays if there are changes to the open Layout and Legend 
windows or when the Layout and Legend windows are new.

3. Click OK to save your preference. 

Once you set these preferences, MapInfo Professional sets these options automatically whenever 
you create a new Layout window. To reset these options for a particular layer locally, select Layout > 
Options to display the Layout Display Options dialog box. This dialog box also allows you to set 
height and width restrictions and an autoscroll option.

Setting your Legend Window Preferences
These settings control the defaults for how titles are specified for all legend frames in the legend 
window, as well as the default text style attributes such as font and size. The settings correspond to 
the settings displayed in Step 2 of the legend wizard. MapInfo Professional uses these defaults if 
there are no metadata keys in the table on which the legend frame is based. If metadata keys are 
present, the metadata defaults override the settings in Step 2 of the wizard and the Legend 
Preferences.

To set the Legend window preferences:

1. On the Options menu, point to Preferences and click Legend Window to display the Legend 
window preferences.

2. Use the options in this window to set the Legend Frame Defaults.
• To set the Title Pattern, type the text that you want to display at the top of each legend frame 

in this box. 
By default, the Title Pattern is “# Legend”, where ‘#’ is the name of the layer on which the 
frame is based. So, if the frame is based on the States layer, the default pattern title would be 
“States Legend.” You can change this pattern to “Legend of #” or simply “#.” To have no 
default pattern, leave the box blank. 
Choose a title pattern default that suits your needs. The # character can be used in any of the 
pattern text boxes as a shortcut key for the layer name.
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• To set the Subtitle Pattern, type the subtitle text you want in this box. The entry in this box is 
blank by default, but you can set your own default title pattern for subtitles.

• To set the Style Name Pattern, type the text you want to display beside each symbol in this 
box. The default pattern is the ‘%’ character. The Style Name is the text that describes each 
symbol in a legend frame. The % character is used as a placeholder for the type of object the 
legend symbol corresponds to: point, line, or region.
You can type in your own default Style Name Pattern, either using the % character or not. 
For example, in a legend frame based on the States layer, a Style Name Pattern that reads 
“% of #” will display as “Region of States” next to the symbol in the legend. The % character 
can only be used in the Style Name Pattern box. 

• To set the Border Style, select this check box to place a border around the legend and select 
the appropriate style by clicking the Border Style button.

3. To change the defaults of the style attributes for the titles, the style name, or the legend frame 
border, click the desired style box to display the corresponding style dialog box and make your 
changes. 

4. Click OK to save these settings and return to the Preferences dialog box.
5. Click OK to close the Preferences dialog box.

Text Box Size Limits

MapInfo Layout or Mapper windows can contain a maximum of 2047 characters. Text object rotation 
is restricted to under 256 bytes. Y are restricted to 256 bytes.

Setting the Startup Preferences 
In general, the Startup preferences control:

• How MapInfo Professional behaves when you startup
• The MAPINFOW.WOR workspace properties such as whether printer information and queries 

are saved to workspaces

To set your startup preferences for MapInfo Professional:

1. On the Options menu, point to Preferences and click Startup to display the startup 
preferences.

.
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2. Select the following boxes to enable the indicated functionality; clear the check box to disable 
this functionality. You may select all that apply.
• Save MAPINFOW.WOR when Exiting MapInfo — Select this check box to save your setup 

to the MAPINFOW.WOR workspace when you exit MapInfo Professional. When you clear 
this check box, MapInfo Professional does not save the MAPINFOW.WOR unless you save it 
explicitly.

• Load MAPINFOW.WOR when Starting MapInfo — Select this check box to display 
MAPINFOW.WOR when you enter MapInfo Professional. 

Note To enable this check box, you must clear the Display Quick Start Dialog check box. 

• Save Queries in Workspaces — Select this check box to save the queries you create 
during a mapping session in the workspace. If you do not select this check box and the 
selected map has only one layer based on a query, the query is not saved and the application 
writes a map definition with an empty layer list. MapInfo Professional cannot support 
subselects in queries. The operators Any and All are not supported in the MapXtreme 2004 
versions of MapInfo SQL and, therefore, subselects are not supported either.

Note MapInfo Professional cannot map selections with Group Bys, so Group By clauses are 
ignored. MapInfo Professional only translates the Order By clause.

• Save Printer Information into Workspaces — Select this check box to save the printer 
information in the workspace. 
This check box saves the printer name, paper orientation, paper size, and the number of 
copies from your printer settings into the workspace. This also includes any overrides you 
might have made to the default printer settings in the Printer preferences. We recommend 
that you leave this preference on. 

• Restore Printer Information to Workspaces — Select this check box to restore printer 
information from a workspace. When you open the workspace, the printer name, paper 
orientation, paper size, and the number of copies are restored. This is useful if you are 
sharing workspaces with other MapInfo Professional (6.0 or later) users who are also using 
the same printers. 

Note If this preference is turned off, or if the printer indicated is not available, the printer 
settings for the workspace revert back to the default printer set in the Printer preferences. 

• DBMS Connection — Select this check box to save a default DBMS Connection, specify a 
DBMS connection that will be opened each time you begin a MapInfo Professional session. 
Click Set to set this connection.

• Display Quick Start Dialog — Select this check box to display the Quick Start dialog box 
automatically when you start MapInfo Professional. This check box is selected by default. 
Clear the Display Quick Start Dialog check box to prevent it from displaying when you start 
subsequent MapInfo sessions. 

3. Click OK to save these settings and return to the Preferences dialog box.
4. Click OK to close the Preferences dialog box.

To set default DBMS Connections, see Setting up your Database Connection Preferences in the 
Help System.
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Creating a Startup Workspace 

STARTUP.WOR is the name you give to a workspace from which MapInfo Professional is run. You 
can create it so that MapInfo Professional automatically opens various tables and windows on 
startup. When you use STARTUP.WOR, MapInfo Professional performs the startup actions 
regardless of what you did in your previous MapInfo Professional session or how you have set 
preferences for MAPINFO.WOR.

To create a workspace:

1. Open the tables and windows you want in your workspace. Size and position them as you 
please.

2. Choose File > Save Workspace.
3. Name your workspace “Startup” and save the workspace into your “home” directory. By 

“home” directory we mean your private Windows directory. 

When you run MapInfo Professional, the following occurs in the order shown:

1. If there is a STARTUP.WOR in the MapInfo Professional program directory, it is run.
2. Then, if there is a STARTUP.WOR in your home directory it is run. (When there is a 

STARTUP.WOR in both the MapInfo Professional program directory and your home directory, 
both will= run.) 

3. Then, if any file names are given on the command line—or if you double-click a document, 
MapInfo Professional loads those files. MapInfo Professional support adding workspaces 
(.WOR), running applications (.APP), and opening databases (.TAB) on the command line.

4. Only if MapInfo Professional did not add a workspace or run a program from the command line 
does it then check the AutoLoad preference and load MAPINFOW.WOR from the user's home 
directory. When the preference is set, and the file is found, it is loaded. Note that if we had a 
workspace or application on the command line, we skip the AutoLoad.

5. Finally, if MapInfo Professional didn't load a workspace or run an application from the command 
line, and it didn't AutoLoad MAPINFOW.WOR, then MapInfo Professional shows the Tool 
palette.

Setting your Address Matching Preferences
Use the Address Matching preferences to specify the placement of the house number in addresses. 
The default setting is for house numbers to come before the street name.

To set your address matching preferences:

1. On the Options menu, point to Preferences and click Address Matching to display the 
Address Matching Preferences dialog box.

2. Click OK to save this preference and return to the Preferences dialog box.
3. Click OK to close the Preferences dialog box.
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Setting your Directory Preferences
The Directory preferences control the directories in which MapInfo Professional looks for files.

To set your directory preferences:

1. On the Options menu, point to Preferences and click Directories to display the Directory 
Preferences dialog box settings.

2. To set a preferred directory for each type of file, highlight the file dialog type and click Modify. 
The Choose Directory dialog box displays.

3. Select the appropriate directory for the file type you highlighted and click OK.
4. Repeat this process until you have specified all of the directories you need to.
5. If you are accessing your application data files and other configuration files (Mapinfow.prj, 

templates, and custom symbols) remotely, select the Use when searching for application data 
files check box and enter the path to the remote location in the field below. This field is usually 
pre-filled for you.

6. Click OK to save these settings and return to the Preferences dialog box.
7. Click OK to close the Preferences dialog box.

Use this setting to specify the default directories that display in the File menu dialog boxes when you 
open or save different files. You can specify directories for:

• Tables
• Remote tables
• Workspaces
• MapBasic programs
• Import files
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• DBMS SQL queries
• Theme templates
• Saved queries
• New grids
• Crystal Report files
• Graph support files
• Shapefile tables

When you click Open, you can select an icon from the MapInfo Places Bar. Click the Workspace 
Directory icon to display the workspace directory you designated in this preference.

Additionally, use this preference to search for raster and grid tables. If you open a *.tab file for a 
raster or grid image and the image file cannot be found an attempt is made to find the image in the 
same location as the .TAB. If the image file is not found, it will then use the Search Directories.

Use the Search Directories for Tables and Workspaces to specify search paths that MapInfo will use 
to look for tables referenced in workspaces or MapBasic programs that do not have fully qualified 
paths. 

To search directories for tables and workspaces:

1. To specify a search path, in Search Directories for Tables group, click Add. 

Note You can use the Add and Remove buttons to add or remove paths from the list.

2. Specify a drive and directory in the Choose Directory dialog box and click OK. 
You can set up to four paths. Use the Up and Down keys to change the search order.

3. Click OK to save these settings and return to the Preferences dialog box.
4. Click OK to close the Preferences dialog box.
• For more information see Choosing the Directories in the Place Bar in the Help System.

Setting your Output Setting Preferences
The Output Settings allow you to control raster and grid file color settings for on-screen display, 
printed output, and file export settings. In addition, you can also specify how you want to handle 
transparency in vector and raster files in both your printed output and exported files. Other printer 
settings enable you to specify an output method, map scaling, and whether to print a border around 
a Map window. 

You can override the settings in the Output settings preferences in the Advanced Printing dialog box. 
These preferences represent the default settings used in the Advanced Printing dialog box. These 
settings can then be saved in a workspace. 

Note You can get additional printer advice in the MapInfo Professional Printing Guide in the 
Documentation subfolder of your installation directory.
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To set your output preferences:

1. On the Options menu, point to Preferences and click Output Settings to display the Output 
Preferences dialog box.

2. The Display tab sets the on-screen display options for raster or grid files. Click the appropriate 
output settings based on your output requirements.
These entries explain the display settings, the printing options, and window export options in this 
dialog. Some of the options appear in more than one dialog so we have grouped all of the like 
explanations together.
• Display Raster in True Color When Possible — Click this check box to display your 24-bit 

raster or grid file images in true color (make sure your display settings are set to greater than 
256 colors). Clear this check box if you only want your images to display using 256 colors. 
This box is checked by default.

• Dither Method — Dithering is a technique that blends pixels electronically to improve the 
look of an image. Click a dither method when you are converting a 24-bit image to 256 
colors.
Dithering creates the illusion of complex colors by using a pattern of finite (fixed) color dots. 
For example, to create the color green using dithering, the color would consist of a pattern of 
yellow and blue dots.
Halftone dithering calculates a series of half tone differences in color between high- contrast 
elements in your image to create a smooth transition of color. This option is selected by 
default for display, print, and export options.
Error diffusion dithering calculates an interim color between contrasting colors and shades 
the surrounding pixels to blend evenly toward that interim color.

Note You can select dither method options in the display, printing, and exporting sections of 
this dialog box. The same definitions apply to each area.

3. Click the Printing tab to set the printing options for Map windows, Layout windows and all other 
output file types. Select the appropriate printing settings based on your output requirements. 
Remember that resetting these printer options locally overrides these preferences.
• Output Method/Print Directly to Device — Click this option to print your image file directly 

from MapInfo Professional. This check box is checked by default.
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• Output Method/Print Using Enhanced Metafile — Click this option to generate an 
enhanced metafile of your MapInfo Professional image before sending it to the printer. This 
setting takes advantage of current printer technology to shrink the spool size and print your 
file quicker without sacrificing quality.

Note You must use this setting if you are printing a map containing a translucent raster or grid 
layer. If you do not use this setting, the image will not print translucently.

• Print Border for Map Window — Click this check box to print a black border around the 
image you are printing. Clear this check box to leave the image unbordered. This check box 
is checked by default.

• Internal Handling for Printing Transparent Vector Fills and Symbols — Special 
programming has been added to handle transparent fill patterns and bitmaps for vector 
images when printing or exporting. Click this check box to use this functionality or clear it to 
let the printer or Windows export functions to handle this. This check box is checked by 
default.

• Scale Patterns — Select this check box to match the non-transparent fill patterns in your 
print output to more closely match what you see on your screen. This check box is checked 
by default. Clear this check box to let the printer driver have exclusive control over rendering 
the pattern fills.

Note The Scale Patterns check box does not affect transparent fill patterns because 
transparent fill patterns are always scaled.

• Use ROP Method to Display Transparent Raster — Click this check box to allow the 
internal ROP (Raster Overlay by Pixel) to manage the transparent pixel display and printing 
in raster images. Since the ROP Method is largely a display method, not all printers, plotters, 
and export programs can use it. We recommend that you either check with the printer 
manufacturer before using this setting or try a few test prints or exports to get the results you 
want. This check box is cleared by default.
Using the ROP method may not produce problems unless you print the metafile.

• Print/Export Raster in True Color When Possible — Click this check box to print and 
export your 24-bit raster or grid file images in true color (make sure your printer settings are 
set to greater than 256 colors). Clear this check box if you are not working with a color 
printer. This check box is checked by default.

Note See the Dither Method setting above for details about this option.

4. Click the Exporting tab settings to set the export options for Map windows, Layout windows and 
all other output file types. Select the appropriate window export settings based on your output 
requirements. Remember that resetting these options locally overrides these preferences.
• Export Border — Select this check box to include a black border on images you are 

exporting. Clear this check box to export the image without a border. This check box is 
checked by default.

Note The preference setting definitions for Internal Handling for Transparent Vector Fills and 
Symbols, Use ROP Method to Display Transparent Raster, Print Raster in True Color 
When Possible, and Dithering Methods are the same for export as for printing. 

• Use Anti-Aliasing— Select this check box to apply the anti-aliasing options available in 
MapInfo Professional.

5. Click OK to save these settings and return to the Preferences dialog box.
6. Click OK to close the Preferences dialog box.
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Understanding the Anti-Aliasing Export Preferences

To give you more control over map images when exporting MapInfo Professional maps, you can use 
anti-aliasing methods. This is particularly important when you are saving maps created in MapInfo 
Professional for use in other Windows-based applications, in particular in slide presentations or for 
web pages. 

The benefits of anti-aliasing can include:

• Make your fonts look smoother 
• Make jagged edges in maps look rounder 
• Can make text can be easier to read (for some) because it looks more like printed type
• Make maps look more visually attractive

We have added the ability to smooth images and text during the export process. You can use this 
capability with all types of windows such as Map windows, layouts, legends, and graphs. 

Note You cannot anti-alias images you are exporting to .EMF or .WMF format, because these are 
not true raster formats.

There are three smoothing options you can use to customize your raster image: 

1. Smooth using a Filter value. You can set a flag that selects one of six filters that allow you to 
choose the direction the filter is applied to the image from.

2. Smooth using a Mask value. You can select a value that indicates the size of the area you want 
to smooth. For example, to create a 3x3 pixel mask value, you would enter a 3 in this field. This 
would limit the amount of change in the color of the pixels. Typically mask sizes would be 2-3 
pixels when exporting at screen resolution. If you are exporting at a higher resolution, a larger 
mask might be appropriate.

3. Smooth using a Threshold value. You can select a threshold value to indicate which pixels to 
smooth. Each pixel in an image has a value based on its color. The smaller the pixel value, the 
darker the color. Select this option to smooth all of the pixels above the threshold you enter in 
this field. When you set this value to 0, MapInfo Professional will smooth all of the pixels.

You must either set a global preference for these anti-aliasing options or set them locally during the 
export process (using the Advanced button).

• For more information, see Recommendations for Effective Pattern Scaling in the Help System.

Setting the Printer Preferences
You can use the printer preferences to select a printer for MapInfo Professional output, which can be 
separate from your default Windows printer.

Note You can get additional printer advice in the MapInfo Professional Printing Guide, which is 
located in the Documentation subfolder of your installation directory.
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To set your printer preferences:

1. On the Options menu, point to Preferences and click Printer to display the Printer Preferences 
dialog box.

2. Complete your selections using these instructions.
• Windows Default — This entry displays the path to the default printer specified for your 

operating system. This button is selected by default.
• MapInfo Preferred — Click this button to select a different default printer when printing while 

using MapInfo Professional. This can be a printer or a plotter. After you select this option you 
can specify the size of the paper that is appropriate for this printer. 

• Size — After you select a printer, this list prefills with the appropriate paper sizes available. 
Select the requested paper size from this drop-down list.

• Orientation — After you select a printer, you can specify the direction that the paper faces. 
Portrait indicates that the paper is taller than it is wide (as shown in the previous figure); 
landscape indicates that the paper is wider than it is tall.

• Network — Click this button to locate the printer or plotter on the network that you want to 
set as the default. This button only displays for users running under Windows 2000 and 
Windows XP Pro. The Connect to Printers dialog displays.

3. To select a default printer, do one of the following:
• Select the path of the printer you want to use as your default and click OK,
• Double-click the printer in the list.
Using either method the Printer Preferences window redisplays.

4. Click OK to confirm your selections and set your MapInfo Professional default printer options.

Note If you selected Save Printer Information to Workspaces in the Startup preferences, 
MapInfo Professional saves the printer information and settings to the workspace.

To set this preference, make changes in the Startup Preferences dialog box.
5. Click OK to save these settings and return to the Preferences dialog box.
6. Click OK to close the Preferences dialog box.
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If you select the Windows Default printer, MapInfo will always use the printer that is currently set as 
the default in Windows. The settings for that printer will display in the MapInfo Preferred Printer 
Setup group. You will not, however, be able to change them in the Printer Preferences dialog box. To 
change the Windows default printer, go back to the Windows Control Panel. 

To use a printer other than the one indicated in the Printer preferences, choose either: 

• On the File menu, click Print. You can change the printer you are using in the Print dialog box, 
overriding the default printer settings. 

• On the File menu, click Page Setup. In the Page Setup dialog box, click the printer to display the 
Preferences dialog box for the default printer. Select a different printer in the Name drop-down 
list. This will override the default printer set in the Printer preferences. 

Note The printer override applies only to the window you are currently printing. To change the 
default settings, go back to the printer preferences and specify a new default printer.

• For more information, see Selecting a Printer and Error Message Displays when Print Output is 
Too Large topics in the Help System. 

Setting your Style Preferences
The Style preferences allow you to preset the look of your objects regions, text, and lines.

To set the default style preferences:

1. On the Options menu, point to Preferences and click Styles to display the Styles Preferences 
dialog box.

When you set the text styles you are also setting the label styles.
Complete your selections using these instructions.
Default Object Styles — Click the Region, Symbol, Line, and Text buttons to set these style 
options. These selections will serve to create the default settings for these style elements.
The text styles you select here apply to all text objects and labels.
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Enhanced Rendering 
Enable Enhanced Rendering
Use this check box to apply the following anti-aliasing and object translucency options to your 
labels and text.
Smooth Text
Use this drop-down list to select the smooth text options for your labels and text.
Highlight Control — Click this button to specify the Line, Region, and Multipoint styles of 
selected and target objects, as well as highlighting specifications in the Map window. 
Additionally, specify the style of selected and target multipoint objects. The default settings are 
shown in the Style boxes of the Highlight Control group. click one of the boxes to display the 
corresponding style dialog box and change its settings. 

Symbol — Click this button to set the default symbol style for Query > Find tasks. In the Symbol 
Style dialog box, select the new symbol style and click OK to save them. 
Show reference grid for style pickers — Click this check box to display reference grids on the 
style picker dialog boxes. This option allows you to refer to a particular style based on the 
intersection of the column letters and row numbers. Clear this check box to stop the reference 
grids from displaying.

2. Click OK to save these settings and return to the Preferences dialog box. Click OK to close the 
Preferences dialog box.

• For more information, see Changing the Find Symbol Style Locally and Inserting Styles into 
Tables in the Help System.

Setting the Web Services Preferences
The Web Services Preferences dialog box provides access to settings for the Web Feature Service 
and Web Map Service timeout values, GetMap pixel limits, and Proxy Server settings in MapInfo 
Professional. Additionally, you can set geocoding server and routing server options. These options 
allow you to control the web services preferences.

Note You can set per-server defaults based on particular WFS and WMS servers in the Override 
Timeout Values section of the Server Information dialog box.
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To access the Web Services Preferences dialog box:

1. Choose Options > Preferences > Web Services to display the Web Services Preferences 
dialog box.

2. Select the tab you want to set the options for and click OK to save the options you select.

Setting the Proxy Server Preferences

1. From the Options menu, click Preferences and then Web Services and then Proxy tab to 
display the proxy server options.

2. Select the preferences appropriate for your server and click OK to confirm them.

Use System Settings
Click this option to use the LAN settings in the system registry. This is the default preference. 
You can review the current LAN settings by clicking Start > Control Panel > Internet 
Options > Connections Tab > LAN Settings.

Use Direct Connection
Click this option to override the system LAN settings and try to connect directly to the Internet 
(not through a proxy server).

Use Proxy Server 
Click this option to set and use the proxy server settings to connect to the Internet.

Settings
Click this button to set the proxy server options. See Setting the Custom Proxy Server 
Preferences on page 66 for instructions on completing these settings.
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Setting the WFS Server Preferences

1. From the Options menu, click Preferences and then Web Services and then WFS tab to 
display the WFS server options. This tab sets the WFS refresh, timeout, and server options.

2. Select the preferences appropriate for your server and click OK to confirm them.

WFS Refresh
You use the WFS Refresh option to retrieve updated GML information from the web feature 
service pertaining to the current layers.

Update Mapper Filters with Current Mapper
Select this check box to use the current filter settings to refresh the Map window. If you select 
this check box and the table has already been refreshed, the current bounds of the front-
most map window are used. If the check box is cleared and the table is refreshed, the 
bounds of the map window (at the initial WFS request) are used. 

Note The original map bounds are used, regardless of the current map window bounds.

WFS Timeout Values
In this section you set the default WFS timeout values (in seconds) for the WFS servers you 
use. You can set per-server defaults based on particular WFS servers in the Override 
Timeout Values section of the WFS Server Information dialog box.

Connect Timeout
Indicates the amount of time (in seconds) allowed to establish an Internet connection request 
to a Web Feature server. If the request takes longer than this value, a timeout occurs. The 
default connect timeout is 60 seconds.

Send Timeout
Indicates the amount of time (in seconds) allowed to send an Internet request to a Web 
Feature server. If the request takes longer than this value, a timeout occurs. The default send 
timeout is 60 seconds.
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Receive Timeout
Indicates the amount of time (in seconds) allowed to begin to receive a response from a 
request from a Web Feature server. The download can take longer than the timeout, but the 
response has to occur within the timeout setting. The default receive timeout is 300 seconds.

Maintain Servers List
Click the Servers button to display the WFS Servers List, where you can add, edit, and 
delete WFS servers.

Setting the WMS Server Preferences 

1. From the Options menu, click Preferences and then Web Services and then WMS tab to 
display the WMS server options. This tab sets the WMS timeout, and server options.

2. Select the preferences appropriate for your server and click OK to confirm them.

WMS Timeout Values
In this section you set the default WMS timeout values (in seconds) for the WMS servers you 
use. You can set per-server defaults based on particular WMS servers in the Override 
Timeout Values section of the WMS Server Information dialog box.

Connect Timeout
Indicates the amount of time (in seconds) allowed to establish an Internet connection request 
to a Web Map server. If request takes longer than this value, a timeout occurs. The default 
connect timeout is 60 seconds.

Send Timeout
Indicates the amount of time (in seconds) allowed to send an Internet request to a Web Map 
server. If the request takes longer than this value, a timeout occurs. The default send timeout 
is 60 seconds.

Receive Timeout
Indicates the amount of time (in seconds) allowed to begin to receive a response from a 
request to a Web Map server. The download can take longer than the timeout, but the 
response has to occur within the timeout setting. The default Receive Timeout setting is 300 
seconds.

WMS GetMap Pixel Limits
The GetMap Pixel Limits option represents the maximum number of pixels (in width/height) 
that a map request is limited to. The GetMap request is designed to retrieve the highest 
resolution map image as is necessary to render the image on the screen, for a printer, or for 
an export file. This option prevents the request from going higher than the specified values. 
Different servers have different limits, so you can set the limit that works best for your 
environment. 

Note You can set per-server defaults for GetMap Pixel Limits in the WMS Server Information 
dialog box.

Unfortunately, servers do not report their limits to us, so if the GetMap request fails, it means 
that you have entered a value that is too large. 
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Typically, large GetMap requests occur when you are printing or exporting windows 
containing WMS images. This happens because printing and exporting occurs at 
larger sizes and/or higher resolutions than on-screen display requires. 

Note You can also use this option to shorten the WMS map retrieval time, but remember that 
the resulting image will display at a lower resolution.

Max Width
Max Width specifies the maximum number of pixels for a GetMap request in the X direction.

Max Height
Max Height represents the maximum number of pixels for a GetMap request in the Y 
direction.

Maintain Servers List
Click the Servers button to display the WMS Servers List, where you can add, edit, and 
delete WMS servers.

Setting the Geocoding Server Preferences

You can get more information about setting up a geocoding server in Setting up a Geocoding 
Server on page 67. A table must be open to enable the Geocode using Server menu item.

To set the geocoding server preferences:

1. From the Options menu, click Preferences and then Web Services and then Geocode tab to 
display the Geocoding server options. This tab sets the geocoding server timeout and 
maintenance options.

2. Select the preferences appropriate for your server and click OK to confirm them.
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Offset From Road
Use this field to indicate the default distance the geocoded point should be from the road, if 
applicable. 

Offset From Corner
Use this field to indicate the default distance the geocoded point should be from the corner, if 
applicable. 

Units
Use this field to indicate the units for the previous entries.

Dictionary
Use this drop-down list to select the dictionary options you want the geocoder to use 
(Address or User). These libraries exist on the service. Not all dictionary types may exist on 
all services. There are a maximum of 5 options:

Select All Dictionaries - Select this option to use both the user and address dictionaries.
Address Dictionary Only - Select this option to use only the service’s address dictionary 
and not the user’s dictionary.
User Dictionary Only - Select this option to use only the user’s address dictionary and not 
the service’s address dictionary
Prefer Address over User - Select this option to use the service’s address dictionary before 
the user’s address dictionary. This option is the default.
Prefer User over Address - Select this option to use the user’s address dictionary before 
the service’s address dictionary. 

Number of Addresses to Batch
Use this option to specify how many addresses you want to send to the geocoding service at 
a time. The number of addresses you send at a time can affect performance. If you are using 
the EOLS, the batch size can also affect billing of geocoding transactions if you cancel a 
geocoding operation during processing. 

Default Timeout Values
Use these timeout values to set the communication parameters for the geocoding service. 
You can override these defaults on a per-service basis locally by editing the service in the 
Services list and specifying the override.

Note When you set the time out values locally, you may want to keep in mind the size of 
your request. The more complicated your request, the more time may be required for 
connection/sending/receiving.

Connect Time Out
Use this setting to indicate the amount of time allowed to establish an Internet connection to 
the geocoding service. If the request takes longer than this value, a timeout occurs. The 
default connect time out is 60 seconds.

Send Time Out
Use this setting to indicate the amount of time allowed to send an Internet request to the 
geocoding service. If the request takes longer than this value, a timeout occurs. The default 
send time out is 60 seconds.
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Receive Time Out
Use this setting to indicate the amount of time allowed to begin to receive a response from a 
request to geocoding service. The download can take longer than the time out, but the 
response has to occur within the timeout setting. The default receive time out is 300 seconds.

Result Codes - Mark Multiple Match when Automatic Geocoding
Select this option to display a result code of M when you are performing automatic geocoding 
and there are multiple matches for an address. If you do not select this option, and there are 
close matches, the system displays an S for street only. See Understanding the Geocoding 
Result Codes in the Help System.

Symbol Style
Use this setting to set the default symbol style for the points you are creating for geocoding. 
You can override it during a geocoding operation using Symbol Style in the Common 
Options tab.

Maintain Servers List
Click Servers to display the Geocoding Servers List, where you can add, edit, and delete 
MapMarker and Envinsa geocoding servers. This list is the same as you would see when you 
select the Servers button in the Geocode Using Servers and the Find Address dialog box.

Setting the Routing Server Preferences

1. From the Options menu, click Preferences and then Web Services and then Routing tab to 
display the Routing server options. This tab sets the driving region server maintenance options.

2. Select the preferences appropriate for your server and click OK to confirm them.

Maintain Servers List
Click the Servers button to display the Routing Servers List, where you can add, edit, and 
delete Envinsa Drivetime servers.
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Setting the Custom Proxy Server Preferences

You can configure MapInfo Professional for proxy server use. By default, MapInfo Professional uses 
your system LAN settings as the default proxy server settings. To set the Web Services Preferences 
to use a different proxy server, you must know the IP address and port number of the alternate proxy 
server to properly complete these entries.

To set up your web service preferences to use a different proxy server than those provided in your 
system LAN settings:

1. From the Options menu, click Preferences and then Web Services. The Web Services 
Preferences dialog box displays.

2. In the Proxy Server Settings box, click the Use Proxy Server button and click the Settings 
button. The Web Services Proxy Settings dialog box displays.
Use these options to configure the proxy server for your internet and intranet use.

3. Enter the IP address of your computer and the port number in the fields provided. If you do not 
know this information, check the IP Config settings or consult your system administrator.

4. To access local addresses without going through the proxy server, select the Bypass proxy 
server for local addresses check box.

5. To exclude some non-local IP addresses from the proxy server, enter the IP addresses in the text 
area provided, using a semicolon to separate the addresses.

6. Click OK to save your entries.

As a result of these settings, you are prompted for a user name and password when you are 
attempting to access the Internet to use the Web Map Service or the Web Feature Service features.

Setting up the Image Processing Preferences
You can control the reprojection options of your vector and raster maps using the Image Processing 
Preference. Reprojection, particularly when reprojecting seamless tables or other large raster map 
layers, can take a long time. This is particularly true if your reprojection is dramatic, as when you are 
transforming world-wide rasters from Long/Lat to Mercator, for example. To see the results of this 
setting go to Reprojecting a Raster based on a Vector Map in the Help System.

To set the raster reprojection options for all registered raster files:

1. From the Options menu, choose Preferences and Image Processing to display the Image 
Processing dialog box.
You can also access these options using the Image Processing button in the Map Options 
dialog box.
The Resampling Method options are enabled when you select Always or Optimized. Never is 
the default reprojection option and reflects the vector reprojection only behavior.

2. Select the reprojection option that suits your raster reprojection needs. Select:
• Never to prevent raster reprojection. This is the default setting which preserves the pre-

version 8.5 MapInfo Professional behavior.
• Always to ensure that reprojection is always performed, that is, MapInfo Professional 

calculates the image’s coordinates based on a precise formula and then the pixels are 
resampled using Cubic Convolution or Nearest Neighbor options. 

• Optimized to determine the reprojection of a raster image based on the look of the 
destination rectangle (a selection of the image) after transformation into the source image 
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space. If it looks as a rigorous rectangle (two sides are parallel to x-axis and two sides 
parallel to y-axis), then the standard Windows functions stretch the source image in both 
directions, as it was in pre-version 8.5 MapInfo Professional. If the image fails the rigorous 
rectangle test, the reprojection is performed using the resampling options.

3. If you select Always or Optimized, you can decide how best to resample the image from these 
options:
• Cubic Convolution provides the best restoration of pixel values because of their 

separateness. Using this option, a pixel in the destination image is calculated based on the 
pixel values in a 4x4 pixel window centered at the original pixel in the source image. The 
coordinates of the original pixel are calculated for every pixel of the destination image based 
on a special optimized procedure. Pixels are then weighted based on the basic pixel 
coordinates. In general, we recommend you use the Cubic Convolution resampling method 
for aerial images and satellite rasters to get a better image quality. The Cubic Convolution 
algorithm used in MapInfo Professional is based on the work of S.K. Park and R.A. 
Schowengerdt, Computervision, Graphics and Image Processing (1983, Volume 23. Pages 
258-272).

• Nearest Neighbor replaces the pixel value in the reprojected image with the original pixel 
value from the source image. This resampling method takes less time to render than the 
Cubic Convolution method, but may be less precise. In general we recommend you use 
Nearest Neighbor resampling for raster maps, grids, and scanned maps to get faster results.

Note When you are reprojecting 8-bit palette raster images, such as color .TIFF or .BMP 
images, MapInfo Professional uses the Nearest neighbor resampling option without 
regard to the resampling method you choose.

4. After you have selected these options, click OK to save them.
When you choose the Always or Optimized reprojection options, the reprojection process runs in 
the background, so there is nothing to see, but you can see the differences that the Cubic 
Convolution and Nearest Neighbor resampling options make in the way the raster displays.

Note The data used in this instruction set ships with the product. You can retrieve this data from 
the data CD. 

Setting up a Geocoding Server
To use MapInfo Professional with a geocoding server, you need MapMarker Java Server 4.0 or later 
or Envinsa Server 4.0 or later. MapInfo Professional supports any geography that is supported by 
Envinsa currently. Envinsa supports MapMarker Java Server V2, V3, and V4. Keep in mind that any 
Envinsa server only supports the data that is installed.

Before you can access a MapMarker or Envinsa geocoding service, you need to connect MapInfo 
Professional to its server. This process gives MapInfo Professional all the information it needs to 
access the geocoding service. You need to enter this information only once per service.

To set up a geocoding server:

1. Make sure that the table you want to geocode is open.
2. From the Table menu, choose the Geocode Using Server option to display the Geocode using 

Server dialog box. If you have not added any geocoding servers yet, the Configure Service 
dialog box displays.
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3. Do one of the following:
• If you do not have a MapMarker or Envinsa geocoding server, you can use Pitney Bowes 

MapInfo's hosted Envinsa Online Service (EOLS) to try this functionality. Click Activate to 
sign up for a geocoding service near you. See Accessing Online Services at MapInfo in the 
Help System for more instructions in signing on to this service.

Note Pitney Bowes MapInfo may not have online services with data that includes the 
geography you are interested in. Please check with your local Pitney Bowes MapInfo 
sales personnel to ensure that web services exist for your geography.

• If you have a MapMarker or Envinsa geocoding server, click Next to display the Geocoding 
Using Server dialog box. 

After you add geocoding servers to MapInfo Professional, this box displays your 
default server.

4. Click Servers to display the Geocoding Servers List dialog box. 
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This list is empty by default until you add a geocoding server either using the Servers 
button in the Geocode Using Server dialog box or in the geocoding web services 
preferences.

Note When you have entered a server that you will use most frequently, highlight it in the list. 
Click Set Default. A check mark displays to indicate that the server you selected will 
open by default.

5. To add a new server, click Add. The Geocoding Server Information dialog box displays.

6. Type the service URL and description in the fields provided. You can connect to either a 
MapMarker or Envinsa geocoding service by making a selection in the Type of Service drop-
down list.
When you select an Envinsa service, enter a user ID and password in the fields provided. Select 
the Remember Password check box to save the password in encrypted format in the server list. 
This option is selected by default. If you prefer to enter the password each time you access this 
server, clear this check box. 

CAUTION: Anyone knowing this password will be able to use the Envinsa geocoding 
service.
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7. Consider whether the default timeout settings are appropriate for the service you are adding. 
The default settings that display in each field are set in the geocoding web services preferences. 
You can change these global defaults using the instructions in Setting the Geocoding Server 
Preferences on page 63.
To reset these entries for the current server, select the Override Default Values check box and 
enter new timeout settings using these definitions:

Connect Timeout
Indicates the amount of time (in seconds) allowed to establish an Internet connection request 
to a geocoding service. If the request takes longer than this value, a timeout occurs. The 
default connect timeout is 60 seconds.

Send Timeout
Indicates the amount of time (in seconds) allowed to send an request to a geocoding service. 
If the request takes longer than this value, a timeout occurs. The default send timeout is 60 
seconds.

Receive Timeout
Indicates the amount of time (in seconds) allowed to begin to receive a response from a 
request from a geocoding service. The download can take longer than the timeout, but the 
response has to occur within the timeout setting. This default timeout is 300 seconds.

If the default timeout settings are appropriate for the new service, clear this check box.
8. When you have completed these entries, click Test URL to ensure that the connection is made. 

When you click Test URL and MapInfo Professional can connect to the service, the Geocoding 
Server Details dialog box displays.
If the URL is valid, the Engine Info list displays the service’s available, country data, the 
supported geocoding types (Street, Postcode, Geographic), and the version information. Click 
the column headings to sort the entries alphabetically. Click Close to return to the Geocoding 
Server Information dialog box.

Note If you select Test URL and no service connection is found, an error message displays. 

9. When all of these fields and options are complete, click OK to save the new geocoding server.

Setting up the Routing Server 
Before you can access an Envinsa Drivetime service, you need to show MapInfo Professional where 
to find the Routing server it is housed on. This process gives MapInfo Professional all the 
information it needs to access the server. You need to enter this information only once per server. To 
set the routing server preferences, see Setting the Routing Server Preferences on page 65.

To add a Routing server:

1. From the Options menu, choose the Preferences option and then select Web Services. Click 
the Routing tab to set the web service preference options.

2. To add a new routing server, click Servers to display the Routing Servers List dialog box. 
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3. Click Add. The Routing Server Information dialog box displays.
MapInfo Professional supports server-side and proxy server authentication. If you use a proxy 
server for Internet access and your routing server also requires user/password authentication, 
you authenticate with the proxy server first. As a result, the Connection dialog box displays twice 
-- once for the proxy server and once for the routing server.

4. Type the server URL, the server description, the default user name and password in the fields 
provided. Click the check box to remember the password when you enter the correct user name.

5. Consider whether the default timeout settings are appropriate for the server you are adding. The 
default settings display in each field. The options you select in this dialog box determine the 
Routing server’s default settings. To change these entries, select the Override Default Values 
check box and enter new timeout settings using the same definitions.

Note When you have entered a server that you will use most frequently, highlight it in the list. 
Click Set Default. A check mark displays beside the server you selected.

6. When you have completed these entries, click Test URL to ensure that the connection is 
available. The Routing Server Details dialog box displays.
If the URL is valid, the Countries list displays the server’s available country data. Click Close to 
return to the Routing Server Information dialog box.

Note If you select Test URL and no server connection is found, an error message displays. 

7. When these fields and options are complete, click OK to save the new routing server.

Starting up and Leaving MapInfo Professional
In this section we cover the very basics of starting MapInfo Professional, using the STARTUP.WOR, 
and exiting the program. Since opening a table is basic to getting started in using MapInfo 
Professional, we cover that topic here, as well.

Starting MapInfo Professional
Now that you have MapInfo Professional installed and have read a little about its power and 
functionality, you are ready to begin mapping and analyzing your data.

To start MapInfo Professional:

• Do one of the following:
• Double-click the MapInfo Professional icon on your desktop. In a few seconds, MapInfo 

Professional’s Quick Start dialog box displays. 
• From the Start menu, select MapInfo Professional 9.5 (or MapInfo Professional 9.5 

Client, if this is a network installation) from the Selected Program folder.
Using either method the Quick Start dialog box displays.
Here you can choose how you want to start your mapping session. The Quick Start dialog box 
displays every time you start MapInfo Professional, but you can change this behavior in the 
Startup preferences (On the Options menu, point to Preferences and click Startup) using 
instructions in Setting the Startup Preferences in the MapInfo Professional Help System. In the 
Startup Preferences dialog box, clear the Display Quick Start dialog box to deactivate the display 
of the Quick Start dialog box.
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If you are returning to MapInfo Professional, you can return to the previous mapping session by 
choosing Restore Previous Session or use last workspace. If this is your first look at MapInfo 
Professional, choose the Open a Table option to begin. The Open dialog box displays.

Exiting MapInfo Professional 
To leave MapInfo Professional:

• On the File menu, click Exit. There is no confirmation message.

CAUTION: If you made changes to a table and did not save them a prompt appears asking 
you if you want to save the changes. Unless you choose Save, the changes are 
lost.

• For more information, see Leaving MapInfo Professional using the MAPINFOW.WOR 
Workspace in the Help System.

File Format Types Supported
You can open the following file types using the File > Open capability in MapInfo Professional:

• TAB: MapInfo .TAB files (*.tab)
• WOR: MapInfo workspace files (*.wor)
• MDB: Microsoft Access files (*.mdb)
• DBF: dBASE DBF files (*.dbf)
• TXT: Delimited ASCII files (*.txt) 
• WKS: Lotus 1-2-3 files (*.wk1, *.wks, *.wk3, *.wk4)
• XLS: Microsoft Excel files (*.xls)
• SHP: ESRI Shapefiles (*.shp)
• Raster image files (*.bil, *.sid, *.gen, *.adf, *.img, *.ntf, *.ecw, *.url, *.tif, *.grc, *.bmp, *.gif, *.tga, 

*.jpg, *.pcx, *. jp2, *.j2k, *.png, *.psd, *.wmf, *.emf, *.map)
• Grid images (*.adf, *.flt, *.txt, *.asc, *.img, *.dem, *.dt0, *.dt1, *.dt2, *.mig, *.grd)
• CSV: Comma Delimited files (*.csv)

Note Grid Format Direct Support: The following grid handlers support direct read of DEM-USGS 
Text (.dem); GTOPO30 (.dem) and DTED levels 1, 2, 3 (.dt0, .dt1, .dt2). These grid handlers 
are read-only; they cannot be used to create grid files during the Create Grid Thematic 
interpolation process.
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Using the Universal Translator, you can import these file format types:

• DWG/DXF: AutoCAD 
• E00: ESRI ArcInfo format
• SHP: ESRI Shapefile format
• MID/MIF: MapInfo file formats
• TAB: MapInfo .TAB files
• DGN: Microstation Design files
• CATD.DDF: Spatial Data Transfer Standard (SDTS)
• FT: Vector Product Format (VPF)

You can import the following file types into MapInfo Professional using Table > Import:

• MIF: MapInfo Professional Interchange Format. MapInfo Professional’s data interchange format 
(ASCII file format).

• DXF: The graphic/data interchange format for AutoCAD and other CAD packages.
• MBI: MapInfo Professional Boundary Interchange format. An ASCII file for MapInfo DOS 

boundary files.
• MMI: MapInfo DOS MMI 
• IMG: A file format for MapInfo Professional for DOS image files.
• GML: OS MasterMap format. 
• GML/XML: Geographic Markup Language 2.1 (*.gml, *.xml)

Note You can download raster handlers for NIMA formats such as ADRG, CADRG, ASRP, CIB, 
USRP, and NITF formats from the Pitney Bowes MapInfo website or get them from the 
Installation CD.

MapInfo Professional imports graphics and textual information from MapInfo Professional 
Interchange Format, DXF, MBI, and MMI files. MapInfo Professional imports only graphics from IMG.

These are the Raster image file formats MapInfo Professional supports:

• MrSID: The MrSID raster handler allows you to open and display raster images compressed in 
the MrSID format.

• BMP -- Windows Bitmap. Windows format only: Monochrome: 8 Bit Color, 24 Bit Color
• GIF -- Graphics Interchange Format
• GIF89a Format (non-interlaced only): Monochrome, 8 Bit Color
• JPEG-2000 -- Joint Photographic Experts Group: MapInfo Professional supports creating 

JPEG 2000 files using Save Window As and viewing JPEG 2000 files using the LeadTools raster 
handler.

• JPEG -- Joint Photographic Experts Group
• JFIF V1.02 (JPEG File Interchange Format): 8 Bit Gray, 24 Bit Color, No Subsampling, 24 Bit 

Color, YUV422 Subsampling, 24 Bit Color, YUV411 Subsampling
• PCX -- ZSoft Paintbrush
• PCX File Format Version 5 (Paintbrush Version 3.0): Monochrome, 8 Bit Gray, 8 Bit Color, 24 

Bit Color
• SPOT -- Satellite Pour l'Observation de la Terre -- Spot Image Formats 1.5 and 4.0: 8 Bit 

Gray, Format 1.5, 8 Bit Gray, Format 4.0, 24 Bit Color, Format 1.5, 24 Bit Color, Format 4.0
• TGA -- Truevision TGA Truevision File Format Specification 2.0: 8 Bit Gray, 8 Bit Color, 24 

Bit Color
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• TIFF -- Tagged Image File Format: TIFF Revision 5.0, Monochrome (Class B), 
Uncompressed, Monochrome (Class B), PackBits Compression, 8 Bit Gray (Class G), 
Uncompressed, 8 Bit Color (Class P), Uncompressed, 24 Bit Color (Class R), Uncompressed

• PNG – Portable Network Graphics Format
• PSD – Adobe Photoshop Version 3.0
• WMF – Windows Metafile: The raster handler will load a rasterized version of the WMF file.
• ECW – Enhanced Compression Wavlet by ER Mapper
• GRD/GRC – MapInfo Vertical Mapper: GRD files can be treated as either a grid or raster 

image. If the associated .TAB file contains a RasterStyle 6 entry, the file will be treated as a grid.
• ASRP – ARC Standard Raster Product to 1.2
• ADRG – ARC Digitized Raster Graphic
• CADRG- Compressed ARC Digitized Raster Graphic
• NITF – National Imagery Transmission Format (version 2.x) 
• CIB – Controlled Image Base
• GIF – Graphics Interchange Format
• TIFF LZW– Tagged Information File Format LZW
• TIFF CCITT Group 4– Tagged Information File Format CCITT Group 4
• GeoTIFF

File Limitations for MapInfo Professional Supported Formats

Keep the following notes in mind when working with these MapInfo formats:

• MapInfo Professional only supports the DXF file import to release 13. This has been 
superseded by the Universal Translator and Open Universal Data feature.

• The Open Universal Data feature supports all DXF formats up to the current AutoCAD 
release. While it is our company’s intention to keep pace with the new releases of FME, if you 
extend the application to import AutoCAD DXF files using a newer version of FME before we 
have upgraded our product, errors may occur

• You can have maximum 500 files open at a time in MapInfo Professional if you remove the 
HKEY_LOCAL_MACHINE\SOFTWARE\MapInfo\MapInfo\Common Max Files registry key

• You can have up to 125 files open at a time for editing in MapInfo Professional.
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What’s New in MapInfo 
Professional 9.5
Thank you for upgrading to the most advanced computer mapping product in 
the Pitney Bowes MapInfo software family! As the field of computer mapping 
continues to expand, Pitney Bowes MapInfo leads the way with new products 
that are designed to fulfill your computer mapping needs from the most basic to 
the most specialized.

For more information about the bug fixes and corrections we have made to 
MapInfo Professional in this release, you will soon be able to review the release 
notes at:

http://reference.mapinfo.com/
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Before You Get Started
Before You Get Started
There are some important enhancements to the MapInfo Professional functionality that make the 
application easier to use, make your maps better looking, give you more options for creating and 
editing data, better data access, and enhanced licensing and deployment. Developer users now 
have greater programmability support with the introduction of .Net design and integration options.

Most of the data used in this documentation is available either from the data CD or from the trial data 
on the Pitney Bowes MapInfo web site. To retrieve the trial data, go to:

http://goto.mapinfo.com/webtutorials/

and download this data to your computer. You must have Internet access to retrieve the tutorial data.

Workgroup Installation Supports File Sharing
In the past, System Administrators installed MapInfo Professional program files in a network location 
and gave users access to these files via a shortcut. This was known as a "Network" installation. 

System Administrators have asked us for an installation process that enables them to store 
commonly used files in a shared, central location to accommodate Vista requirements. This 
"Workgroup" installation allows users to retrieve the Application Data Files (such as the 
MAPINFOW.PRJ file and custom symbols) from a shared, network location but install the program 
locally. Using this model, all users can share coordinate system settings, templates, and custom 
symbols. 

There are two steps to this Workgroup installation process:

1. System Administrators create a shared location for the application data files and create a 
method for users to install MapInfo Professional on their own computers.

2. Users install the application on their computers, pointing to the shared location for their 
Application Data Files.

What are the Application Data Files?

Application Data Files are user files that affect the look and basic settings of your MapInfo maps. 
Specifically:

• Configuration files:

• MAPINFOW.ABB (The abbreviations file)

• MAPINFOW.CLR (The colors file)

• MAPINFOW.FNT (The fonts file)

• MAPINFOW.MNU (The menu file)

• MAPINFOW.PEN (The pen file)

• MAPINFOW.PRJ (The projections file)

• WFS and WMS server lists
• Thematic Templates
• Custom Symbols
• Graph Support
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• Layout Templates

Beginning a Workgroup Installation (System Administrators)

To prepare for a Workgroup installation:

1. Inset the installation CD, click Install Products > MapInfo Professional > MapInfo 
Professional Workgroup. The Workgroup Install dialog box displays.

2. Click Install MapInfo Workgroup. At the Welcome dialog box, click Next.
3. In the License Agreement dialog box, click I agree and click Next. The Custom Setup dialog box 

displays.

Note: All Application Data Files are selected by default. 

4. To prevent file sharing of one or more of these file types, click the drop-down arrow beside the 
file type and select This feature will not be available from the list. 

Note When you choose not to install file(s) to the shared location, MapInfo Professional uses 
the local copy of these file(s) instead. 

5. Highlight the Application Data Files entry and click Change. The Change Current Destination 
Folder displays. Navigate to the the shared location for storing these files and click OK. 
Make sure that this shared location is accessible by all users who need these files. Users 
will need read/write access to add new templates and other custom symbols to share.

Note When users install MapInfo Professional, these same Application Data Files are also 
stored locally. This allows them to access these files when the shared folder is 
unavailable. For more details, see Completing a Workgroup Installation (MapInfo 
Professional Users) on page 79.

6. Highlight the MapInfo Professional v9.5 Installer entry and click Change to display the 
Change Current Destination Folder dialog box. 
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Do one of the following:
• If you want your users to install MapInfo Professional from a CD you create: 

select a local destination folder and click OK. This installer then copies the MapInfo 
Professional installation files to the local destination folder you selected. At the end of this 
process, you can create installation CDs for each user from the installation files copied to this 
local folder. You can then distribute these CDs to each user so they can begin their MapInfo 
Professional installation.

• If you want your users to install MapInfo Professional from a central network location:
select a network location folder and click OK. This installer then copies the MapInfo 
Professional installation files to the network location folder you selected. At the end of this 
process, notify each user of this network destination folder so they can begin their MapInfo 
Professional installation. 

The Custom Setup dialog box displays.
7. Click Next to display the Ready to Install the program dialog box. Click Install. 
8. At the end of this process, the Installshield Wizard Completed dialog box displays. Click Finish.
9. Finally, do one of the following:

• If you saved the installation files locally, create one MapInfo Professional installation CD for 
each user from the contents of the local folder. Make sure you copy the mode.xml file along 
with the other installation files in that directory.

• If you saved the installation files on the network, notify each user of that network location so 
they can install MapInfo Professional locally.

During this process, you created a MODE.XML file that contains the shared location you set for the 
Application Data Files. When the user opens MapInfo Professional for the first time, the path to the 
shared location is copied from the XML file to the user’s computer registry. If you need to change the 
network location of these files, follow the instructions in Changing the Shared Location after 
Installation on page 80.

Note: IMPORTANT: If your users ask you about the product serial numbers, you can find them on 
the outside of the MapInfo Professional box. Serial numbers are also in a letter inside the 
box, if you need to store them.
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The Application Data Files are also stored locally for use when the shared folder is unavailable. The 
next section describes this in more detail.

Completing a Workgroup Installation (MapInfo Professional Users)

To complete the workgroup installation,do one of the following:

• If your system administrator has given you a CD or DVD for installaiton, place this media in 
the appropriate computer drive and follow the MapInfo Professional Installer instructions.

• If your system administrator has placed the MapInfo Professional installer in a network 
location, navigate to that location and follow the MapInfo Professional Installer instructions.

Understanding your Workgroup Installation

When you install MapInfo Professional as part of a workgroup, you share commonly used files with 
the other users in your organization. Workgroups use the same configuration, template, and custom 
symbol files without having to copy them manually. This method supports each workgroup member 
in creating more consistent maps.

As part of your application’s installation process, the MapInfo Professional installer creates a local 
copy of these Application Data Files for your use when the shared location is not available. This is 
very important.

• If the shared location of your Application Data Files is available,
MapInfo Professional saves your template, symbol, and configuration work to the shared 
location. 

• If the shared location of your Application Data Files is not available, 
MapInfo Professional saves your template, symbol, and configuration work to your local copy of 
these files.

Note If the shared location is not available when you open MapInfo Professional for the first time, 
an error displays explaining that the application will use the local Application Data Files. You 
can use the instructions in Changing the Shared Location after Installation to select a new 
shared location, if necessary.

Since typically you will access the shared location, this will not be an issue. But if you change any of 
the Application Data Files locally and the shared location becomes available, we recommend you 
copy your work to the shared location. This will ensure that your files are available when you and 
your co-workers need them.

A Note About Graph and Theme Template Files

The search for graph and theme template files is dependent upon the folder setting in the Directory 
Preferences dialog box. If these preferences do not exist in the network location, the application 
searches for files locally.
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Changing the Shared Location after Installation

To change the shared location for these files after installation, use the Directory Preferences dialog 
box. Each user in the Workgroup needs to follow this procedure to maintain these shared files.

To change the application data file location for a Workgroup user:

1. Choose Options > Preferences > Directories to display the Directory Preferences dialog box.

The shared location displays in the Workgroup Directory field. 
2. You can reset the Workgroup folder in one of these ways:

• To set a new shared location, enter a new path in the field provided or click  to select a 
new shared path. 

• To use local files only, clear the Use when searching for application data files check box.

Note You can use named drives or UNC paths in the Workgroup Directory field.

3. Click OK to confirm your change. The application saves this new path to your registry. Each time 
you open MapInfo Professional after this, the application uses this new path to access the 
Application Data Files.
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Licensing Additions
We have added more flexibility to your MapInfo Professional licenses by adding a permanent, 
distributed license. 

Distributed Licenses are now Available

We have developed a new licensing model that allows companies to "distribute" permanent licenses 
using your MapInfo License Server, which is available on the MapInfo Professional CD. This model 
was developed for customers who have limited access to email or to the Pitney Bowes MapInfo FNO 
server. Distributed licenses follow a similar activation procedure to other models that are handled 
using your License Server. For instructions on installing the License Server, please see the License 
Server User Guide.

You can also return a distributed license to your License Server if you need to transfer it to another 
computer. For these instructions, see Transferring a Distributed License on page 82.

Before you start the distributed activation process, make sure you have the following pieces of 
information from your License Server system administrator:

• The correct serial number and activation code
• The License Server machine name 
• The port number for the server

Then you can begin your distributed license installation and activation.

To activate a distributed license:

1. Make sure your MapInfo License Server is running. Check to see that the server is set up 
properly and contains the appropriate activated licenses.

2. Begin the MapInfo Professional installation process as you would with any other license model.
3. When you are prompted for your serial number and access code, enter the distributed license 

serial number and activation code. Distributed license serial numbers begin with "MID". Click 
Next. The License Server Name and Port dialog box displays.
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Note The port number defaults to 27000 but it can be set by your License Server system 
administrator. Check with the administrator if the port number is not working.

4. Type in your License Server’s (machine) name in the first field and the port number in the second 
or leave the default entry in place. Click Next to continue. The remaining installation prompts are 
the same as in Installing MapInfo Professional on page 13.

5. When you open MapInfo Professional for the first time, one of the following occurs:
• If the application finds the license server, and the serial number, activation code, and port 

numbers are correct, the application opens and the product is activated. 
• If the application did not access the license server, did not recognize the serial number or 

activation code, or did not recognize the port number, an error message displays. We 
recommend that you review these components to ensure that they are correct and/or work 
with your system administrator to review these four pieces of information. Correct the 
erroneous information and begin the activation process again.

After you activate your license, you can review the licensing details in MapInfo Professional by 
selecting Help > About this MapInfo Product. The About this MapInfo Product dialog box displays:

The serial number, access code, and licensing details display in this box for future 
reference.

Transferring a Distributed License

You can transfer a distributed license to your License Server, when you want to move the license to 
another computer. 

Note Before making any hardware changes to your PC (such as disk re-formatting) please 
remember to return your activated license back to Pitney Bowes MapInfo or to your License 
Server. After your hardware has been changed you may then re-activate your license. 
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To transfer a distributed license to your License Server:

1. Choose Help > Licensing > Transfer License. The Return distributed license to license server 
dialog box displays.

2. Click OK to transfer the distributed license to the server. After the transfer is complete, a 
confirmation message displays. You can then install MapInfo Professional again on another 
computer using the same serial number, activation code, license server name and path, and port 
number.
If you have unsaved or open MapInfo table data, the Save Modified Table Data dialog box 
displays. This dialog box helps you save or discard data before you transfer your license to your 
License Server. Click the appropriate option to save or discard this data:
• Click Save to save the open table data
• Click Save All to save the open data in the appropriate data tables 
• Click Discard to close the open table without saving the modified data
• Click Discard All to close the open tables without saving the modified data
After you make your selection in this dialog box, the transfer continues as described above.

Note After you return the license, the application closes. Since MapInfo Professional is still 
installed on your computer, if you open the application again, the product will attempt to 
activate another distributed license. If the license is not available, you can use the courtesy 
license for the balance of your 30 day trial.

Activating and Returning Licenses Silently
Information Technology engineers may want to activate or return MapInfo Professional node-locked 
or distributed licenses silently, using a log file for reports. The return process described in this 
section can also return a borrowable license to the server. This section describes these processes.

Activating a Node-Locked or Distributed License Silently

A node-locked license is a permanent license that originates from the Pitney Bowes MapInfo FNO 
server. A distributed license is a permanent license that originates from a License Server owned by 
your company. This same process works for both types of license activations.

Note Before making any hardware changes to your PC (such as disk re-formatting) please 
remember to transfer your activated license back to Pitney Bowes MapInfo or to your License 
Server. After your hardware has been changed you may then re-activate your license. 
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To activate a node-locked or distributed license silently:

1. Collect the information you need to install MapInfo Professional on the client’s computer, 
including the appropriate serial number and access code. For distributed licenses, you also need 
to enter your license server’s name and port number.

2. From the client computer’s command line, type the following and press Enter:
<path to application>\MapInfow.exe -ActivateLicense c:\mylog.txt
where c:\mylog.txt is the path and name of a log file that tracks the details (successes and 
errors) of the activation process. The log file is optional.

Note If you do not specify a log file, as in the example below, the application creates a file 
called activatelicense.log in your temp folder.

<path to application>\MapInfow.exe -ActivateLicense

One of these events occurs:
• If the serial number begins with MID, the application attempts to activate a distributed license 
• If the serial number begins with MIN, the application attempts to activate a node-locked 

license 
• There was an error in the activation process that requires correcting
To view the results of the activation process after it is complete, open the log file with any text 
editor. Possible log file messages include:

Returning a License Silently

Before making any hardware changes to your PC (such as disk re-formatting) please remember to 
return your activated license back to Pitney Bowes MapInfo or to your License Server. After your 
hardware has been changed you may then re-activate your license. 

Message What to Do

Your node lock license was activated 
successfully.

The activation process is complete.

Your distributed license was activated 
successfully.

The activation process is complete.

A license was already activated. No new 
license is activated.

The activation process is complete.

One of the license components is incorrect 
or missing 

Check the log file to see which component (serial 
number, activation code, or for distributed licenses, 
server name or port number) is missing or incorrect.

No license was activated as your license 
appears to be a concurrent or borrow type 
license.

Check your License Server and to review the type(s) 
of licenses that are available. Your client may need 
to get a concurrent or borrow a license instead. See 
MapInfo Licensing and Activation on page 18 for 
more details on these license types.
84 MapInfo Professional 9.5



Chapter 2: What’s New in MapInfo Professional 9.5
You can return a node-locked, borrowed, or distributed license to the Pitney Bowes MapInfo FNO or 
your License Server using these instructions:

• From the client computer’s command line, type the following and press Enter:
MapInfow.exe -ReturnLicense c:\mylog.txt 

where c:\mylog.txt is the path and name of a log file that tracks the details (successes and 
errors) of the return process. The log file is optional.

Note If you do not specify a log file, as in the example below, the application creates a file 
called returnlicense.log in your temp folder.

<path to application>\MapInfow.exe -ReturnLicense

One of these things occurs:
• The license is returned to the Pitney Bowes MapInfo FNO server or your License Server
• An error occurs preventing the return of the license
To view the results of the return process after it is complete, open the log file with any text editor. 
Possible log file messages include:

Message What to Do

Your distributed license was returned 
successfully to the license server 
<ServerName>.

The return process for the distributed license is 
complete.

Your borrowed license was returned 
successfully to the license server 
<ServerName>.

The return process for the borrowed license is 
complete.

Your node license was returned 
successfully to Pitney Bowes MapInfo.

The return process for the node-locked license 
is complete.

If returnable license was found but the 
system could not return it, the system posts 
an error message describing the error.

Check the log file for the details of the error and 
correct the problem either on the client’s 
machine or in your License Server, as needed.

No license was returned as no distributed 
license was found.

Check the About this Product dialog box to 
ensure that the license is distributed and try the 
return process again.

No license was returned as no server 
license was found.

Check your License Server to make sure the 
license is available and the server is up. Then 
try the return process again.

No license was returned as no node- lock 
license was found.

Check the About this Product dialog box to 
ensure that the license is node locked and try 
the return process again.
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New Major Features in MapInfo Professional 9.5
We have been hard at work adding the features you have asked for. In this release of MapInfo 
Professional we have focussed on creating a better map look and feel and better access to new 
formats. We have also 

• Saving WFS Data Changes to the Server on page 86
• New Universal Data Integration and Support on page 90

Saving WFS Data Changes to the Server
If several groups are working with a single dataset, or you are building a centralized database of 
web-based map data, you may be using a Web Feature Service transaction server to manage that 
data. You can now use MapInfo Professional to insert, update and delete records to and from a WFS 
transaction server. Users familiar with the Linked Tables functionality in our application will find this 
workflow similar.

Updating the WFS-T with Data Changes

This is the overall WFS-T transaction process:

1. Retrieve the WFS-T server records you want to update and create a .tab file. 
2. Edit this .tab file data locally using MapInfo Professional. 
3. When your changes are complete, save the changes back to the server and MapInfo 

Professional makes as many changes as it can. 
4. Finally, the application offers to refresh the WFS table after you save it.

Note Remember, features that have changed on the server since you retrieved your local copy 
may be locked and you cannot update them. 

MapInfo Professional checks to see if there are data conflicts for the features you are updating or 
deleting. If the server cannot commit these changes due to data conflicts, an error displays to 
inform you of any failures and, if possible, the reason(s) for those failures. Follow the Conflict 
Resolution steps in Resolving WFS-T Data Conflicts to decide whether to overwrite the server 
changes with yours, leave the data on the server and lose your changes, or skip the record and 
maintain your edits locally. 
See What to Do if You Cannot Complete Transactions for more information in handling your 
data.

5. When the transaction is complete, the web feature service displays a message to show any 
records that were not saved to the server. 
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Saving WFS Data Changes to the Server

To retrieve WFS layers that you can upload and send back to the server:

1. Choose File > Open Web Service > Open WFS to display the Open WFS Table dialog box.

If the WFS server accepts transactions, the Allow Edits check box enables as in this 
example.

2. Select the layer you want to edit from the list and click OK.
3. Make your data edits in MapInfo Professional.
4. Choose File > Save to save your changes to the server.
5. If there are no server conflicts, your changes are saved. A refresh confirmation dialog box 

displays.

6. Click Yes to refresh your table with data from the server. Click No to leave the current data in 
place.
Supplement 87



New Major Features in MapInfo Professional 9.5
Resolving WFS-T Data Conflicts

If the data on the WFS server has changed since you downloaded it, you may not want to make your 
changes right away. The Conflict Resolution subsystem allows you to review the changes to be 
made so you can determine whether to upload your changes anyway or refresh your local layers 
with the server’s changes.

To resolve conflicts with data on the server:

1. Choose File > Open Web Service > Open WFS and select a WFS table in the Open WFS Table 
dialog box.

2. Make your changes to the WFS layer and click Save. If a conflict exists, the Resolve Conflicts 
dialog box displays.

Here, you decide to overwrite the servers data with your data, use the data on the server instead 
of yours, or save your data locally and leave the server data as it is. You can choose to resolve 
conflicts Automatically or Interactively. 
• Automatic Conflict Resolution: Use this method to treat all of the changes you have made the 

same way and either upload them and overwrite the server’s data or save your changes 
locally and leave the server records as they are. This method is faster but less flexible. 

• Interactive Conflict Resolution: Use this method to investigate each record in conflict and 
decide individually which records to overwrite and which records to leave as they are on the 
server. This method is slower but more precise.

3. Automatic Method: If you know you want to overwrite the server data with your edited data in all 
cases, or if you want to keep the server data as it is in all cases, click Automatic. The Resolve 
Conflicts Automatically dialog box displays. Select the appropriate option and click OK. When 
you return to the Resolve Conflicts dialog box, move on to step 5.
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4. Interactive Method: Each record displays individually. For each record, do one of the following:
• To overwrite the server’s data with your changes, click the MapInfo button
• To maintain the server’s data, click the Server button
• To save this data locally and skip this record click Stop Commit

Note Stop Commit stops the entire "save to the server" process. That is, if you are working 
in Interactive Mode and you select Stop Commit, any changes you have accepted up 
to this point are saved locally but are not saved to the server. If you want to commit 
these changes to the server later, begin this process again.

Once you have decided the handling of each record, move on to step 5.
5. After your conflicts are resolved, click OK to confirm your choices. The application applies as 

many changes to the server as possible. 

What to Do if You Cannot Complete Transactions

There are some reasons why you may not be able to update your dataset on a WFS-T enabled 
server, and it is good to keep these in mind:

• Server implements Lock Feature. If the server implements the LockFeature operation, another 
user may have locked a feature you are trying to change. This LockFeature prevents you from 
overwriting the other user’s work. You can wait until the lock is cleared to update the server.

• Server doesn’t conform to standards. Not all WFS servers support transactional capabilities. 
If the WFS-T server does not conform to the OGS specifications, MapInfo Professional may not 
be able to transact data with it. This is likely a permanent failure, until the WFS-T server 
conforms to the OGS standard.

• Server is down. You cannot connect to a server that is not on-line. When this occurs, the best 
practice is to wait until the server is available again to complete your transaction. 

Who can Read .tab Files Created using WFS-T

At Pitney Bowes MapInfo, we try to keep .tab files as backwardly compatible as we can, to preserve 
your investment in our product. Some of the changes to the WFS-T do not allow us to do this for 
MapInfo Professional 9.5. These are the cases and their file format requirements.

Note If you edit a .tab file with WFS-T data in it, you cannot open that .tab file with an earlier 
version of MapInfo Professional. 

If You open a WFS-T Layer and...
Is this Table Compatible with Previous 

Versions of MapInfo Professional?

Save it locally and do not select the Allow 
Edits check box

Yes, pre-9.5 MapInfo Professional users can 
read this .tab file

Make changes and commit them to the WFS-T 
server

Yes, pre-9.5 MapInfo Professional users can 
read this .tab file

Make changes and do not commit them to the 
WFS-T server

No, pre-9.5 MapInfo Professional users cannot 
read this .tab file
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New Universal Data Integration and Support
We have upgraded MapInfo Professional to support for SQL Server 2008. 

To retrieve data from a SQL Server 2008 database:

1. Choose File > Open Universal Data to display the Specify Input Data Source dialog box. You 
may want to review the details of this process in Using Universal Data Directly on page 195.

2. Select the Ellipsis  button beside the Format drop-down box to display the Formats Gallery.

3. Select the Microsoft SQL Server Spatial entry to retrieve SQL Server 2008 data and click OK.
Click the Details button to read a format overview, some quick facts, and to review geometry 
support information when you use this format. 

4. The first time you connect to a SQL Server 2008 database, click Settings to identify the 
database and log in information details of the database. The MS SQL Server Spatial Input dialog 
box displays.

For details in completing this dialog box, see Understanding the MS SQL Server 
Spatial Input Settings Dialog Box.
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5. Enter the server name and database information in the fields provided to access the database 
you want to retrieve data from.

6. Do one of the following:
• Select Use Windows Authentication to use your Windows ID and password to access this 

database. If you select this option, you will be able to open the resulting .tab file or .wor files 
that contain this table without entering a user name or password. You do not have to enter a 
user name or password in the fields provided.

Note Check with your database administrator to ensure that Windows Authentication has 
been enabled on your SQL Server database.

• Select Use SQL Server Authentication to enter a unique ID and password to access this 
database. If you select this option, you will be prompted for this ID and password each time 
you open this .tab file or access it in a workspace.

After the database authenticates your credentials, you are ready to select the table(s) you want 
to display.

7. In the Table List field, select the dataset located on the server you entered. The MS SQL Server 
Spatial Table list displays.

For more information about this dialog box, see the FME Suite Help System.
8. Do one of the following and click OK:

• To select all of the tables in the list, click Select All
• To clear the selection of tables, click Clear All
• To select individual tables in the list, select the check box beside the table
Use the Filter by field to enter a search string to filter a large number of visible tables.

9. The Select Layers dialog box displays. To change the display options of one or more layers, 
select it/them. All layers you select together will share the same display characteristics.
• To change the display options of several contiguous layers, click the name of the first layer, 

press the Shift key, and click the name of the last layer 
• To change the display options of some layers, click the name of the first layer, press the Ctrl 

key, and click the other layers that require the same change
• To change the display options of one layer, click the layer name
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10. Once you have selected the layer(s), use the display buttons to make the style changes you 
require. If the layer(s) contain:
• Point data, click the Symbol Style button to change the symbol options
• Line data, click the Line Style button to change the line options
• Region data, click the Region Style button to change the background options
• Text data, click the Text Style button to change the text options

Note If you want to open maps based on data that is thematically related, assign the same 
styles to all of the layers.

11. Consider the options that affect the whole data source. You can select from these options:
• Use color information from data 
• Do not open empty layers 

12. Specify the path for the saved data in the Directory field. 
13. Select the viewing options from the Preferred View drop-down box. 
14. When you have completed your selections, click OK to open the data according to the settings 

you have specified. 
If the Choose Projection dialog box displays, select the table’s projection and click OK.
A status bar displays to indicate the progress and the data displays.

Note For any terminology that is unfamiliar to you, review the FME Suite Help System.

As a result of this process, you create a .tab file that you can use to create a map. Once the .tab file 
is created, each time you open it or open a workspace that contains it, MapInfo Professional 
retrieves this table using the database entries you have set in these instructions. You do not need to 
repeat this procedure unless you want to retrieve other data from the same database.

Understanding the MS SQL Server Spatial Input Settings Dialog Box

The information about this dialog box is from the FME Help System.

Database Connection

Server
The host name of the MS SQL Server.

Database
The name of the database to access. 

Use Windows Authentication
Specifies whether Windows Authentication should be used to authenticate with the database. 
If this option is selected, the Username and Password fields are ignored.

Use SQL Server Authentication (default)
Specifies whether SQL Server Authentication should be used to authenticate with the 
database. 

User ID
The name of the user who will access the SQL server.

Password
The password associated with the user ID.
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Constraints

Table List
Enter (or browse for) the name(s) of specific database table(s) to extract.

Where Clause
Use this option to limit the rows read from each table. This example selects only the features 
whose lengths are more than 2000:

MSSQL_SPATIAL_WHERE_CLAUSE LENGTH > 2000

Envelope
To extract only a portion of the area covered by the layers you have selected, click the Use 
Search Envelope check box and enter the lower left corner (minimum X and Y) and 
width/height in ground units of the rectangle you need. The application exports all features 
that intersect this area.

Click Clip to Search Envelope to remove any exported features outside the area you need.

Mapping - New and Enhanced Features
We have made several important changes to simplify your work and enhance the look of your maps:

• MapInfo Professional Gets a Face Lift on page 93
• Sharing Map Styles Gets Easier on page 94
• New Features for Custom Symbols on page 95
• Opening Shapefiles with the Projection Automatically on page 99
• New Map Window Changes on page 100
• Label Enhancements on page 101
• Changes to Viewing and Modifying Layer Selections on page 108

MapInfo Professional Gets a Face Lift
We have upgraded the visual elements of MapInfo Professional to make the application more 
visually appealing and consistent with other Windows XP products. If you use MapInfo Professional 
on Windows XP or with Vista, and you have set your current display theme to Windows XP (in the 
Themes or Appearance tabs) or Vista (in the Window Color and Appearance folder) you may notice 
that the dialog box elements display differently:

Classic Windows 2000 Display, Windows XP Display, and Vista Display
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In the future, we will use the new display settings for dialog boxes in the MapInfo Professional 
documentation. There is no change in the product’s functionality due to this enhancement.

Note When you run MapInfo Professional under Windows 2000, the Windows Classic theme 
displays and the XP Theme Style is not available. When you run MapInfo Professional under 
Windows 2003 Server, run the themes services to enable the XP Theme Style. You can 
access this service by choosing Control Panel > Administrative Tools > Services. 

Sharing Map Styles Gets Easier
If you want to share a color or a pattern you use in a map, you may have found it difficult to describe 
the style to another MapInfo Professional user. We have added reference grids to list boxes in the 
Line Style, Region Style, Symbol Style, and Text Style dialog boxes to make it easier for you to refer 
to the colors and patterns you use. Reference grids display by default. 

To close this list, click the Close button in the upper right-hand corner of this list.

In this example, find the intersection of the column letter and the row number that identify the color 
you want to share or use your mouse to hover over the color to display a tool tip with the reference 
information.

To see the reference grid in your Symbol Style list:

1. Choose Options > Symbol Style to display the Symbol Style dialog box.
2. Click the down arrow beside the Color drop-down list to display the reference grid.

Note The process for displaying reference grids is the same for all of the style picker dialog 
boxes.

We have added an option in the Style Preferences dialog box to allow you to display or hide 
reference grids. To hide the reference grids in the style picker lists, choose Options > Preferences 
> Styles and clear the Show reference grid for style pickers check box. To display reference grids 
at any time, select this check box.
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New Features for Custom Symbols
We have added several new features that give you more options and flexibility in working with 
Custom Symbols. 

More Formats Supported for Custom Symbols

You can now add any raster format file as a custom symbol. This includes files that any installed 
raster handler can support, whether the raster handler is supplied with MapInfo Professional or one 
you use independently. 

Since some raster images require more than one file to display, the process for adding multi-file 
raster images is slightly different from those images that display using a single file. Examples of 
these multi-file raster image formats include: *.bil, *.emf, *.gen, *.img, *.ntf. *.url, *.map, *.wmf, *.grc.

Note MapInfo Professional does not support the ArcInfo binary grid coverage files (.ADF files).

To add a raster image as a custom symbol:

1. Choose Options > Symbol Style to display the Symbol Style dialog box.

2. Choose the Custom Symbols option from the Font drop-down list and click Add. The Add 
Custom Symbols dialog box displays.

Note The Files of Type drop-down list only displays the single file formats that are supported, 
including *.bmp; *.gif; *.png; *.jpg; *.jp2; *.j2k; *.pcx; *.psd; *.tif; *.tga; *.ecw. The All 
files (*.*) option allows you to add the image and support files for multi-file format images.
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3. Do one of the following and click Open:
• If you are adding a raster image with a single file format, navigate to the image you want to 

add.
• If you are adding a raster image with a multi-file format, select the All Files *.* option and 

select the all of the files that are part of the image you want to add.

Note You can also copy raster files to the \CUSTSYMB folder subfolder manually. 

4. The Add Custom Symbol Results dialog lists the file(s) you are adding. 

We have widened this dialog box so it is easier to see full path of the file(s) you area 
adding to the Custom Symbols folder. 

5. Click OK to save your image file(s) to the \CUSTSYMB folder.

Note If you add your custom symbols to the Custom Symbols folder manually, click Reload to 
display your new symbol in the Symbol drop-down list.

These new custom symbols do not have any size restrictions, but your system may slow down if you 
use very large (multiple gigabyte) images in your maps. Consider the resolution of your custom 
symbols when you load and display them to prevent this performance issue.
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New GIF Custom Symbols Added

We have added some new .GIF custom symbols from the West London local authorities called Civic 
England that you can use to enhance your maps. These symbols are already in your \CUSTSYMB 
folder and provide an example of the kinds of images you might want to add using the instructions in 
More Formats Supported for Custom Symbols. These symbols represent institutions, leisure, 
and transportation.

To access these custom symbols:

1. Choose Options > Symbol Style to display the Symbol Style dialog box.
2. From the Font drop-down list, select Custom Symbols CivicEngland. We have also added 

several other Civic England folders that group the images according to use. 

Organizing Custom Symbols

Insurance companies and government agencies among others have told us that they use groups of 
custom symbols together to depict various risks or events. Users asked us to help them organize 
these symbols so it would be easier to use them together.

When you want to add a set of custom symbols, you can now add them into subfolders of your 
\CUSTSYMB folder. The name you give the subfolder then appears in the Font list of the Symbol 
Style dialog box so you can use the custom symbol set in your map.
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Adding your New Folder to the Font List

After you add the \CUSTSYMB subfolder and images you want, there are several ways that the 
application can update the Font list.

To add a new folder to the Font list:

1. Using Windows Explorer create a folder under the \CUSTSYMB folder and place the appropriate 
images into it. We recommend that you name this folder in a descriptive way, in case others also 
need to use it. For more about sharing your custom symbols, see Sharing or Not Sharing your 
Custom Symbols. 

2. After these folders and images are copied, you need to update the Font list so they display. 
There are three ways to do this:
• Open MapInfo Professional 
• Choose Options > Symbol Style and select Custom Symbols and select Add to add a 

symbol individually or select Reload
• Use the MapBasic statement Reload Custom Symbols from dir in the MapBasic 

window
Using any of these options prompts the application to search for additional custom symbols 
under the \CUSTSYMB folder.

3. Click the Font drop-down list to display your new folder with the new images in them. In the 
Symbol drop-down list, the images display in alphabetical order, from left to right.

Using the New Fonts

To use one of the fonts you added:

1. Choose Options > Symbol Style and select Custom Symbols CivicEngland from the Font 
drop-down list. 

2. Select the image you want from the Symbol drop-down list and click OK to display it.
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Sharing or Not Sharing your Custom Symbols

Where you keep your \CUSTSYMB folder determines whether you share this folder or not. There are 
four locations that MapInfo Professional will look for the \CUSTSYMB folder:

• To prevent others from sharing your custom symbol folder (default setting): 
C:\Documents and Settings\<yourloginID>\Application

Data\MapInfo\MapInfo\Professional\950\CUSTSYMB\New Subfolders

• To share your custom symbol folder with other users: 
C:\Documents and Settings\All Users\Application

Data\MapInfo\MapInfo\Professional\950\CUSTSYMB\New Subfolders

• To keep your custom symbol folder in a per-computer location:
C:\Documents and Settings\<machine name>\etc...)

• You can also keep the \CUSTSYMB folder in the application folder:
C:\Program Files\MapInfo\Professional\CUSTSYMB\New Subfolders

Opening Shapefiles with the Projection Automatically
MapInfo Professional now reads the native projection of most Shapefiles before creating the .tab file. 
This new process allows you to open the Shapefile more precisely. 

To open a Shapefile:

1. Choose File > Open and navigate to a Shapefile and click Open.

Note If a .tab file exists for the Shapefile you selected, choose the option to overwrite it.

2. Give the .tab file a name and click Save. The Shapefile Information dialog box displays.

You cannot edit the contents of the Projection field directly. 
• If the Shapefile’s native projection is found and it matches an entry in the MAPINFOW.PRJ 

file, the projection’s name displays in the Projection field as shown in the figure above. 
• If a native projection is found but it is not in the MAPINFOW.PRJ file, a message displays in 

this field: Not found in projection file and the name of the native projection displays.
• If a native projection is not found, the name of the currently selected table projection 

preference displays in this field. 
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3. One of the following occurs:
• If the application detects a supported projection, 

MapInfo Professional selects the Use Projection in Source File radio button and the 
Projection button is disabled. Do one of the following:
- To use the detected projection, leave Use Projection in Source file selected and go to 
step 4 
- To choose a new projection, click Choose Projection and click the Projection button to 
select a supported projection. In the Choose Projection dialog box, the source projection is 
highlighted. Select the projection you want and click OK.

Note If you substitute the Shapefile’s native projection with a new one, the application does 
not reproject the Shapefile’s objects and data using the new projection. Substituting 
the Shapefile’s projection in this way may produce unexpected results.

• If the application does not detect the Shapefile’s native projection, or there is no matching 
supported projection in the MAPINFOW.PRJ file, click Projection to select one and click OK.

4. Select the style and cache options for this file.
5. Click OK to create the .tab file and display the Shapefile.

New Map Window Changes
In earlier versions of MapInfo Professional, you were limited to adding four tables, selections, or 
queries to a new Map window at a time. We have redesigned the New Map Window to make it 
easier to add more layers to a new map at once. You can also set the layer order in the New Map 
Window dialog box.

To create a new map from the currently open data:

1. Open your source data in MapInfo Professional.
2. Choose Window > New Map Window to display the New Map Window dialog box.

The layers in the Available Layers list are sorted in the order they were opened, with 
the most recently opened layer at the top.
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3. To select data for the new map, do one of the following:
• Double-click a layer in the Available Layers list on the left to move it into the Layers to include 

in the Map window list on the right

• Click one or more layers in the Available Layers list on the left and click  to move them 
into the Layers to include list on the right. Use Shift and Control to select multiple files.

If you include a layer (or layers) by mistake, select the layer(s) in the Layers to include list and 

click  to return them to the Available Layers list. When you return a layer to the Available 
Layers list, the layer returns to its original position in the list.

4. To move the layers up and down in the Layers to include list, select the layer you want to move 
and position it in the list using the Up and Down buttons.

5. When the Layers to include list contains the layers you want in the right order, click OK to display 
the new map.

Label Enhancements

Labels Look Better in MapInfo Professional 9.5

You may notice that the rotated and horizontal labels that display in your maps look better. We have 
incorporated a new anti-aliasing process that is based on the latest graphic rendering technology. 
This technology helps us improve the realism of your map by removing the "jagged" label and text 
display in low resolution maps.

These label enhancements are also visible in the Layout window, the Browser window (although not 
the Redistricter window), and the Legend window.

Horizontal Labels with Enhanced Rendering Set to None
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Horizontal Labels with Enhanced Rendering Set to Anit-Alias

Setting the Label Options in the Map Window

To use the enhanced rendering options for labels in a Map window:

1. Open your map and display horizontal or rotated labels.
2. Choose Map > Options to display the Map Options dialog box.
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Note Some of the Enhanced Rendering options that display in this dialog box will not be 
completed until the MapInfo Professional 9.5 Maintenance Release. Selecting these 
options will not result in any changes to your map. Please review the Release Notes for 
the Maintenance Release for instructions in using these options.

3. Do one of the following and click OK:
• To enhance (smooth) the display of horizontal or rotated labels, 

select the Smooth Labels drop-down list and choose Anti-alias.
• To display your horizontal or rotated labels more quickly, 

select the Smooth Labels drop-down list and choose None.

Note Using the Anti-alias option causes the labels to be drawn more precisely, which takes more 
time. You may notice that your map takes longer to display after you select this option.

Remember, this feature affects labels that are rotated or horizontal only. Curved labels are always 
drawn with anti-aliasing options.

Display More Labels in your Map Automatically

In the past, customers asked us to get as much label detail into maps as we could. To serve this 
need, we allowed the occasional overlapping autolabel, until your map looked like this.
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Customers then asked us to prevent overlapping labels, which resulted in maps that looked like this:

Customers then asked us to find a way to bring the detail back without the overlapping labels that 
made maps confusing and unreadable. 

To do this, we have added a new feature that detects overlapping autolabels and repositions the text 
around the point, line, or region to avoid overlaps and display more labels. More labels in better 
positions make a more useful map. When you use this new feature, your map can look like this.

To display more labels without overlapping other labels:

1. With the Map open, select Map > Layer Control or  to display the Layer Control dialog box.
2. Scroll down to a layer that contains labels you want to reposition.
3. Click Label to display the Label Options dialog box.
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4. Select the When overlaps occur, try other positions radio button and click OK. This option is 
not available when you select the Allow Overlapping Text radio button. 

5. Click OK again to return to the Map window.

Note This feature applies to Autolabels only. You cannot use this option to reposition custom 
labels. You can position custom labels manually.

MapInfo Professional draws the labels in the layers at the bottom of the Layer Control list first, then 
labels in the layers above them reposition accordingly. If MapInfo Professional cannot find a label 
position that does not overlap another label, the label does not display. 

This type of additional label calculation may take more time to process. You may have to wait longer 
for your map to display.

Displaying More Curved Labels

When a curved label is longer than the polyline it describes, it hangs over or extends beyond the end 
of the polyline. If the label is more than 40% longer than the polyline, MapInfo Professional does not 
display the label by default. For labels within that 40% calculation, MapInfo Professional displays the 
text along the angle of the label’s last character to provide a consistent look. The following figure 
shows labels that extend beyond the end of the polylines they describe.
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Example of streets with extended labels

For this release, you control of the extension percentage and decide what looks best on your map.. 
For example, the following figure displays a neighborhood with labels with a 40% label extension.
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The following figure is the same neighborhood, but the label option is set to a 70% extension. The 
labels of some of the smaller streets now display.

To set the curved label extension percentage:

1. With the map open, select Map > Layer Control or  to display the Layer Control dialog box.
2. Scroll down to a street, highway, ferry, or other polyline layer.
3. Click Label to display the Label Options dialog box.
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4. Click the Curve labels along segments option to enable the Curved labels may extend 
beyond line by slider. Slide the indicator to the extension percentage you want to allow for 
curved labels on the selected layer. 

Note You must set this value for each polyline layer whose labels you want to extend. You can 
set the same or different extensions for each layer, as is appropriate for your data.

Setting a higher value in the Maximum percent field displays more labels. We recommend that 
you experiment with this feature to find the appropriate percentage for your map.
The default extension is 40%, but you can select any value between 0 and 100 using this slider. 
Workspaces you save with this percentage keep the value you select here. When you close 
MapInfo Professional, the percentage of this slider entry reverts to 40% until you reset it in a new 
session.

Note This feature is not available for the Horizontal labels or the Rotate labels with segments 
placement options.

5. When you have completed your entry, click OK to save these settings to your workspace. When 
you return to the map window, you will see the results. 

This is a curved labels feature only. Adding this feature to a workspace sets its version to 9.5, which 
means you cannot open it in a pre-9.5 version of MapInfo Professional or ProViewer.

Changes to Viewing and Modifying Layer Selections
Now, when you make a selection in a layer, you can use the Context Menu to view the entire layer, 
select all from the layer, and make the layer editable. These selections can be points, lines, and 
polygons, but not labels.

Note You must make a selection to enable the new context menu options. Also, if you do not have 
rights to edit the selected table, MapInfo Professional disables these new options.

To perform layer-specific tasks on the current map:

1. With your map open, select a layer you want to change.
2. Right-click your mouse to display the context menu.
108 MapInfo Professional 9.5



Chapter 2: What’s New in MapInfo Professional 9.5
From here you can select one of these options to affect the current layer:
• View Entire Selection Layer to reset the map center and zoom so that all of the selected 

layer is visible 
• Select All from Selected Layer to select all of the objects in the current layer
• Make Selection Layer Editable to enable editing on the selected layer

These new menu options should simplify your ability to view and work with a selected layer. When 
you make a selection in a layer (a table), the layer displays in bold in the Layer Control list. If you 
have more than one instance of the layer open at a time, all of the layers display in bold type.

Important Selection Notes 
• These selection options do not apply to seamless tables. 
• When you make a selection in a Query table, MapInfo Professional selects the base table in 

both the Query window and any other open window that shares the base table.
• You cannot use the Make Selection Layer Editable option to edit read-only tables. 
• If your map contains several layers that are based on the same table, you can only make one 

of those layers editable using the Make Selection Layer Editable command. By default, the 
top-most, selectable, and currently visible layer becomes editable.
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Coordinate System and Datum Enhancements

Belgian EPSG Code Added

We have added a new EPSG Code:

• Belgian National System (7 parameters)\p31370

Croatian Coordinate System

We added the following coordinate system:

• Gauss Kruger zone 5

Egyptian Coordinate System

We have added a new Egyptian coordinate system:

• Egyptian Transverse Mercator

Estonian Coordinate System

We have added a new EPSG Codes for Estonian coordinate systems:

• L-EST97 (EUREF89)\p3301
• L-EST 1992 (EUREF89)\p3300

Fijian Coordinate Systems 

We have added new Fijian coordinate systems:

• Fiji Map Grid (WGS72)
• Fiji Lat/Long(Viti Levu - Clarke 1880 datum)

Finnish Coordinate Systems

We have added new Finnish coordinate systems:

• Finnish Coordinate Systems (2003) Finnish KKJ Zone 0 through Zone 5
• Finnish Coordinate Systems (Old, 1996) Finnish KKJ Zone 0 through Zone 5
• Finnish Coordinate Systems (Old, 1990) Finnish KKJ Zone 0 through Zone 5

French Coordinate Systems

We have added the following coordinate systems:

• Lambert I Carto - Paris (Borne monde)\p27571
• Lambert II Carto - Paris (Borne monde)\p27572
• Lambert III Carto - Paris (Borne monde)\p27573
• Lambert IV Carto - Paris (Borne monde)\p27574
• Lambert I Nord - Paris (Borne monde)\p27561
• Lambert II Centre - Paris (Borne monde)\p275620
• Lambert III Sud - Paris (Borne monde)\p27563
• Lambert IV Corse - Paris (Borne monde)\p27564
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Systèmes français Méridien de Paris (Borne Europe) (V7.8) 

• "Lambert I Carto - Paris (Borne Europe)\p27571
• "Lambert II Carto - Paris (Borne Europe)\p27572
• "Lambert III Carto - Paris (Borne Europe)\p27573
• "Lambert IV Carto - Paris (Borne Europe)\p27574
• "Lambert I Nord - Paris (Borne Europe)\p27561
• "Lambert II Centre - Paris (Borne Europe)\p27562
• "Lambert III Sud - Paris (Borne Europe)\p27563
• "Lambert IV Corse - Paris (Borne Europe)\p27564

Systèmes français Méridien de Paris (Borne France) (V7.8) 

• "Lambert I Carto - Paris (Borne France)\p27571
• "Lambert II Carto - Paris (Borne France)\p27572
• "Lambert III Carto - Paris (Borne France)\p27573
• "Lambert IV Carto - Paris (Borne France)\p27574
• "Lambert I Nord - Paris (Borne France)\p27561
• "Lambert II Centre - Paris (Borne France)\p27562
• "Lambert III Sud - Paris (Borne France)\p27563
• "Lambert IV Corse - Paris (Borne France)\p27564

Systèmes français RGF93 - Méridien de Greenwich (Borne monde)

• "France Lambert-93 (Borne monde)\p21540

Systèmes Français RGF93 - Méridien de Greenwich (Borne Europe) ---"

• "France Lambert-93 (Borne Europe)\p2154

Systèmes français RGF93 - Méridien de Greenwich (Borne France

• "France Lambert-93 (Borne France)\p2154

DOM-TOM IGN

• "Réunion, RGR92 - UTM 40S - IGN\p2975
• "PDN-Gauss Laborde Réunion-IGN\p2990
• "Antilles Françaises, RRAF1991 - UTM 20SN - IGN\p2989
• "Guadeloupe, Ste Anne- UTM 20N- IGN\p2970
• "Guadeloupe, Fort Marigot- UTM 20- IGN\p2969
• "Martinique, Fort Desaix- UTM 20- IGN\p2973
• "Guyane, RGFG95 - UTM 22N - IGN\p2972
• "Guyane, CSG67- UTM 22N- IGN\p2971
• "Guyane, RGFG95 - UTM 21N - IGN\p3313
• "Guyane, CSG67- UTM 21N- IGN\p3312
• "Nouvelle Calédonie, Grande Terre - UTM 58S - IGN72\p3060
• "Nouvelle Calédonie, Maré - UTM 58S - IGN53\p2995
• "Nouvelle Calédonie, Lifou - UTM 58S - IGN56\p2981
• "Mayotte, Combani1950 - UTM 38S - IGN\p2980
• "Mayotte, RGM04 - UTM 38S - IGN
• "Mayotte, Cadastre 1997 - UTM 38S - IGN
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• "St Pierre et Miquelon - UTM 21N - IGN1950\p2987

Systèmes français Méridien de Greenwich (MIW avant 3 - Obsolète) 

• "Lambert I Carto - Greenwich (Obsolète)
• "Lambert II Carto - Greenwich (Obsolète)
• "Lambert III Carto - Greenwich (Obsolète)
• "Lambert IV Carto - Greenwich (Obsolète)
• "Lambert I Nord - Greenwich (Obsolète)
• "Lambert II Centre - Greenwich (Obsolète)
• "Lambert III Sud - Greenwich (Obsolète)
• "Lambert IV Corse - Greenwich (Obsolète)

Réunion IGN

• "Réunion, RGR 92 - UTM 40 sud - IGN 1989\p10012
• "PDN-Gauss Laborde Réunion IGN\p4626

LABORDE Madagascar

• "Laborde Madagascar (mètre)
• "Laborde Madagascar (kilomètre)
• "Laborde Madagascar

German Coordinate Systems

We have added bounded coordinate systems:

• Gauss-Kruger (DHDN) bounded Zone 1 through 5

Irish Coordinate System 

We have updated our Irish Coordinate System as follows: 

• Irish Grid
• Irish Transverse Mercator (ITM)

Libyan Coordinate Systems

We have added new Libyan coordinate systems:

• LTM 2 Zone 5 through 13
• LTM 2 Zone 13
• UTM Zone 32 (LGD 2006) through UTM Zone 35 (LGD 2006)
• LTM 16

155 - A new Datum for Libya (LGD 2006) its parameters:

Ellipsoid - International

ShiftX = 208.4058 m
ShifYy = 109.8777
ShiftZ = 2.5764 m
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Netherlands Coordinate System

We have added a bounded coordinate system:

• Netherlands National System (mm acc)

Polish Coordinate Systems

We have added new coordinate systems:

• "PUW 42/GK Zone (Pulkowo 1942)\p3333
• "PUW 42/GK Zone 4 (Pulkowo 1942)\p3334
• "Poland ETRS89 / CS92\p2180
• "GUGiK 80\p3328
• "Universal polar stereographic (WGS84)
• "Polish Lambert conformal
• "1965/1\p3120
• "1965/2\p2172
• "1965/3\p2173
• "1965/4\p2174
• "1965/5\p2175
• "ETRS89 / Poland CS2000 zone 5\p2176
• "ETRS89 / Poland CS2000 zone 6\p2177
• "ETRS89 / Poland CS2000 zone 7\p2178
• "ETRS89 / Poland CS2000 zone 8\p2179

Romanian Coordinate System

We have added two Romanian Coordinate Systems as follows: 

• Romanian Stereo 1970
• Romanian Transverse Mercator

156 - Dealul Piscului 1970 datum for Romania

Krassovsky Ellipsoid #3
Shift X = 28
Shift Y = -121
Shift Z = -77

Swedish Coordinate System

We have added a new coordinate system:

• ST74\p3152
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Turkish Coordinate Systems

We gave added the following coordinate systems:

• UTM Central Meridian 27 Zone 35 (ED50)
• UTM Central Meridian 30 (ED50)
• UTM Central Meridian 33 Zone 36
• UTM Central Meridian 36 (ED50)
• UTM Central Meridian 39 Zone 37 (ED50)
• UTM Central Meridian 42 (ED50)
• UTM Central Meridian 45 Zone 38 (ED50)
• GK Central Meridian 27 (GRS80)
• GK Central Meridian 30 (GRS80)
• GK Central Meridian 33 (GRS80)
• GK Central Meridian 36 (GRS80)
• GK Central Meridian 39 (GRS80)
• GK Central Meridian 42 (GRS80)
• GK Central Meridian 45 (GRS80)
• UTM Central Meridian 27 Zone 35 (GRS80)
• UTM Central Meridian 33 Zone 36 (GRS80)
• UTM Central Meridian 39 Zone 37 (GRS80)
• UTM Central Meridian 45 Zone 38 (GRS80)

Database Features
The following are the database changes for this version of MapInfo Professional.

Updated Codes Ensure Oracle 11g Compatibility
We have updated our list of coordinate system projection codes to include the Oracle 11g SRIDs. 
This ensures that .tab files based on Oracle tables contain the correct coordinate system reference 
so MapInfo Professional can display your data correctly. Where there is more than one coordinate 
system definition that matches a SRID, we have added those additional entries as well. This should 
ensure that your Oracle 11g data opens in the right projection every time.

Create Maps from Oracle 11g Tables with Annotation Text 
We have added new functionality that allows you to display Oracle 11g Annotation Text correctly in 
your MapInfo .tab file. This data can be linked or live access.

When you download an Oracle 11g table that contains an Annotation Text column, MapInfo 
Professional reads the annotation text geometry and creates a text object. This text object contains 
arrays of objects consisting of the actual text string, the location at which the text is to be rendered, a 
leader line object, and any style attributes that have been saved with the object. For this version we 
are only supporting one annotation element for each record. 

Note A single annotation_text object in Oracle can contain all of the map's text objects.
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If the table contains both an Annotation Text field and another Geometry field or fields, MapInfo 
Professional prompts you to select the information you want to display. When the application opens 
the table, it displays only what you have specified in the Map Catalog, whether it was a geometry 
field or the Annotation Text field. See A Note about Opening Tables with Multiple Geometry 
Columns on page 116.

Oracle also has a metadata table that stores and retrieves information related to the Annotation Text 
objects in the table. This metadata is called user_annotation_text_metadata, which is, the 
MapScale, the text expression (default string), and the text attributes (such as font name, font color, 
size, etc.). The last two fields are defaults if the actual table records for these fields are set to NULL..

Before you can download the Oracle 11g table, you have to make it mappable so you can display it. 

Note We assume that you have the Oracle 11g client installed. Annotation text is a new feature of 
this Oracle release and is not available on earlier versions of the DBMS.

To open a table with Oracle 11g annotation text in it:

1. Choose Table > Maintenance > Make DBMS Table Mappable to open a DBMS connection. 
See Opening a Connection to an Oracle Spatial Data Source on page 245 for specific 
instructions, if needed. At the end of this process the Select DBMS Table displays.

2. Select the Oracle table from the list and click Open. The Make Table Mappable dialog box 
displays.

Note When Oracle Annotation Text displays in the Index Type drop-down list, then you know 
that the table contains an annotation text field.

3. Select Oracle Annotation Text from the Index Type drop-down list to display the annotation text 
as part of the table. MapInfo Professional only displays the geometry that is selected in the this 
list.

Note If you select Oracle Annotation Text, the other geometry information does not display.

4. If the Projection button is enabled, the application could not identify the projection of your table 
from the Oracle metadata. Select a projection for this table using the Projection button or accept 
the default Latitude/Longitude setting that is assumed by default.
If the Projection button is disabled, the application has read the projection information from the 
Oracle metadata and will use that projection to display the file.
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5. Click OK to make the table mappable. If the table is large, you may see a progress bar until a 
confirmation message displays. Click OK to clear the message.

6. Choose File > Open and open the mappable table you just created. The Open DBMS Table 
Options dialog box displays.

7. In this dialog box, select the appropriate button to open the table linked or live. 
8. Under the Standard Mode option, click Column Filter. The Column Picker dialog box displays.

9. To display the Annotation Text in the new map, double-click TEXTOBJ in the Available column to 
move it to the Selected column.
If there are additional geometry fields in this table, such as the GEOLOC field in the example 
above, do not move it (them) from the Available list to the Selected list with the TEXTOBJ entry. 

10. Click OK to return to the Open DBMS Table Options dialog box. and display the table with 
annotation text.

<image>

Note Tables with Annotation Text in them are not editable.

A Note about Opening Tables with Multiple Geometry Columns

Remember, when you display annotation text, you cannot also display other geometry column data 
from the same table. If you try to open an Oracle table with Annotation Text and other geometry 
columns, you may see the following error:

Unsupported data type for column(s): TEXTOBJ Unable to fetch 
records into table.

Use the Column Picker dialog box to specify which columns to open to avoid this error. 

Annotation Text Sample Available

If you use an Oracle 11g database and want to try the Annotation Text feature in this release, we 
have provided annotation text examples on the Data CD. You can find this Oracle script in the 
\AnnotationLabels folder of the Introductory_Data directory.
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Dragging and Dropping Table Columns Added
We have added new feature that allows you drag and drop columns in the Table Maintenance dialog 
boxes. This functionality is available in both the New Table Structure and the Modify Table Structure 
dialog boxes. This capability should make it easier to reorder the columns in a table.

To drag and drop a column in a selected table:

1. Open the table you want to change the column layer structure for.
2. Choose Table > Maintenance > Table Structure. One of the following occurs:

• If you have more than one table or workspace open, the View/Modify Table Structure list 
displays. Select the table you want to modify and click OK to display the Modify Table 
Structure dialog box.

• If you have only one table open, the Modify Table Structure dialog box displays.

3. Click the column you want to move and drag it to the new position in the list. A small blue arrow 
shows the position of the column you are dragging. You can repeat this process for each column 
you want to reposition.

4. Click OK to save your change(s). 

Miscellaneous Features
The following features may be of interest to some users:

• .NET Programmability Capabilities Introduced
• New Drawing and Editing Tools and Toolbars Available
• Tell Us What You Think!
• MapInfo Professional Printing Guide Available in Help
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.NET Programmability Capabilities Introduced
MapBasic programs can now call functions and subroutines written using Microsoft's .Net 
development platform. You can write code in languages such as C# (C-sharp) and VB.Net (Visual 
Basic for .Net), using Microsoft's Visual Studio development environment. Then you can call those 
.Net routines from your MapBasic programs.

Even if you are not a MapBasic programmer, you can see a demonstration of this new capability by 
running the "Named Views" MapBasic tool (Nviews.mbx). The Named Views dialog box has been 
replaced with a .Net dialog, to take advantage of .Net capabilities. The new Named Views dialog is 
resizable, and it displays the named views (map bookmarks) in a hierarchical tree, where you can 
organize your views by dragging and dropping.

The MapBasic development environment is a free download available from MapInfo.com. To get 
your copy, click the link below or go to www.mapinfo.com and type MapBasic Overview in the 
Search field. There is also information there about building custom applications and integrating 
MapInfo Professional into your application using the MapBasic development environment.

http://extranet.mapinfo.com/products/Download.cfm?ProductID=1063&productcategoryid

A Demonstration of .Net Capabilities Already Implemented

If you are a .Net developer who wants to add GIS features to your application or you want to build 
mapping solutions of your own, you may want to take advantage of MapInfo Professional’s robust 
feature set. In this release, code you write in the Microsoft Visual Studio development environment 
(using, for example, C# or VB .Net) can now call functions and subroutines in the MapBasic 
development environment.

To see a demonstration of this new functionality, run the Named Views MapBasic tool from the Tool 
Manager. We have autoloaded this tool for you so you do not have to. Make sure open a map before 
using this tool.

To use the Named Views tool:

1. Display the map at the exact position and zoom level you want to return to.
2. Select Tools > Named Views > Named Views to display the Named Views dialog box.
3. Click Add and type a description of the current map view. Click Add to save your description.

When you add a named view, MapInfo Professional creates an XML file with the map location so 
you can go to it later. This XML file is located along the following path:
C:\Documents and Settings\USERNAME\Application Data\

MapInfo\MapInfo\Professional\950\nviews.xml
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New Drawing and Editing Tools and Toolbars Available
Pitney Bowes MapInfo has made a contractual arrangement to include the MapCAD tools software 
on the installation CD. This product provides tools that work with MapInfo Professional to create 
maps that are appropriate for land development and surveying tasks. MapCAD requires MapInfo 
Professional 9.5 or later to run.

To install the MapCAD tools, save the zip file to your computer and unzip the files into the \tools 
subfolder under your MapInfo Professional installation folder. Then add the MapCAD MBX using the 
Tool Manager (Tools > Tool Manager > Add Tool).

Note There is no menu for this tool. Individual tools display on floating toolbars. These toolbars 
display when you load or autoload the tool.

The manufacturer provides a full help system to assist you in using this product. For support, contact 
MapCAD Incorporated directly. Their web site is:

http://www.geoas.de

Tell Us What You Think!
Want to give MapInfo Professional Engineers feedback? We have created a new option in the 
Help menu so you can provide direct product feedback to Pitney Bowes MapInfo! If you have a need 
for a new feature, or you need our product to do something it doesn’t currently do, use this feature to 
write to us. Whether you want to complain or complement, let us know so we can meet your MapInfo 
Professional needs better. 
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To send us feedback:

• Choose Help > Send Product Improvement Suggestions to display the customer 
feedback form.

Our team of Product Managers and Engineers will collect your feedback and consider your request 
in a future release of MapInfo Professional. You will be able to track the activity on your suggestions 
through different statuses and maintain a list of your ideas or suggestions. Your suggestions will be 
grouped with other similar ideas to help us build a list of new features and workflows for the 
application. You may be invited to give your feedback on the scoping and implementation of these 
suggestions and participate in surveys that help us narrow down the priority of the features we are 
working on. 

The goal of this new feature is to ensure that MapInfo Professional stays on the forefront of your 
needs and product requirements. Help us do that important work for you!

MapInfo Professional Printing Guide Available in Help
Over the years, users have told us that the MapInfo Professional Printing Guide helps them print 
large or complex maps or layouts. You can now access the MapInfo Professional Printing Guide, 
which contains printing tips and tricks from our Quality Assurance department, in the Help System.

To access the Printing Guide in the Help System:

• Choose Help > MapInfo Professional Help Topics > Productivity Aids > MapInfo 
Professional 9.5 Printing Guide.

Data Enhancements
For this release of MapInfo Professional, we have updated the introductory and sample data we 
provide with the product.

• Data Updates for this Release
• Understanding your Introductory and Sample Data

Data Updates for this Release
The following data files have been added or updated:

Introductory Data Updates
• Updated US_Zips (updated April 2008)
• Updated USZipbdy (updated October 2006)
• Added Workspaces (Introductory_Data\NorthAmerica\USA\Workspaces\)
• Curved Labels Updates
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Sample Data Additions
• Added a Cadastral Parcel Sample for Washington, D.C. (NAD 83) (updated January 2008)
• Added a contiguous Mississippi River table
• MapInfoBankBranches for Connecticut (Updated October 2007)
• Updated all StreetPro Samples
• Added 7 Countries to StreetPro samples including Austria, Denmark, France, Ireland, 

Norway, Portugal, Switzerland
• Updated all Telco Boundaries (updated March 2008)
• Updated Telco Data: Rate Centers (updated March 2008)

- Areacodes (updated March 2008)
- PSAP Boundaries (updated March 2008)
- LATA Boundary (updated March 2008) PopInfo, ExchangeInfo

• Added another Washington DC workspace to show Parcel Data
• Updated Business Points Samples (updated January 2008)

Updated StreetPro Data
• UK to v9.0
• Switzerland to v9.0
• Ireland to v9.0
• Espana (Spain) to v 8.5
• Ireland to v9.0

Updated the USA Workspace in the Workspcs folder
• Turned on curved labeling and anti-alias for labels (smoothing)
• USA Map with anti-alias and curved labels enabled
• Updated default workspaces (US, CAN, Mexico, Europe) by enabling smooth labeling

(these workspaces now have a version 950 stamp in the .wor file)
• Removed  USGS_REF and Mapinfo - Us_Roads_States_Capitals.WOR 

(due to File reference error on WMS Server)
• Removed GLOBE - World_States and Provinces_Rivers_Topography.WOR 

(due to reference error on WMS Server)

Understanding your Introductory and Sample Data 
If you install the data from the data CD that is shipped with MapInfo Professional, you will notice that 
it has the following folder structure and data presentation. We use the term Introductory Data to 
describe the data you can use to geocode locally and to enhance the maps you create in every 
session. The Sample Data folder provides examples of other types of data that are available from 
Pitney Bowes MapInfo.

To provide more room for data in the future, we have decided to ship a separate data CD with 
MapInfo Professional. Here is the folder structure and data presentation for the introductory and 
sample data that is shipped with MapInfo Professional. We use the term Introductory Data to 
describe the data you can use to geocode locally and to enhance the maps you create in every 
session. The Sample Data folder provides examples of other types of data that are available from 
Pitney Bowes MapInfo.
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The Introductory_Data folder is structured as follows:

NorthAmerica
\Canada

\Can_WMS
\Workspaces

\Mexico
\Workspaces

\USA
\AnnotationLabels
\Dem
\Demographics

\Census2000
\Cnty
\Docs
\State

\USA_Maps
\US_WMS

\USRaster
\Workspaces

World
\Africa

\Workspcs
\Asia

\China
\Workspcs

\India
\Workspcs

\Japan
\Workspcs

\Australia
\Workspcs

\Europe
\Aust_Swz
\Benelux
\France
\Germany
\Greece
\Iberia
\Italy
\Scand
\UK
\UKCrimeExample
\Workspcs

\World_WMS
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The Sample Data shows you examples of the other MapInfo data products that may be useful to 
you. The SampleData folder is structured as follows:

Geographic
\AirPhotoUSA
\StreetPro Samples

\StreetPro_Austria
\StreetPro_Belgium
\StreetPro_Canada
\StreetPro_Denmark
\StreetPro_Deutschland
\StreetPro_Espana
\StreetPro_France
\StreetPro_Great_Britain
\StreetPro_Ireland
\StreetPro_Italy
\StreetPro_Netherlands
\StreetPro_Norway
\StreetPro_Portugal
\StreetPro_Sweden
\StreetPro_Switzerland
\StreetPro_US

Industry_Data
\Business Points

\UseCase
\Insurance

\TelcoData
\AreaCodeInfo
\CarrierInfo
\ExchangeInfoPlus
\LataInfo
\MediaPrints
\POPInfo
\PSAP_Pro
\RateCenterInfo
\Workspaces

\Weather

There are industry-specific sample workspaces and updated the samples that ship with the MapInfo 
Professional application to enhance your maps and geocoding. To make space for this new data, we 
have removed the indexes from all of the data except the USZIPBDY.TAB, US_ZIPS.TAB, and the 
US_CNTY.TAB files. You need the indexes for these files to maximize your ability to geocode to ZIP 
code boundaries and centroids and county centroids.
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Installing the Free Data Locally

To install the free data locally:

• Place the Data CD in the CD drive and follow the prompts that display according to the needs of 
your implementation of MapInfo Professional. 

CAUTION: If you want to install this data in addition to your existing product data, you need 
to specify a new folder to ensure that your current data is maintained. 
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Directory of MapInfo 
Professional Shortcuts
This section contains a comprehensive list of the shortcuts available in the 
MapInfo Professional application. You can create custom shortcuts by editing 
the MAPINFOW.MNU file using a text editor.

CAUTION: Making changes to the MAPINFOW.MNU file may cause 
the default shortcuts you change to stop working. Make 
these changes carefully and record your changes so you 
can change them back, if necessary.

Topics in this Section:

Shortcuts for File Menu Items. . . . . . . . . . . . . . . . . . . . . . . . . . . .126
Shortcuts for Edit Menu Items  . . . . . . . . . . . . . . . . . . . . . . . . . . .126
Shortcut to Tools Menu Items . . . . . . . . . . . . . . . . . . . . . . . . . . . .126
Shortcuts to Objects Menu Items . . . . . . . . . . . . . . . . . . . . . . . . .127
Shortcuts for Query Menu Items. . . . . . . . . . . . . . . . . . . . . . . . . .127
Shortcuts for Options Menu Items . . . . . . . . . . . . . . . . . . . . . . . .127
Shortcuts for Map Menu Items . . . . . . . . . . . . . . . . . . . . . . . . . . .127
Shortcut for Layout Menu Item . . . . . . . . . . . . . . . . . . . . . . . . . . .128
Shortcuts for Window Menu Items . . . . . . . . . . . . . . . . . . . . . . . .128
Shortcuts by Keystroke . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .129



Shortcuts for File Menu Items
Shortcuts for File Menu Items

Shortcuts for Edit Menu Items

Shortcut to Tools Menu Items

Menu Item Keystrokes

File > New Table Ctrl+N

File > Open Ctrl+O

File > Save Table Ctrl+S

File > Save Workspace Ctrl+K

File > Print Ctrl+P

File > Exit Alt+F4

Menu Item Keystrokes

Edit > Undo Ctrl+Z

Edit > Cut Ctrl+X

Edit > Copy Ctrl+C

Edit > Paste Ctrl+V

Edit > Clear Del

Edit > Reshape Ctrl+R

Edit > New Row Ctrl+E

Edit > Get Info F7

Menu Item Keystrokes

Tools > Run MapBasic Prog Ctrl+U
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Shortcuts to Objects Menu Items

Shortcuts for Query Menu Items

Shortcuts for Options Menu Items

Shortcuts for Map Menu Items

Menu Item Keystrokes

Objects > Set Target Ctrl+T

Objects > Clear Target Ctrl+Delete

Menu Item Keystrokes

Query > Unselect All Ctrl+W 

Query > Find Ctrl+F

Query > Find Selection Ctrl+G

Menu Item Keystrokes

Options > Line Style Shift+F8

Options > Region Style Ctrl+F8

Options > Symbol Style Alt+F8

Options > Text Style F8

Menu Item Keystrokes

Map > Layer Control Ctrl+L

Map > Create Prism Map F10

Map > Create 3D Map F11
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Shortcut for Layout Menu Item
Shortcut for Layout Menu Item

Shortcuts for Window Menu Items

Map > Create Thematic Map F9

Map > Modify Thematic Map Alt+F9

Map > Previous View Alt+Left Arrow

Menu Item Keystrokes

Layout > Previous View Alt+Left Arrow

Menu Item Keystrokes

Window > New Browser F2

Window > New Mapper F3

Window > New Grapher F4

Window > New Layout F5

Window > Redraw Window Ctrl+D

Window > Tile Windows Shift+F4

Window > Cascade Windows Shift+F5

Menu Item Keystrokes
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Shortcuts by Keystroke

Menu Items Keystrokes

Map > Previous View and 
Layout > Previous View 

Alt+Left Arrow

File > Copy Ctrl+C

Window > Redraw Window Ctrl+D

File > New Row Ctrl+E

Query > Find Ctrl+F

Query > Find Selection Ctrl+G

File > Save Workspace Ctrl+K

Map > Layer Control Ctrl+L

File > New Table Ctrl+N

File > Open Ctrl+O

File > Print Ctrl+P

File > Reshape Ctrl+R

File > Save Table Ctrl+S

Objects > Set Target Ctrl+T

Tools > Run MapBasic Program Ctrl+U

File > Paste Ctrl+V

Query > Unselect All Ctrl+W 

File > Cut Ctrl+X

File > Undo Ctrl+Z

Objects > Clear Target Ctrl+Delete

Window > New Browser F2

Window > New Mapper F3

Window > New Grapher F4

Window > New Layout F5
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File > Get Info F7

Options > Text Style F8

Map > Create Thematic Map F9

Map > Create Prism Map F10

Map > Create 3D Map F11

File > Exit Alt+F4

Options > Symbol Style Alt+F8

Map > Modify Thematic Map Alt+F9

Options > Region Style Ctrl+F8

Window > Tile Windows Shift+F4

Window > Cascade Windows Shift+F5

Options > Line Style Shift+F8

Edit > Delete Del

Menu Items Keystrokes
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Term Definition

3DMap A window that allows you to view your maps containing continuous grids from various 
viewpoints in 3D Format.

Add Node 
Button 

Use the Add Node button to add a node to regions, polylines, and arcs. You can add 
nodes when the Reshape tool is in effect. Adding nodes can give more precision to your 
object.

Address 
Dictionary

The search dictionary used for matching addresses during geocoding.

Alias The name assigned to an expression or a column when you are working in the Select 
Columns field in the SQL Select dialog box. This name appears as the column title for 
that expression or column in a Browser.

Application A computer program used for a particular kind of work, such as word processing. 
Application is often interchangeable with the word program.

Arc Button The Arc button allows you to access the Arc tool. Use the Arc tool to draw an arc the size 
and shape of one quarter of an ellipse. Once you have created an arc, you can reshape it 
to the desired size.

ASCII The acronym for American Standard Code for Information Interchange. ASCII is a 
standard code used in most microcomputers, computer terminals, and printers for 
representing characters as numbers. It not only includes printable characters, but also 
control codes to indicate carriage return, backspace, and so forth.

Assign 
Selected 
Objects Button 

Use this button to permanently assign all selected map objects to the target district.

Axis Used in a graph, these are graduated lines bordering the plot area of a graph. Location 
coordinates are measured relative to the axes. By convention the X-axis is horizontal, the 
Y-axis is vertical.

Bar Chart A type of thematic map that displays a bar chart of thematic variables for each record in a 
table from which the map is based.

Base Map Usually the dominant or underlying layer in a given map. (These are typically the data 
layers that Pitney Bowes MapInfo® offers as ready products.) Users usually layer their 
own data on top of these base maps or use these base maps to geocode or to make new 
layers. Examples are joining industry data to postal code boundaries for analysis and then 
combining arrangements of the postal codes into new territory layers.

Base Table A permanent table, which is part of a map, as opposed to a query table, which is 
temporary. You can edit the contents of base tables, and you can change their structure 
(by editing, deleting, reordering columns and adding or deleting graphic objects).
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Bitmap A screen image displayed as an array of dots or bits. Software usually generates either bit-
mapped (raster) or object-oriented (vectored) files. MapInfo Professional can work with 
both.

Boundary 
Region

In GIS a boundary is a region on a map enclosed by a border. Cambria County, Manitoba, 
and Argentina would all be represented as boundaries on a map. Note that a single 
boundary could encompass several polygons. Thus, Indonesia is a single boundary but 
consists of many polygons.

Boundary 
Select Button 

The Boundary Select button allows you to access the Boundary Select tool. Use the 
Boundary Select Tool  to search for and choose all the objects within a given region, such 
as a state or county boundary, a police patrol district, a sales territory, and so forth.

Browser A window for viewing a table (or database, spreadsheet or text file) in tabular form.

Buffer A type of proximity analysis where areas or zones of a given distance are generated 
around selected map objects. Buffers are user-defined or can be generated for a set of 
objects based on those objects’ attribute values. The resulting buffer zones form region 
objects representing the area that is within the specified buffer distance from the object.

Cadastral A map set used to graphically define the cadastre or land ownership in a given area. A tax 
map is an example of a cadastral map. The land registration, assessment roles, and tax 
maps comprise the cadastre.

Cancel Button A command button for closing a dialog box without making changes.

Cartesian A coordinate system using an x,y scale not tied to any “real-world” system. Most CAD 
drawing uses this method of registering objects (for example, a drawing of a ball-bearing 
assembly, floor plans). If a drawing uses Cartesian coordinates, one corner of the drawing 
probably has coordinates 0, 0. 

Cartesian 
Coordinates

The conventional representation of geometric objects by x and y values on a plane.

Cartographic 
Legend

A MapInfo Professional legend window that enables you to display cartographic 
information for any map layer in the Map window.

Cartography The art and science of making maps. In GIS it is also the graphic presentation and visual 
interpretation of data.

Term Definition
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Centroid Usually the center of a map object. For most map objects, the centroid is located at the 
middle of the object (the location halfway between the northern and southern extents and 
halfway between the eastern and western extents of the object). In some cases, the 
centroid is not at the middle point because there is a restriction that the centroid must be 
located on the object itself. Thus, in the case of a crescent-shaped region object, the 
middle point of the object may actually lie outside the limits of the region; however, the 
centroid is always within the limits of the region. 

In MapInfo Professional, the centroid represents the location used for automatic labeling, 
geocoding, and placement of thematic pie and bar charts. If you edit a map in Reshape 
mode, you can reposition region centroids by dragging them.

Change View 
Button 

This button allows you to change the zoom, map scale, and window centering aspects of 
the Map or Layout that currently displays.

Check Box A small square box that appears in a dialog box. You can click in the check box or on the 
text in order to select the option. Check boxes are generally present when multiple options 
can be selected at one time. 

Click To press and release a mouse button quickly.

Column A column in a Browser corresponds to a field in a table. A column contains a specific type 
of information about an object, such as Name, Abbreviation, Land area, Price, Population, 
and so forth. The information for each object is listed on a row in the Browser.

Command A word or phrase, usually found in a menu, that displays a dialog box and/or carries out an 
action.

Conflict 
Resolution

When conflicts exist between the data residing on a remote database and new data that 
you want to upload to the remote database via a MapInfo Professional linked table. The 
conflict resolution process is invoked whenever an attempt to save the linked table detects 
a conflict in an update.

Control Menu A menu activated through the Control Menu Box located in the upper left corner of all 
windows. The control menu is used to resize, move, maximize, minimize, or close the 
window.

Control Points The points on a raster image whose coordinates serve as a reference for associating earth 
coordinates with any location on the image. See Registration on page 144.

Coordinate An x,y location in a Cartesian coordinate system, or a Latitude, Longitude location in an 
earth coordinate system. Coordinates represent locations on a map relative to other 
locations. Earth coordinate systems may use the equator and the Greenwich prime 
meridian as fixed reference points. Plane coordinate systems describe a two-dimensional 
x,y location in terms of distance from a fixed reference and are usually in the first quadrant 
so that all coordinates are positive numbers.
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Coordinate 
System

A coordinate system is used to create a numerical representation of geometric objects. 
Each point in a geometric object is represented by a pair of numbers. Those numbers are 
the coordinates for that point. In cartography, coordinate systems are closely related to 
projections. You create a coordinate system by supplying specific values for the 
parameters of a projection. See Cartesian Coordinates on page 133, Projection on 
page 143, and Spherical Coordinates on page 145.

Cosmetic Layer The topmost layer of a Map window. Objects may be placed in this layer such as map titles 
and graphic objects. It is always displayed, and all objects placed in the Cosmetic Layer 
must be saved to a new or existing layer.

Data 
Aggregation

A process that occurs when combining separate map objects into a single object. MapInfo 
Professional calculates what the column values for the new object should be, based on 
sums or averages of the values of the original objects.

Data 
Disaggregation

A process that occurs when splitting a map object(s) into smaller parts where MapInfo 
Professional splits the data associated with the map object(s) into smaller parts to match 
the new map objects.

Data Sources An ODBC data source is an SQL database and the information you need to access that 
database. For example, an SQL Server data source is the SQL Server database, the 
server on which it resides, and the network used to access that server. 

Database Any organized collection of data. The term is often used to refer to a single file or table of 
information in MapInfo Professional.

Decimal Degree The decimal representation of fractions of degrees. Many paper maps express 
coordinates in degrees, minutes, seconds (for example, 40_30i10I), where minutes and 
seconds are fractions of degrees. 30 minutes equal half a degree, and 30 seconds equal 
half a minute. MapInfo Professional, however, expresses coordinates in decimal degrees 
(for example, 72.558 degrees), where fractions of degrees are expressed as decimals. 
Thus, the longitude: 40 degrees, 30 minutes, would be expressed in MapInfo Professional 
as 40.5 degrees.

Default The value or option used in the absence of explicit specification. Often the original setting 
or value for a variable.

Degrees 
Longitude, 
Degrees 
Latitude, 
Decimal 
Degrees

Degrees (longitude and latitude) are coordinates used to represent locations on the 
surface of the earth. Longitude, or X-coordinate, represents a location’s east-west 
position, where any location west of the prime meridian has a negative X value. Latitude, 
or Y-coordinate, represents a location’s north-south position, where any location south of 
the equator has a negative Y value.

Derived 
Column

In a table created through the SQL Select, a derived column is one created by using an 
expression. The column is derived in the sense that it isn’t just a copy of the data in one of 
the tables being accessed by the SQL Select command.
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Derived Field The same as a derived column.

Deselect The process of undoing a selection. The object or area you deselect will not be affected by 
subsequent commands. Performed by selecting another area, by clicking in a blank area, 
or by executing the Unselect All command.

Digitizer, 
Digitizing 
Tablet 

An electronic device that lets you trace a paper map into a GIS or CAD package. The 
digitizer consists of a table (or tablet) onto which you attach a paper map. You then can 
trace the map by moving a hand-held, mouse-like device known as a cursor, or puck, 
across the surface. Digitizing a map produces vector data as the end result.

Districts 
Browser

A special browser that displays when redistricting. It differs from other Browser windows in 
the following respects: one row can only be selected at one time, one row is always 
selected, and the selected row becomes the target district into which you can add other 
objects.

Dot Density 
Map 

A type of thematic map that carries information by showing a large number of tiny dots, 
wherein each dot represents some specific unit quantity. For example, for a population dot 
density map each dot might represent 10,000 people. 

Drawing 
Toolbar

A MapInfo Professional window containing twelve buttons that access tools for drawing 
and modifying objects on your map or layout.

Edit Handle The small boxes that appear at the four corners of the minimum bounding rectangle of an 
object in an editable layer of a Map window or in a Layout window.

Ellipse Button The Ellipse button allows you to access the Ellipse tool. Use the Ellipse tool to create 
elliptical and round objects.  

Export The process whereby a program saves information in a file to be used by another 
program.

Expression A statement containing two parts: 1) column names and constants (for example, specific 
data values), and 2) functions (for example, area) and operators (for example, +, -, >), in 
order to extract or derive information from a database. Expressions are used in Select, 
SQL Select, Update Column, Create Thematic Map, and Label with Column. 

Field A field in a table corresponds to a column in a Browser. A field contains a specific type of 
information about an object, such as, name, abbreviation, land area, price, population, and 
so forth. The record for each object consists of that object’s values for each of the fields in 
the database.

File A collection of information that has been given a name and is stored on some electronic 
medium such as a tape or disk. A file can be a document or an application.

Fill Pattern The design and color used to fill a closed object.
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FLEXNet 
Operations 
module (FNO)

The Pitney Bowes MapInfo database that maintains product entitlements and information 
about their activation.

Font A character set based on a particular style used for text characters.

Frame Button The Frame button allows you to create frames in a layout. Each frame can display a map, 
graph, Browser, map legend, graph legend, Info window, statistics window, and message 
window or, it can be an empty frame. 

Generalization The process of simplifying a data set to a size that can be easily manipulated and 
represented. For example, a river may have many twists and turns; however, if a map 
covers a very large area, the river may be represented as a straight line. Similarly, in a 
map of a very large area, a city might be represented as a point marker. 

Geocode The process of assigning X and Y coordinates to records in a table or database so that the 
records can be displayed as objects on a map.

Geographic 
Information 
System (GIS)

An organized collection of computer hardware and software designed to efficiently create, 
manipulate, analyze, and display all types of geographically or spatially referenced data. A 
GIS allows complex spatial operations that are very difficult to do otherwise.

Grabber Button The Grabber Button allows you to access the Grabber tool. Use the Grabber tool to 
reposition a map or layout within its window. 

Graduated 
Symbols Map 

A type of thematic map that shows symbols (point objects) in a variety of sizes to indicate 
which objects have higher or lower numerical values.

Graph window A window that displays numerical data in the form of a graph.

Graticule A grid of horizontal (latitude) and vertical (longitude) lines displayed on an earth map, 
spaced at a regular distance (for example, every five degrees, every fifteen degrees). 
Used to establish a frame of reference.

Grid Surface 
Map

A type of thematic map that displays data as continuous color gradations across the map. 
This type of thematic map is produced by an interpolation of point data from the source 
table. A grid file from the data interpolation is generated and is displays as a raster image 
in a Map window. 

Heads-Up 
Digitizing

A method of digitizing where the user creates vector objects by tracing over a raster image 
displayed on the screen. Thus, heads-up digitizing does not require a digitizing tablet. 

Help Button Bar A bar located at the top of the Help Window that contains buttons you use to move to Help 
topics.

Horizontal 
Scroll Bar 

The Horizontal scroll bar appears at the bottom of the MapInfo Professional window. Use 
the horizontal scroll bar to move left and right. The scroll box inside the scroll bar indicates 
your horizontal location. You can use the mouse to scroll to other parts of the window.
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Hot Views MapInfo Professional technology that automatically updates all the windows you have 
open for a particular table when you make a change in any one of the windows. For 
example, if an item is selected in a Map window, it will be selected in all other Map 
windows and Browsers you have open for that table.

Import The process whereby a program loads a file that is the output of another program.

Individual 
Values Map

A type of thematic map that shades records according to individual values.

Inflection The process of deviating the color in ranged thematic maps to emphasize some numerical 
significance. In thematic mapping we insert a new color between the top and bottom color 
for second interpolation of data.

For example, suppose we were showing population growth with blue representing an 
increase in population growth and red representing a decrease in population growth.

We could have white as the inflection color for a range that has zero or almost zero 
population growth, so that lighter shades of blue would represent a smaller population 
growth and lighter shades of red would represent a smaller decline in population.

Info Button The Info button allows you to access the Info tool. Use the Info tool to select a location on 
your map, including multiple overlapping objects and display a list of all objects at that 
location. You can then choose an object from the list and view the tabular data for that 
object. 

Islands Small areas outside the main boundary that can be reached within the specified time or 
distance. 

IsoChrone An IsoChrone is a polygon or set of points representing an area that can be traversed from 
a starting point in a given amount of time along a given road network. 

IsoDistance An IsoDistance is a polygon or set of points representing an area that can be traversed 
from a starting point travelling a given distance along a given road network.

Isogram An Isogram is a map that displays a set of points that satisfy a distance or time condition. 
Isograms are either IsoChrones or IsoDistances. 

Join The process of creating a relational link between two tables (databases). 

Latitude The horizontal lines on a map that increase from 0 degrees at the Equator to 90 degrees 
at both the North (+90.0 degrees) and South (-90.0 degrees) poles. Used to describe the 
North-South position of a point as measured usually in degrees or decimal degrees above 
or below the equator. 
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Layer A layer is a basic building block of MapInfo Professional maps and consists of a table with 
graphic and text settings like style override, labeling, and zoom layering. Maps are made 
of one or more superimposed layers (for example, a layer of street data superimposed 
over a layer of county or postal code boundaries) which you can design to convey 
geographical or statistical information. Typically, each map layer corresponds to one open 
table. Cosmetic Layers contain map objects that represent temporary map annotations 
(for example, text objects). Cosmetic Layers contain map objects that represent temporary 
map annotations (for example, labels). See Cosmetic Layer on page 135 and Table on 
page 146.

Layer Control 
Button 

The Layer Control Button allows you to access the Layer Control dialog box. This dialog 
box allows you to specify how the various tables in a Map window are layered and 
displayed. See Accessing Layer Control on page 148.

Layout Window A window where you arrange and annotate the contents of one or several windows for 
printing.

Legend The part of a map, which explains the meaning of different colors, shapes, or fill patterns 
used on the map. See also Cartographic Legend on page 133.

Legend Frames Each legend window contains one or more legend frames each corresponding to a style or 
theme layer in the Map window.

Legend 
Window 

A window containing legend frames. You can create more than one legend window for 
each map. The legend window can contain more than one frame. For example, you can 
have one legend window containing four legend frames, or you can have four legend 
windows, each containing one legend frame.

Legend 
Window Button 

Use the Legend Window button to display the Legend window associated with maps or 
graphs. 

Line, Line 
Object

A map object defined by a set of sequential coordinates that may represent the 
generalized shape of a geographic feature (for example, street centerlines, railroads, 
cables). A Pitney Bowes MapInfo street map is a collection of thousands of line objects.

Line Button The Line button allows you to access the Line tool. Use the Line tool to draw straight lines.  

Line Style 
Button 

Use the Line Style button to access the Line Style dialog box. The Line Style dialog box 
allows you to set the line type, thickness and color of line objects (lines, arcs and 
polylines) and borders of closed objects. You can also change the type, thickness and 
color of objects you are editing. 

Linked Table A linked table is a special kind of MapInfo table that is downloaded from a remote 
database and retains connections to its remote database table. You can perform most 
operations on a linked table that you do for a regular MapInfo table.
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Longitude The vertical lines on a map, running from the North to South poles, used to describe the 
east-west position of a point. The position is reported as the number of degrees east (to -
180.0 degrees) or west (to +180.0 degrees) of the prime meridian (0 degrees). Lines of 
longitude are farthest apart at the Equator and intersect at both poles, and therefore, are 
not parallel.

Longitude/ 
Latitude

MapInfo Professional’s default coordinate system for representing geographic objects in a 
map.

Main Toolbar A window containing buttons for choosing tools, accessing dialog boxes, and showing or 
hiding windows.

Map Catalog The MapInfo map catalog stores information about the location of spatial columns on the 
DBMS. There must be one catalog per database. The EasyLoader application can create 
this catalog for each database: Oracle 8, 9, Informix, SQL Server, and MS Access. 
Additionally, you can create a map catalog manually with instructions in the MapInfo 
Professional User Guide. This is a one-time only task per database and is required before 
any tables on that database can be mapped in MapInfo Professional.

Map Scale A statement of a measure of the map and the equivalent measure on the earth. Often 
expressed as a representative ratio of distance, such as 1:10,000. This means that one 
unit of distance on the map (for example, one inch) represents 10,000 of the same units of 
distance on the earth.

The term scale must be used carefully. Technically, a map of a single city block is large–
scale (for example, 1:12,000), while a map of an entire country is small–scale (for 
example, 1:1,000,000). A 1:1,000,000 map is considered small-scale because of the small 
numeric value obtained when you divide 1 by 1,000,000. 

Map Segment In a street map, a segment is a single section of the street. In urban maps, segments are 
generally one block long. Address ranges are stored at the segment level.

MapBasic The programming language used to customize and/or automate MapInfo Professional. To 
create MapBasic applications, you need the MapBasic compiler, which is a separate 
product. However, you do not need the MapBasic compiler to run a compiled MapBasic 
application.

Map window A window that allows you to view a table as a map.

Meridian A line or a portion of a line running from the North to the South pole. A longitudinal line.
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Military Grid 
Reference 
System 

The U.S. Military Grid Reference System (MGRS) is a grid reference system that MapInfo 
Professional supports when displaying maps in a Map window. It is the military version of 
the civilian-use Universal Transverse Mercator (UTM) grid system. Military grid references 
are very similar to the mathematical Cartesian x,y system in which coordinates are giving 
in terms of x (easting) and y (northing). 
In this system, the world is generally divided into 6° by 8° geographic areas, each of which 
is given a unique identification, called the Grid Zone Designation. These areas are 
covered by a pattern of 100,000-meter squares. Each square is identified by two letters 
called the 100,000-meter square identifications. A reference keyed to a gridded map of 
any scale is made by giving the 100,000- meter square identification together with the 
numerical location. Numerical references within the 100,000-meter square are given to the 
desired accuracy in terms of the easting (E) and northing (N) grid coordinates for the point. 
The Grid Zone Designation usually is prefixed to the identification when references are 
made in more than one grid zone designation area. 

Minimum 
Bounding 
Rectangle 
(MBR) 

For any given map object, the smallest rectangle that completely encompasses the object. 

Native 
Projection

The projection in which a map’s coordinate points are stored. MapInfo Professional allows 
you to display maps in other projections, but not as fast as displaying maps in their native 
projection.

Node An end-point of a line object, or an end-point of a line segment which is part of a polyline 
or region object. 

Non-Earth Map A map in which objects are not explicitly referenced to locations on the earth’s surface. 
Floor plans are typical examples.

ODBC Drivers An ODBC driver is a dynamic-link library (.DLL) file that MapInfo Professional uses to 
connect to an SQL database. Each type of SQL database requires a different ODBC 
driver.

ODBC Table An ODBC table is a table residing in a remote SQL database.
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OSGB 
MasterMap 
GML Files 

Many of our international customers want to display MasterMap GML files developed by 
the Ordnance Survey of Great Britain (OSGB). We provide support for some of the 
Topography features (OSGB version 2.0), Topographic Area, Lines and Points, 
Cartographic Symbols and Boundary Lines. 

We maintain support for these features and add support for Cartographic Text and 
Departed Features. MapInfo Professional will continue to support GML files as the OSGB 
updates the schema that underlies the GML technology. 

As the GML format gets more sophisticated in its support of additional layers, feature 
types, and attributes, we will continue to provide full support for those changes. Currently, 
we support the OSGB recommended styles by mapping the style definitions to existing 
MapInfo Professional styles. Where it is not possible to render complicated fill patterns, we 
use the simple dot screen that the OSGB recommended to us. The OSGB style mapping 
to MapInfo styles is hard coded so it cannot be changed. 

For more information about OS MasterMap see 
www.ordsvy.gov.uk/os_mastermap/home/home.htm.

Outer Join A type of multi-table join where all the records in the specified tables are included in the 
result table, even records that do not match the join criteria. MapInfo Professional does 
not perform outer joins.

Pack The process of compressing MapInfo tables so that they use less disk space.

Pie Chart Map A type of thematic map that displays a pie chart of thematic variables for each record in 
the table from which the map is based.

Pin Map, Push-
Pin Map 

A type of map named after the practice of inserting push-pins into a wall map. A pin map 
features point objects. Geocoding a database is one way of creating a pin map. 

Pixel The acronym for picture element. The smallest dot that can be displayed on a computer 
screen. If a screen is described as having a resolution of 1,024 x 768, the screen shows 
1,024 pixels from right to left, and 768 pixels from top to bottom. Each character, object, or 
line on the screen is composed of numerous pixels.

Point, Point 
Object

A map object defined by a single X,Y coordinate pair. Each point object is represented by 
a symbol style (for example, circle, square, triangle, etc.). 

Point Size A unit of measurement equal to 1/72 of an inch. Used to measure character size.

Pointer An arrow-shaped cursor on the screen that can be manipulated by a mouse.

Polygon, 
Polygon Object

A simple bounded region, simple in the sense that it does not consist of more than one 
polygon (where a boundary can consist of more than one polygon). The Polygon tool 
creates a single polygon.

Polygon Button The Polygon button allows you to access the Polygon tool. Use the Polygon tool to draw 
polygons one side at a time. 
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Polygon 
Overlay

A spatial operation that merges overlapping polygons from two layers to analyze those 
intersected areas or to create a third layer of new polygons.

Polyline, 
Polyline Object

A linetype object made up of many line segments. It contains more than two nodes, that is, 
more than its end points. The Polyline tool creates a single polyline. In contrast, the Line 
tool only draws a single straight line (that is, a line defined by two nodes).

Polyline Button The Polyline button allows you to access the Polyline tool. Use the Polyline Tool to draw 
polylines (a connected sequence of lines that are not closed). 

Projection A mathematical model that transforms the locations of features on the earth’s surface to 
locations on a two-dimensional surface, such as a paper map. Since a map is an attempt 
to represent a spherical object (the earth) on a flat surface, all projections have some 
degree of distortion. A map projection can preserve area, distance, shape or direction but 
only a globe can preserve all of these attributes. Some projections (for example, Mercator) 
produce maps well suited for navigation. Other projections (for example, equal-area 
projections, such as Lambert) produce maps well suited for visual analysis. 

Query Table A temporary table produced as the result of a Select, SQL Query, or by choosing objects in 
a Map window or records in a Browser and mapping, graphing, or browsing that selection. 
You cannot make edits and structural changes on query tables, but you can edit a selected 
set of rows in your source table through a query table. See Selection on page 145 and 
Base Table on page 132.

Radius Select 
Button 

The Radius Select button allows you to access the Radius Select tool. Use this tool to 
select all of the objects within a certain radius. See Using the Radius Select Tool on 
page 294.

Ranged Map A type of thematic map that displays data according to ranges set by the user. The ranges 
are shaded using colors or patterns.

Raster Image A type of computerized picture consisting of row after row of tiny dots (pixels). Raster 
images are sometimes known as bitmaps. Aerial photographs and satellite imagery are 
common types of raster data found in GIS. A computer image can be represented in raster 
format or in vector format. See Scanning on page 144 and Vector Image on page 148. 

Record All the information about one object in a database or table. A record in a table corresponds 
to a row in a Browser.

Rectangle 
Button 

The Rectangle button allows you to access the Rectangle tool. Use the Rectangle tool to 
draw rectangles and squares.  

Redistricting The process of assigning map objects to groups. As you assign map objects, MapInfo 
Professional automatically calculates totals for each group and displays the totals in a 
special Districts Browser. This process is sometimes known as load-balancing.

Reference 
Grids

A matrix of letters and numbers that assist users in some style dialog boxes that identify 
specific line styles, colors, and patterns.
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Region, Region 
Object 

An enclosed area defined by one or more polygons. If a region contains one or more lakes 
or islands, each lake or island is a separate polygon. A region is an object created with the 
Polygon tool. 

Region Style 
Button 

Use the Region Style button to access the Region Style dialog box. The Region Style 
dialog box allows you to specify the color, pattern, and borderline style of closed objects. 
You can also change the color and pattern of objects you are currently editing. 

Registration Usually the first stage of the digitizing process or when opening a raster image for the first 
time in MapInfo Professional. Before you can digitize a paper map or work with a raster 
image, you must point to several control points across the map, and enter their 
coordinates (for example, longitude, latitude). After you have registered the map, MapInfo 
Professional can associate a longitude, latitude position with any point on the map 
surface; this allows MapInfo Professional to perform area and distance calculations, and 
overlay multiple map layers in a single map. CAD systems as well as GIS systems utilize 
this process. See Control Points on page 134.

Reshape 
Button 

The Reshape button toggles you in and out of Reshape mode. Use reshape to edit 
regions, polylines, lines, and points by moving, adding, and deleting nodes that define line 
segments. You can also copy and paste selected nodes to create new polylines. Reshape 
is very useful when you are creating sales territories or other merged boundaries. For 
example, you are merging ZIP Code boundaries to create school districts. Some ZIP Code 
boundaries fall into more than one school district. Use the Reshape button to reshape the 
school district to incorporate a section of the ZIP Code boundary. See Reshaping Map 
Objects on page 280.

Result Code Result codes indicate whether a geocode match was made and the type of match it was, 
and conveys information about the quality of the match. The result code is an 
alphanumeric code of 1-10 characters. 

Rounded 
Rectangle 
Button 

The Rounded Rectangle button allows you to access the Rounded Rectangle tool. Use the 
Rounded Rectangle tool to draw rounded rectangles and squares. 

Ruler Button The Ruler button allows you to determine the distance between two points and the length 
of some path.  

Run MapBasic 
Program 
Button 

The Run MapBasic Program button accesses the Run MapBasic Application dialog box 
where you specify the MapBasic program you want to run. 

Scale Bar A map element that graphically depicts the map scale (for example, 0 —— 5 —— 10 km).

Scanning The process of inputting data into a raster format using an optical device called a scanner.

Scroll Bar Bars along the right and bottom sides of each window that allow you to scroll the window 
view. Clicking on the shaded area moves one window screen at a time. 
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Select Button The Select button allows you to access the Select tool. Use the Select tool to select one or 
more objects or records for analysis. You can also use the Select tool to edit a map, layout 
or browser. See Selecting a Single Object from a Map or Layout on page 293.

Selection A data item or set of data items chosen for inspection and/or analysis. Regardless of the 
kinds of windows on the screen, selections can be made using the Select and SQL Select 
Query commands in MapInfo Professional’s Query menu. In Browsers and Map windows, 
items can be placed in the selection set by clicking on them individually. Map windows also 
have special tools for selecting multiple items on a spatial basis.

Set Target 
District from 
Map Button 

Use this button to make the selected object's district the new target district. See 
Redistricting on page 143.

Show 
MapBasic 
Window Button 

The MapBasic window button allows you to display or hide the MapBasic window. You can 
perform many different tasks by typing commands into the MapBasic window. Choosing 
items from MapInfo Professional’s menus could instead perform those same tasks. There 
are times, however, when it is easier to type commands into the command window.  

Snap To Nodes A feature that helps in drawing, moving and positioning map objects. In Snap mode (S 
key) the cursor snaps to a node of a map object when it comes within a certain distance. 

Source Table A permanent table, as opposed to a query table, which is temporary. You can edit the 
contents of source tables and you can change their structure (by editing, deleting, 
reordering columns and adding or deleting graphic objects). You cannot make edits and 
structural changes on query tables but you can edit a selected set of rows in your source 
table through a query table.

Spatial 
Analysis

An operation that examines data with the intent to extract or create new data that fulfills 
some required condition or conditions. It includes such GIS functions as polygon overlay 
or buffer generation and the concepts of contains, intersects, within or adjacent.

Spherical 
Coordinates

Latitude and longitude values that represent objects on the surface of the globe.

SQL 
(Structured 
Query 
Language) 

A standard language used for analyzing information stored in relational databases. 
MapInfo Professional’s database engine is based on the SQL standard.

SQL Query The selection of information from a database according to the textual attributes and object 
relationships of the items. In MapInfo Professional, queries are created with the SQL 
Select and Select commands or with MapBasic commands in the MapBasic window.

Standard 
Deviation

A measurement of the variation of a set of data values around the mean.
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Standard 
Toolbar

A window containing buttons for quick access to the most commonly used menu 
commands such as Cut, Copy, and Paste.

Statistics 
Button 

Use the Statistics button to display the Statistics window. The Statistics window tallies the 
sum and average of all numeric fields for the currently chosen objects/records. The 
number of records chosen is also displayed. As the selection changes, the data is re-
tallied, and the statistics window is updated automatically. See Redistricting on page 143

Statistics 
Window

A window containing the sum and average of all numeric fields for the currently selected 
objects/records. The number of records selected is also displayed. As the selection 
changes, the data is re-tallied, and the statistics window updates automatically.

StatusBar A bar at the bottom of the screen that displays messages that help in using MapInfo 
Professional. The StatusBar also displays messages that pertain to the active window. In a 
Map window, the StatusBar indicates what layer is editable, the zoom display of the map, 
and the status of Snap and Digitizing modes. In a Browser window, the StatusBar 
indicates the number of records currently displaying and the total number of records. In a 
Layout window, the StatusBar indicates the zoom display as a percentage of the actual 
size of the map.

Structured 
Query 
Language 
(SQL)

A standard language used for analyzing information stored in relational databases. 
MapInfo Professional’s database engine is based on the SQL standard.

Subselect A select statement that is placed inside the Where Condition field of the SQL Select 
dialog box. MapInfo Professional first evaluates the subselect and then uses the results of 
the subselect to evaluate the main SQL Select statement.

Symbol, 
Symbol Object

A small, relatively simple shape (for example, square, circle, star, push-pin) used to 
graphically represent a point object (for example, a customer location). 

Symbol Button The Symbol button allows you to access the Symbol tool. Use the Symbol tool to place 
point symbols (push pins) on your map

Symbol Style 
Button 

Use the Symbol Style button to access the Symbol Style dialog box. The Symbol Style 
dialog box allows you to display symbols and specify attributes for symbols. The attributes 
you can specify are size, color, and symbol type. You can change the attributes of existing 
symbols and specify attributes for new point objects before you create them. The point 
objects must reside, or be created in an editable layer. See Symbol, Symbol Object.

Table A table is made up of data in rows and columns. Each row contains information about a 
particular geographic feature, event, etc. Each column contains a particular kind of 
information about the items in the table. You can display tables with graphic information 
stored in them as maps. See Base Table on page 132 and Query Table on page 143. 
See also Layer on page 139.
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Table Row In a table, a row contains all the information for a single item. It corresponds to a record in 
a table.

Target District The district that is selected in a Districts Browser to be affected by subsequent redistricting 
operations.

Text Button Use the Text Button to add titles, labels, and annotations to maps and Layouts. You can 
also use the Text Tool to rotate text with its edit handle. 

Text Cursor A blinking vertical bar that shows the position where text can be edited, inserted, or 
deleted.

Text Style 
Button 

Use the Text Style button to access the Text Style dialog box. The Text Style dialog box 
allows you to choose a font and font settings for your text. 

Thematic Layer A layer containing the thematic settings for a map layer. Thematic layers are drawn 
directly over the map layer on which the thematic settings are based. They are also drawn 
in a particular order, depending on the number of thematic layers you have and the type of 
thematic map objects you are creating. 

Thematic Map A type of map that uses a variety of graphic styles (for example, colors or fill patterns) to 
graphically display information about the map’s underlying data. Thus, a thematic map of 
sales territories might show one region in deep red (to indicate the region has a large 
number of customers), while showing another region in very pale red (to indicate the 
region has relatively few customers). 

Thematic 
Shading

Map objects — points, lines, regions — that have been shaded, using a pattern and/or 
color, according to some point of information about the object, or theme (population, size, 
annual rainfall, date, and so forth). 

Thematic 
Variable

The data values displayed on a thematic map. A thematic variable can be a field or 
expression.

Theme Legend MapInfo Professional’s original style legend that allows you to display legends for thematic 
maps and graphs. MapInfo Professional automatically creates a theme legend window for 
a thematic map. Customize its display through the Modify Thematic Map dialog box. See 
Cartographic Legend on page 133. 

Toolbars MapInfo Professional windows that contain a variety of buttons used to access tools and 
commands for mapping and drawing. There are four Toolbars: the Standard Toolbar 
provides tools for commonly performed tasks, the Main Toolbar provides primary tools (for 
example, Zoom-in, Select, Info, etc.) and the Drawing Toolbar contains all drawing tools. 
The Tools Toolbar contains the Run MapBasic Program and the Show/Hide MapBasic 
Window buttons. Toolbars may be reshaped and hidden.

Transformation The process of converting coverage coordinates from one coordinate system to another 
through programmatic translation. The transformation of CAD generated Cartesian 
coordinates into earth coordinates is an example.
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Ungeocode The process of removing X and Y coordinates from records in a table or database. Can 
also describe a table that has not been geocoded, such as an ungeocoded table.

Vector Image A coordinate-based data structure commonly used to represent map features. Each object 
is represented as a list of sequential x,y coordinates. Attributes may be associated with 
the objects. A computer image can be represented in vector format or in raster format. See 
Raster Image on page 143.

Vertical Scroll 
Bar 

The Vertical scroll bar appears at the right of the most windows. Use the vertical scroll bar 
to move up and down. The scroll box inside the scroll bar indicates your vertical location. 
You can use the mouse to scroll to other parts of the window.

Web Feature 
Services

A Web Feature Service (WFS) client retrieves geospatial GML (Geography Markup 
Language)2 data using HTTP GET and HTTP POST requests over the Internet or through 
a private intranet. The WFS client was developed in accordance with the 1.0.0 OpenGIS® 
Web Feature Service Implementation Specification, which is available online: 
http://www.opengeospatial.org/standards/wfs.

Web Map 
Services 

A Web Map Service (WMS) is a technology that gives you a source for data over your 
Intranet or over the Internet. This innovation is based on a specification from the Open 
GIS Consortium (OGC) and allows you to use raster map images from servers that also 
comply with the specification. An important element of this is that the WMS images are 
registered using the data’s coordinate system so the WMS layer can be used with vector 
and other registered raster images. 

This specification supports transparent pixel definition for image formats as well. This 
allows you to use the images you retrieve as overlays and not solely as the bottom layer of 
your map. This is a very new technology and WMS may not exist for the geography you 
are looking for. Further, the WMS Server determines the data that is provided. See 
Retrieving Map Data from Web Map Services in the Help System.

Web Service A web service is a software system that is accessible using an intranet or Internet 
connection. Web services allow you to retrieve data that others are sharing internally or 
world-wide. The power of web services is that you can use them to create more powerful 
maps or in the case of geocoding or drive region services get more accurate and precise 
results using the same data.

Weighted 
Average

An average that gives more weight to one value over another when averaging. A method 
of averaging that uses a separate column of information to define the relative importance 
of each data value. The formula for a weighted average is: 

SUM(DATA*WEIGHT)/SUM(WEIGHT)

where DATA is the column of data values and WEIGHT is the column of weights. If 
WEIGHT contains all 1’s (or other non-zero values) this reduces to a simple average.

Window In MapInfo Professional, Map windows, Browser windows, Graph windows and Layout 
windows are the major types of windows. They display the data stored in tables. The 
Toolbars, map legends, and the Info tool window are other types of windows.
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Workspace A saved configuration of open MapInfo tables and windows. 

Zoom-in Button The Zoom-in button allows you to access the Zoom-in tool. Use the Zoom-in Tool to get a 
closer area view of a map or a layout. See Zoom Layering.

Zoom-out 
Button 

The Zoom-out button allows you to access the Zoom-out tool. Use the Zoom-out tool to 
get a wider area view of a map or a layout. See Zoom Layering.

Zoom Layering A setting that determines the range (for example, 0–3 miles, 2–5 miles, etc.) at which a 
layer is visible in a Map window.
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