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MapInfo Professional 10 
Printing Guide

The purpose of this guide is to assist you in getting the best possible output from your MapInfo 
Professional software. We begin by covering the new print, import, and export features and 
continue with preferences and printing options available in MapInfo Professional. Then we give 
you some helpful tips and tricks and finally we help you trouble shoot issues you may be 
experiencing with your own use of MapInfo Professional.

We have updated this document with new features and new resolutions to existing issues.

Sections in this Document:

New in this Release
Printing in MapInfo Professional
General Printing Tips and Tricks
Resolutions to Known Printing Issues
Enhancements Added in Earlier Versions

New in this Release
PDFs are capable of holding multiple pages of information in the same space 
through the use of Optional Content Groups (OCG), which are more commonly 
known as layers. Layers in PDFs are very similar to MapInfo Professional map 
layers.

Each layer may hold any portion of the document's objects and layers may be 
made visible or invisible, showing or hiding their contained objects, in any 
combination. By selectively hiding layers, you reduce distractions to concentrate 
on particular areas or types of objects. Layers can be organized into groups and 
the visibility option can apply to all layers within a group as one step.

To print a map window or a layout window to a layered PDF:

1. From the File menu, select Print. The Print dialog box displays.
2. From the Name list, select MapInfo PDF Printer Version 10.0. This PDF 

driver is installed with MapInfo Professional.
3. Optionally, click Properties to set any printing preferences.
4. Click OK to print to a layered PDF file.

Note that it may take some time to process a large map with many layers.

When saving a layout window to a layered PDF, each frame (such as map frame 
and legend frame) becomes a layer in the PDF.

You can continue to use a different PDF driver, not the MapInfo PDF Printer 
Version 10.0. Doing so creates a static PDF map without layer information, so you 
do not have the ability to turn on or off particular map layers.

http://www.mapinfo.com
http://www.mapinfo.co.uk
http://www.mapinfo.com.au


Restrictions when Printing to a Layered PDF

The PDF layers do not correspond exactly to the map layers as shown in the Layer Control in MapInfo Professional. 
The PDF layers appear in an order that is exactly reverse of the order in which map layers are shown in the Layer 
Control. This does not affect the map output in the PDF. Labels in a map window save to a separate layer in the PDF 
with a name that includes the parent layer name. Adornments save as a separate Adornments layer in the PDF. An 
empty Cosmetic layer does not save to the PDF. Embedded legends in Mapper windows that export to the PDF file do 
not toggle on or off in the PDF.

There are some conditions that generate a flat PDF with no layers: 

• When map or layout windows (containing vectors or rasters) have translucent layers.
• When raster or grid layers with transparency have enhanced rendering turned on.
• When map or layout windows have anti-alias set to smooth text and labels (after setting the Smooth Text & Labels 

enhanced rendering option to Anti Alias for a map or layout).
• After selecting the Print using Enhanced Metafile (EMF) check box in the Advanced Printing Options dialog box.
• After enabling printosbm in the registry.

Printing in MapInfo Professional
Before you start printing your map or your graphs, you may want to create a new layout so you can arrange your 
graphs, maps, legends, titles, etc. for the best effect. Choose Windows > New Layout Window to put together a more 
effective presentation. We recommend that you use layout windows for printing because it ties directly to the printer 
driver.

To print a map, layout, or graph from MapInfo Professional:

1. When you have your map or layout the way you want it, choose File > Print to display the Print dialog box.

Note: When you print a layout, the Options button does not display. When you print a graph, the Advanced 
button does not display.

2. Select the printer or plotter you want to use for this workspace from the Name drop-down list. The properties that 
are available for this device are printer/plotter dependent. Please check your device manufacturer’s manual for 
property details. 

Note: Any selections you make in the Properties options will override the selections made in the preferences 
for the current print session.

3. Select the print range of your output and the number of copies you want in the appropriate fields.

4. To set further map print options, click the Options button to display the Map Print Options dialog box.

Note: You cannot select these options for a layout.

5. Make your selections and click OK to return to the Print dialog box.

Map Size
Select the size of the map in this group; the options are Window Size, Fit to Page, and Custom. As you make 
selections, the Custom Scale, Custom Width and Custom Height entries change.

Window Size. Click this button to print the map as it displays on your computer screen.

Fit to Page. Click this button to fit the map to the page size you selected in preferences.

Custom. Click this button to enter your own custom scale, width, and height entries in the fields provided.
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Map Contents

Select an option in this group to determine the map contents you want to print; the options are Same as 
Window and Centered on Window.

Same as Window. Click this button to print the map contents as it appears in the Map window, with the same 
proportions and content as you see.

Centered on Window. Click this button to center as much of the current map that fits on the page. When you 
select this option, the image may print on more than one page depending upon fit. In general when you select 
this option, MapInfo Professional assumes you want to select the Fit to Page radio button and selects this for 
you.

6. To set the advanced print options, click Advanced to display the Advanced Printing Options dialog box.

Note: You cannot select these options for a graph.

7. Select the appropriate options in this dialog box and click OK to return to the Print dialog box. These options are 
the same as those you select in the Output Settings Preferences dialog box. Selecting options here overrides the 
setting you selected in the Output Settings preferences for the current print session.

Output Method
There are two output methods.

• Print Directly to Device. Use this option to print your image file directly from MapInfo Professional. This is the 
default setting and is same printing from all versions before 6.0.

• Print Using Enhanced Metafile (EMF). Use this option to generate an enhanced metafile of your MapInfo 
Professional image before sending it to the printer. This option takes advantage of current technology to shrink 
the spool size and print your file quicker without sacrificing quality.

Print Border for Map Window
Select this check box to print a black border around the image you are printing. Clear this check box to print the 
image without a border. This check box is selected by default.

Internal Handling for Printing Transparent Vector Fills and Symbols
Special programming has been added to handle transparent fill patterns and bitmaps for vector images when 
you print. Select this check box to use this functionality or clear it to let the printer or plotter to manage this type 
of work. This check box is selected by default.

Scale Patterns 
Select this check box to print non-transparent fill patterns that look like what you see on your screen. This check 
box is checked by default. Clear this check box to let the printer driver have exclusive control over rendering the 
pattern fills.

Use ROP Method to Display Transparent Raster
Select this check box to allow the internal ROP (Raster Overlay by Pixel) to manage the transparent pixels 
when printing raster images. Since the ROP Method is largely a display method, not all printers and plotters can 
use it. We recommend that you experiment with this setting until you get the results you want when printing 
raster images. This setting has no effect when printing vector layers. This check box is cleared by default.

Print/Export Raster in True Color When Possible
Select this check box to print your 24-bit raster or grid file images in true color. Make sure your printer settings 
are greater than 256 colors. This check box is selected by default.

8. When you have completed these selections and returned to the Print dialog box, click OK to begin printing.

Recommendations for Effective Pattern Scaling

When you are printing, find out what type of printer driver you are using. Many PCL6 and some HPGL drivers handle 
fill pattern scaling and give you control over this feature. Turning off their scaling may be the difference between what 
you see in print and what you see on your monitor. We recommend that you try turning off your driver’s scaling options 
and try ours first, because we have enhanced our method to better meet your Map and Layout window requirements. 
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To turn our pattern scaling options on, check the Scale Patterns check box in the Output Preferences dialog box. Then 
try turning off our scaling and turn theirs back on to see which you like better. Tests show that our scaling produces 
color output that more closely matches your screen’s display.

If you are printing to postscript drivers using LanguageLevel 2 or 3, we find that some of the Microsoft drivers do not 
support pattern scaling. As a result, our scaling method may not help you. Microsoft recommended that you reset the 
language level of the postscript driver to LanguageLevel 1 to remove this restriction. We did find some exceptions to 
this condition. On Windows 2000 some HP Laser Jet and Color Laser Jet postscript drivers using our scaling option 
printed correctly. 

Printing to a File
To print the current map to a file:

1. Choose File > Print to display the Print dialog box and set your printer options.

2. Select the Print to File check box.

3. Click OK. The Print to File dialog box displays.

4. Type the name of the file you want to create in the field provided and click OK. Use the extension .PRN to help you 
identify the file as a print file.

General Printing Tips and Tricks
These entries are numbered but, other than the first one, they are in no particular order.

Good first steps in troubleshooting a printing problem are to make sure you have downloaded and installed the 
latest patch for MapInfo Professional and are using the latest printer driver for your printer/operating system. 
Exceptions are noted in this document.

Embedding MapInfo Professional Graphics Tip. When you embed a MapInfo map or graph in another application 
(such as Word or PowerPoint), click outside the map/graph before you use the Print or Print Preview commands. This 
allows the container application to take over previewing or printing properly. This is particularly true if you have just 
made changes to the map or graph you are printing.

HP 755 Driver Suggestion. If you are having difficulties printing using this plotter model, try the plotter driver for the 
HP 650C (C2859B) instead. In many cases, if you are having difficulty with a printer or plotter model and a similar 
model exists, you can substitute the similar model's driver for the current one and get good results. For example, you 
can use the printer driver for the HP 8500 DN Color LaserJet with the HP8550 color LaserJet driver).

Need for Speed When Using Fill Patterns?. Note that fill patterns on the first row of the Region Style dialog box (see 
next figure) are Windows standard and tend to print faster. The other patterns are bitmaps MapInfo has created for 
your use. You might want to consider this when you are selecting fill patterns.
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1 Use the fill patterns from this row for fast printing results.

Speed Still an Issue? If you want to improve printer speed, and your printer has Fast, Normal, Best print quality 
options, we suggest you select Fast. 

If your image is large and you are printing at a resolution of 600 DPI or greater, your image may exceed this limitation. 
To print the image, reduce the resolution of the printout or shrink the size of the image. See also Printing Maps Larger 
than 1.6 Meters (63 Inches).

Translucent Raster Maps? You cannot print a translucent raster map or grid on Windows 9X platforms or export them 
to EMF or WMF file formats. You need to use a non-metafile (i.e. .BMP or .TIF) format to export raster images on 
Windows 9X.

Old Driver Works, New Driver Doesn’t. When in doubt, if an older driver worked and the new one does not, go back 
to the older driver. For instructions on reinstalling older versions of printer drivers, see Hatch Patterns Printing as 
Black Polygons.

Disk Space an Issue? Make sure you have plenty of temporary disk space, particularly if you are using the Print using 
the Enhanced Metafile option. The system is trying to create a layered bitmap locally on disk.

Print Workspace Path with Map? In some cases, you may want to print the path to a particular workspace with your 
output. Here is a quick way to do this:

1. Choose Options > Show MapBasic Window to display the MapBasic window. 

2. Open the workspace you want to print. The path and workspace name display in the MapBasic window.

3. Use Ctrl C or Edit > Copy to copy the path and workspace name from the MapBasic window.

4. Choose Window > New Layout Window to create a new layout window.

5. Make the new Layout window active and use Ctrl V or Edit > Paste to paste the path into the Layout window. The 
path may paste in the gray area of the Layout window and may be difficult to see.

6. Select and drag the path to the desired printable location.

Printing Globally? Spool Locally! Try spooling print jobs locally rather than at the plotter. This allows the computer to 
rasterize your output rather than the printer, which can be more efficient.

1. To set up local print job spooling, choose Start > Settings > Control Panel > Printers.

2. Right-click the printer and choose Properties to display the printer’s properties.

3. Click the Advanced tab to display the advanced property options.

1
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4. Click the Spool Print Documents button and Start printing after last page is spooled button.

Note: If you do not have administrative rights to your computer, you may not be able to use the spooling 
option. Contact your IT department if you want to make this change to get their support.

5. Click OK to save your changes.

Resolutions to Known Printing Issues
There are many variables that affect printing and plotting with any application, and MapInfo Professional is no 
exception. MapInfo Professional does not provide its own printer drivers, it uses the existing ones installed under the 
current Windows operating system. This section addresses specific printer/plotter issues that have been uncovered by 
users and partners.

Platform Independent Issues
These issues occur regardless of operating system or hardware/software, except where specifically noted. Look for the 
issue you are working with below and refer to the resolution.

Printing a Layout Window to Multiple Pages

Printers/Plotters: HP Designjet Printers

MapInfo Professional Versions: 4.X and later

Issue: How do you print a layout window to multiple pages?

Resolution: With the layout window active, choose Layout > Options to display the Layout Options dialog 
box.

To make the layout page two pages wide and two pages tall, type 2 in the Layout Size Width and Height fields. 
Then click OK.

Handling the “Unable to Save Window Contents” Message

Printers/Plotters: HP Designjet 1055CM

MapInfo Professional Versions: 7.0+

Issue: This issue comes up whenever users try to print a layout window at 60 in. x 36 in. or larger due to 
memory issues.

Resolution: In this circumstance, print directly to the device rather than create the Enhanced MetaFile (EMF). 
Additionally we recommend that you use the appropriate HPGL driver for your printer and operating system. All 
current HP printer drivers are available at their web site, www.hp.com.

Hatch Patterns Printing as Black Polygons

Printers/Plotters: HP Designjet Series Plotters

MapInfo Professional Versions: All

Issue: When you print maps with hatch patterns, some regions display as solid black.

Resolution: According to Hewlett Packard support, the new HP printer driver (4.63) handles non-Windows 
standard hatch patterns properly. We recommend that you download and install the new HP 4.63 driver to 
resolve this problem.
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Hatch Patterns are Compressed when I Print

Operating System: Windows 2000

Printers/Plotters: HP LaserJet Series, tested on HP LaserJet 4050 Series PCL 6

MapInfo Professional Versions: 7.0+

Issue: When you use a MapInfo hatch pattern (a pattern not on the first row in the Region Style dialog box), you 
may notice that the pattern may become very compressed. This is because the patterns are a bitmap that get 
drawn at a higher printer resolution. The standard Windows patterns do not exhibit this problem. The printer 
resolution affects the amount of compression.

Resolution: Some printer drivers have a new output setting called Scale Patterns (WYSIWYG) that enables the 
patterns to scale correctly. In the HP printer we tested, this option is available when you select the Printing 
Preferences > Print Quality > Details options. 

Users should turn off either the driver's, or our scaling, as doing both scales fill patterns twice. Try both types of 
scaling to find the one you like better.

Platform-Specific Issues
These issues pertain to particular operating systems and/or hardware except where specifically noted. These issues 
are grouped by operating system.

Transparent/Translucent Raster Layers Printing Black

Operating System: Windows 2000

Printers/Plotters Tested: Epson Stylus Color 1520, HP Color LaserJet 8500N, HP Designjet 650C (C2859B), HP 
Designjet 750, HP Designjet 1055CM, HP Designjet 2500CM, HP Designjet 2500CP, HP DeskJet 1120C, HP DeskJet 
855C, HP LaserJet 4MV, HP LaserJet 4Si, HP LaserJet 4050, HP LaserJet 5000N, Lexmark 3200.

MapInfo Professional Versions: 6.5, 7.0+

Issue: PostScript printers print transparent raster layers as black even when you select white as the transparent 
color. There are several issues here, including the size of the spool file, amount of printer memory, and whether 
the container (Word, PowerPoint, etc.) supports transparent or translucent objects.

Translucent images do not print correctly if you select the Print Direct to Device option.

Resolution: Typically, if you are working with a PostScript printer driver you should use the Enhanced Metafile 
approach to printing and let MapInfo Professional handle printing the transparent and translucent layers of 
raster or grid images. If your printer can use an HPGL\RTL driver, use that to improve the output instead.

To set up the Enhanced Metafile process, click the Advanced button in the Print dialog box and select the 
following options:

• Print using Enhanced Metafile (EMF)

• Internal Handling for Vector Fills and Symbols

• Use ROP Method to Display Transparent Raster

• Print Raster in True Color When Possible

This resolves the issue but the output is often slow.

Additional Recommendation: Most printers should be able to handle the MapInfo Professional generated vector fill 
pattern styles. However, if you are still having problems, we recommend that you use Windows vector fill patterns 
that are in the first row of the Region Style dialog box to get better results. See General Printing Tips and Tricks 
for more details.

Note: HP Designjet 1055CM users: These additional property settings have worked for some users. In the 
Print dialog box, click the Properties button and select the Advanced tab to display these options:
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Process document: In Computer

Sharpen lines: Off

Select the Options tab to set the Quality option to Fast (draft) and click OK.

Note: HP Plotter users: Make sure you are using an HPGL/RTL driver and not a PostScript driver.

Preferred Printer Uninstalled/Reinstalled Error

Operating System: Windows 2000

Printers/Plotters: Reported with HP Designjet 1055CM but applies to all

MapInfo Professional Versions: 6.0

Issue: You cannot access the printer preferences when you upgrade and install a new printer driver. Usually in 
these cases, you (or someone in IT) removes the printer and installs a new driver over the network. However 
the preferred printer setting in the Printer Preferences dialog box is not reset at that time and remains 
unchanged, which creates a version discrepancy. This causes MapInfo Professional to shut down the Printer 
Preferences dialog box.

Resolution: To reactivate the printer preferences, close MapInfo Professional and delete the MAPINFOW.PRF 
(Preferences) file. Do not make any changes to the file, just delete it. When you reopen the application, MapInfo 
Professional re-creates the preferences file and resets the entries to the MapInfo Professional defaults.

Note: You will have to re-enter your preferences when you return to the preferences dialog boxes. 

After you have deleted the .PRF file, the Print button in the Preferences dialog box will re-activate. Select the 
desired printer as the MapInfo preferred printer.

Note: If MapInfo Professional is open when the .PRF file is deleted, MapInfo Professional retains the current 
preferences and creates a new .PRF file when you close the program. 

Plotting 54” Layouts

Operating System: Windows 2000

Printers/Plotters: HP Designjet 1055CM, HP Designjet 2500CP, HP Designjet 3500CP

MapInfo Professional Versions: 6.0, 6.5, 7.0+

Issue: Printing results in a single page feed only.

Resolution: Cannot be corrected in current version of MapInfo Professional.

To print within this limitation, we suggest that you either reduce the output resolution or the image size to 
decrease number of pixels.

In some print drivers, you may see the output resolution referred to as “output quality”. In this case, select a 
lower print quality such as “Draft” to lower the output resolution.

Use this formula:

Dots per Inch x Size in inches = Number of pixels
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Memory Loss in Large-Format Layers with HP Designjet Plotters

Operating System: Windows 2000

Printers/Plotters: HP Designjet Series

MapInfo Professional Versions: 6.0, 6.5, 7.0+

Issue: If you are printing large-format layouts (ANSI E 34 x 44 inches) that contain complex raster (transparent 
/ translucent) and vector layers, it is likely that you have encountered memory loss or errors. 

Resolution: The following print configuration may correct the problem:

Try reducing the page size to ANSI C (17 x 22) or smaller. Once you resize the layout frame objects to fit the 
smaller page size, go to the Print dialog box and click the Options button to display the Print Options dialog 
box. Click the Fit to this Page: button and reselect the ANSI E (34 x 44 inches) option.

CAUTION: Use this solution as a last resort only because it could affect the clarity of your image! 

Print output repeats itself every 2 to 4 cm using the HP 500, 800, 5000 Designjet plotter when 
printing Rasters

We have two suggestions to working around this problem. First, try spooling the printer locally either from the driver 
level or the printer level.

Note: You must have read/write rights to your printer and printer driver to resolve this issue.

To work around this problem, there is an advanced hidden setting that you can change within the properties of the 
driver. To prevent the printer from repeating itself every 2-4 cm. when printing rasters with vector overlays:

1. Locate the printer driver’s properties in the Control Panel. To get to this setting, right-click the printer icon and 
choose Properties.

2. Click the Advanced tab. Select the following options:

• Select the Avoid out of memory option.

• If you are using the Windows 2000 or XP operating system, select a scaling factor of 100%.

3. From this dialog box, click the Printing Defaults button.

4. In this dialog box, select the About button. The About <Driver Name> dialog box displays.

5. Holding down the F8 key on your keyboard, click the OK button. The Special Options dialog box displays:

6. Do one of the following and click OK:

• If printing from Windows 98, clear the Enable RenderSmart check box.

• If printing from Windows 2000 or XP, clear the Enable SpoolSmart check box.

CAUTION: When you modify settings in this driver option box, make sure to note the original settings in 
case you need to change them back. These were designed for HP Support Engineers and not for 
general public use. 

You can save these settings as a Quick Set to ensure that they run every time you print raster files.

1. Choose Start > Settings/Control Panel > Printers. 

2. Right-click the appropriate plotter driver icon and choose Printing Preferences.

3. Set the preferences the way you want them in the hidden menu.

4. In the Quick Sets box, type a name for the selected settings (for example, "Raster Print Settings") and click Save. 
All current driver settings (paper type, hidden menu settings, etc.) are saved under the Quick Set name. The printer 
driver remembers these settings and they can be used for future print jobs. 

To print a raster map later with the same settings:

1. Choose File > Print to display the Print dialog box.

2. Choose the Properties button. The Properties dialog box displays.
MapInfo Professional 10 Printing Guide 9



3. Make sure the name you entered (as in “Raster Print Settings” in our example) displays in the Quick Sets drop-
down list and click OK. The Print dialog box redisplays.

4. Click OK to print.

Note: If you do not need this special setting in Quick Sets, remember to change this setting back to the default 
machine setting.

Cannot Print with HP Designjet Printers (Driver 5.31 or 5.32). 

When you attempt to use this driver one of these things happens:

• If you select the Maximum Performance option, you get memory error messages and the printer prints only part of 
the image

• If you select the Avoid out of memory option, the computer crashes and displays both an Out of Hard Disk Space 
message and an Out of Virtual Memory message

The resolution of this issue is similar to the preceding issue. The dialog box is the same.

To resolve this issue:

1. Choose File > Print to display the Print dialog box.

2. Click the Advanced button at the bottom of this dialog box. The Advanced Printing Options dialog box displays.

3. Select these options and click OK:

• Print directly to the printer
• Internal Handling for Transparent Vector Fills and Symbols
• Use ROP Method to Display Transparent Raster
• Print Raster in True Color When Possible
• Select the Half Tone dither method.

4. From the Control Panel, select Printers or Printers and Faxes and find the printer you want to print from.

5. Right-click the printer you want to print to and select the Properties option. The Properties dialog box displays.

6. Click the About button to display the About <Printer Driver> dialog box.

7. Holding down the F8 key on your keyboard, click the OK button. The Special Options dialog box displays.

8. Do one of the following:

• If printing from Windows 98, clear the Enable RenderSmart check box.

• If printing from Windows 2000 or XP, clear the Enable SpoolSmart check box.

Printing Maps Larger than 1.6 Meters (63 Inches)

When you print a map that is larger than 1.6 meters or 63 inches in Normal or Best modes, often the image is 
incomplete. Only the first 1.6 m or 63” prints.

To resolve this issue, do one of the following:

• Click the Advanced button and in the Print Quality options, select a lower print resolution (from 600 to 300 DPI or 
from 300 to 150 DPI)

• Set the Scale to fit option to 100% to divide the resolution rendering by 2

When you use one of these alternatives you can print up to 3.2 meters (10.5 feet) at 300 DPI or up to 6.4 meters (21 
feet) at 150 DPI.
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Enhancements Added in Earlier Versions

MapInfo Professional 9.5.1
MapInfo Professional provides enhanced rendering capabilities in this release, including:

• translucency of vector objects (map features, labels, themes, text, and layout objects)
• smoothing (anti-aliasing) of text, vector and images
• new drawing selection method
• new export formats: EMF+ and EMF+Dual
• use of offscreen bitmaps to draw layouts
• printing improvements

Enhanced rendering is possible through Microsoft’s GDI+, an operating system level capability that provides two-
dimensional vector graphics, imaging, and typography handling. GDI+ improves on standard Windows Graphics 
Device Interface (GDI) by adding new features and optimizing existing features. 

Enhanced rendering in MapInfo Professional allows you to create translucent labels, themes, and layers, as well as 
apply anti-aliasing to smooth the jagged edges of text, labels, lines, curves, region borders and raster images. We also 
provide a new way of drawing selections and two new export formats as a result of using the new enhanced rendering 
support. 

Enhanced rendering covers the following topics:

• Enabling Enhanced Rendering
• Enhancing Selection Drawing Style
• Workspaces
• Translucency
• Anti-Aliasing
• Printing Maps with Translucency and Anti-Alias Smoothing
• EMF+ and EMF+Dual Export Formats
• Layout Drawing Improvements

Enabling Enhanced Rendering

To take advantage of enhanced rendering in MapInfo Professional, you must turn on the capability. If you do not turn 
on enhanced rendering, rendering is performed using the standard Windows Graphics Device Interface (GDI). 

Enhanced rendering does not mean that translucency and anti-aliasing are automatically applied. Translucency and 
anti-alias settings must also be applied to generate the best looking maps. You will, however, automatically have the 
improved selection drawing style (see Enhancing Selection Drawing Style on page 12). Translucency and Anti-
Aliasing are discussed under Translucency on page 13 and Anti-Aliasing on page 15, respectively. 

Enhanced rendering is supported for Map, Browser and Layout windows. Enhanced rendering is not available for other 
types of windows. 

To enable enhanced rendering, set it in the Options dialog for the Map (from the Map menu, select Options), Browser 
or Layout windows, or through a MapBasic statement. It is controlled on a per window basis.

Legends are drawn in the same mode as the associated Map window. So, if a map is in enhanced rendering mode, its 
legend is as well. There are no enhanced rendering options in the Legend Options dialog.

Like the Map and Browser windows, enhanced rendering for Layout windows is enabled in its Options dialog. This 
means that any annotations added to the layout, such as titles or watermarks will be drawn using enhanced rendering. 
If you add Map and Browser windows that already are enabled for enhanced rendering, enhanced rendering will be 
forced on for the Layout window. Enhanced rendering for the Map and Browser windows have no affect on the Layout 
window, and vice versa. For more information, see Translucency for Layout Windows on page 14. 
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There is also a style preference to determine the initial enhanced rendering state for newly created windows. See 
Enabling Enhanced Rendering for New Windows on page 12.

Note MapInfo Professional 9.5 opens a workspace with enhanced rendering, but ignores the enhanced rendering 
settings. Versions of MapInfo Professional prior to 9.5 cannot open a workspace with enhanced rendering. See 
Workspaces on page 13. 

Enabling Enhanced Rendering for New Windows

MapInfo Professional provides a Style preference to determine the default state of enhanced rendering for newly 
created Map, Browser and Layout windows. Each window can be changed independently at a later time. This 
preference is disabled by default to maintain backwards compatibility with earlier versions of MapInfo Professional.

Note These preferences control the state of new windows, not existing windows. This means if you are opening old 
workspaces, they will open with enhanced rendering disabled, regardless of how the Style preference is set.

To set enhanced rendering as a default style preference:

1. On the Options menu, point to Preferences and click Styles to display the Styles Preferences dialog box.
2. Select the Enable Enhanced Rendering checkbox and make your selections from the drop-down lists.

For more information, see Setting your Style Preferences on page 171.

Enhancing Selection Drawing Style

MapInfo Professional offers a selection drawing style that uses translucency through enhanced rendering. This 
requires that the window is enabled for enhanced rendering, see Enabling Enhanced Rendering for New Windows 
on page 12. This style method is useful when you need to select map objects, such as points or regions, where they 
overlap or appear to draw on top of one another when you zoom out.

To control the translucency setting for the selection style, go to the Styles Preference dialog. The slider is located in the 
Highlight Control group for that dialog. For more information, see Setting your Style Preferences on page 171.
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If enhanced rendering is turned off, selections are drawn using an older selection method. This method, under certain 
situations, causes overlapping objects to appear unselected.

Note A particular selection style may not look ideal in either mode. You will have experiment with the settings. 

Workspaces

If you open a workspace that does not have enhanced rendering enabled and you wish to use the translucency and 
anti-aliasing features, you must enable it on a per window basis using the Options dialog for the Map, Browser or 
Layout window. 

Note Workspaces with enhanced rendering enabled can only be opened in MapInfo Professional 9.5 or later. 
Enhanced rendering must be disabled to open a workspace in an earlier version of MapInfo Professional. 

Translucency

One key capability of enhanced rendering is the ability to apply translucency to a map layer so that the layer 
underneath is partially visible. This feature can be a very powerful analytical tool. For example, translucency on a 
ranged theme provides two levels of information in a single view—the distribution of data that matches some criteria, 
and the view below the ranged theme that offers a reference map to that data. 

MapInfo Professional supports translucency for a wide variety of layer types, including vector objects, labels, themes, 
raster and grid images, and annotations (cosmetic layer and graphic objects added to layouts). 

Enhanced Rendering Turned Off Enhanced Rendering Turned On
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MapInfo Professional also provides a new method for printing translucent maps. See Printing Maps with 
Translucency and Anti-Alias Smoothing on page 16.

Translucent Layers

Translucency is controlled on a per layer basis. Each layer has its own translucency setting. Translucency for map 
layers and themes is set in Layer Control using a slider control on the Display Options dialog. Translucency for labels 
is set in the Label Options dialog. All objects in the same layer are drawn at the same translucency level. Labels, 
themes and map objects in the same layer have independent translucency settings. You can have multiple translucent 
layers in a Map window, each with its own translucency value.

In order to use translucency in a Map or Layout window, you must enable enhanced rendering in the appropriate 
window’s Options dialog. Enhanced rendering can also be set as a Style preference for new windows you create. For 
more information, see Setting your Style Preferences on page 171.

Keep in mind, when translucency is on (value > 0 percent), enhanced rendering is automatically enabled. However, the 
reverse is not true. If translucency is turned off (value = 0 percent), enhanced rendering will not be turned off. You can 
turn it off manually, if desired, by clearing the Enable Enhanced Rendering checkbox in the Options dialog.

Note There is a shortcut to enabling enhanced rendering if you are already in the Display Options or Label Options 
dialogs. You can enable it by setting a translucency value of greater than 0. This saves you from returning to 
the Map or Layout window Options dialog to enable it.

Translucency is also available for the Cosmetic Layer. Set translucency for the Cosmetic Layer just like you would for 
another layer type, in Layer Control’s Display Options dialog. The translucency setting will be applied to the entire 
Cosmetic Layer.

Translucency for Layout Windows

Layout windows provide two levels of enhanced rendering: 

• Annotation-level enhanced rendering for graphic objects, such as titles or watermarks.
• Window-level enhanced rendering for the Maps, Legends and Browsers.

To set enhanced rendering for layout annotations for an already created layout, go to Layout > Options and check the 
Enable Enhanced Rendering checkbox. You can also set smoothing settings here as well. If you have yet to create 
the Layout, you can enable enhanced rendering as a preference for newly created windows (Options> Preferences > 
Styles). 

To set enhanced rendering for Map and Browser windows that you wish to display in a Layout window, go to the 
appropriate window Options dialog (Map or Browser) and check the Enable Enhanced Rendering checkbox. Adding 
these windows to the layout and enhanced rendering will continue for these windows. To disable enhanced rendering 
for these frames, return to the appropriate Options dialog and clear the checkbox. 

Embedding a Map or Browser window with enhanced rendering on in a Layout window will also force enhanced 
rendering on for the layout. This can be seen in Layout > Options dialog when the Enhanced Rendering checkbox is 
checked, but the control is disabled, preventing you from turning it off.

Adjusting Translucency in a Layout

Translucency for annotations in a layout is controlled by a translucency slider in the Options dialog for Layout windows. 

To adjust the translucency of annotations in a Layout window go to Layout > Options and change the value on the 
translucent slider. All annotations in the Layout window will be treated with the same translucency setting. Annotations 
are objects you can add to a layout by using, for example, the Add Symbol, Line, Polyline, Text, toolbar options. 

To adjust the translucency for Map windows in a layout, you must return to its Map window and access the Options 
dialog to reach the translucency slider.

Note Translucency for annotation objects does not affect the translucency of Maps in layout frames. The contents of 
frames are drawn using that window’s translucency settings. They are not drawn using the Layout window 
translucency setting. The translucency slider on the Layout Options dialog does not control the translucency of 
the maps. 
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Translucent Raster and Grid Images

Translucency for raster and grid images has been available in MapInfo Professional prior to this release. The new 
aspect of image translucency is the added support through enhanced rendering. These images can be drawn 
translucently with or without enhanced rendering enabled. 

The advantage of using enhanced rendering is seen when a translucent raster or grid image is printed. Enhanced 
rendering enabled forces MapInfo Professional to print to offscreen bitmaps, which typically yields better looking 
results than if printed without enhanced rendering. 

For raster images, there is no change to how you set translucency through the user interface or via MapBasic 
commands. Set the translucency in the Adjust Image Styles dialog (Layer Control > Display Options > Style Override > 
Adjust Image Styles).

Raster display options can also be controlled on a per table basis so that the image will open using those particular 
settings by default. These are found in Table > Raster > Adjust Image Styles.

For grid images, the translucency slider is an option in the Grid Appearance dialog. This dialog is reachable from the 
Styles button in the Create Thematic Map Step 3 of 3 or the Modify Thematic Map dialogs. 

See Printing Maps with Translucency and Anti-Alias Smoothing on page 16 for available printing options.

Anti-Aliasing

One aspect of enhanced rendering is the ability to employ an anti-aliasing process that removes the jagged edges of 
text, labels, images, and vector lines and borders. Enabling enhanced rendering does not automatically enable anti-
aliasing (smoothing options are set to None by default). You must set it in Style Preferences for the default state of 
newly created windows, or in the Options dialogs for individual Map, Browser and Layout windows. 

To open the Style Preferences dialog, on the Options menu, point to Preferences and click Styles.

To remove the appearance of jagged characters in horizontal and rotated labels and on custom text objects in the 
window, select the Enable Enhanced Rendering checkbox and choose Anti-Alias from the Smooth Text & Labels 
drop-down list. Smoothed text and labels look better on your map, but because these objects require more rendering, 
it may take longer to display your map. (For more information, see Setting your Style Preferences on page 171.)
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If you wish to smooth raster and grid images in your window, you can set the quality of the resolution. Low Quality 
indicates there will be some image smoothing, but not at the expense of rendering performance. High Quality means 
that you want the highest amount of smoothing MapInfo Professional can provide. This will cause your map to draw 
more slowly than the Low Quality option. 

The third anti-alias setting applies to lines and borders. The following illustration shows the before and after affects of 
anti-aliasing applied to the roads and labels in the Map window. 

Printing Maps with Translucency and Anti-Alias Smoothing

MapInfo Professional provides a new printing method for maps and layouts containing translucent content and anti-
alias settings. This method renders the map or layout “behind the scenes” to an offscreen bitmap prior to sending it to 
your printer or plotter. The use of offscreen bitmaps is invoked depending on the type of translucent content in the map 
and the enhanced rendering state of the window, as follows:

• Invoked when your map or layout contains translucent vectors (e.g., map layers, themes, or labels) and enhanced 
rendering has been enabled. 

• Invoked if your map contains images with either High or Low Quality smoothing enabled. 
• Invoked for translucent raster and grid images provided enhanced rendering is enabled. 

You cannot control this print method through the Print dialog, as you can with Direct to Device or Print to EMF. This is a 
registry setting called PrintOSBM, located under HKEY_LOCAL_MACHINE\SOFTWARE\MapInfo\MapInfo\Common. 
The values are dword:00000000 (auto) and dword:00000001 (forced on). Auto, the default, means that printing will use 
offscreen bitmaps only for the translucency and anti-alias conditions listed above. Forced on means printing will use 
offscreen bitmaps regardless of the translucency and anti-alias settings. 

For translucent raster and grid images, you can also print using EMF when enhanced rendering is not enabled. 

Note Direct printing to a printer or plotter does not support translucency. 

Enhanced Rendering Off Enhanced Rendering On, 
with smoothing options
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EMF+ and EMF+Dual Export Formats

In order to take full advantage of enhanced rendering, MapInfo Professional provides EMF+ and EMF+Dual image 
export formats. These are enhanced metafile vector image formats that support Windows GDI+ (Graphics Device 
Interface). Use these to save translucent maps instead of exporting to the older metafile formats, such as EMF and 
WMF. Older formats do not support translucency very well, which display images using translucency with a dithered, or 
speckled, appearance. 

Choose EMF+ if you expect to bring your maps into an application that supports EMF+, such as Microsoft Office 2007. 
Choose EMF+Dual (a combination of EMF and EMF+) if your maps may be used in applications that may or may not 
support EMF+, such as Microsoft’s Office 2003 and Office 2007.

Note EMF+Dual format will produce a larger file than EMF+. But it provides better compatibility with older application 
that do not support EMF+.

Layout Drawing Improvements

Beginning with this release, MapInfo Professional now prepares a layout for display by rasterizing the contents to an 
offscreen bitmap, and displaying the entire layout once the bitmap is drawn. You will no longer see a partial display of 
the Layout window. The drawing is done offscreen and is presented to you when it is completely drawn.

This behavior applies to layout displays with or without enhanced rendering enabled. 

PrintOSBM Registry Setting

This registry setting controls a new printing method that renders a print job to offscreen bitmaps prior to sending it to 
the printer or plotter. This is used when printing maps and layouts containing translucency and/or anti-alias content. 
For details see Printing Maps with Translucency and Anti-Alias Smoothing on page 16. 
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MapInfo Professional 9.5

PolygonMode

This release of MapInfo Professional introduces a new way of drawing complicated polygons, such as those containing 
holes or many nodes. This was due to an issue with printing such objects using an Adobe PDF printer driver. It left 
visible seams and gaps in the image when the PDF was printed. These seams and gaps were not visible on screen nor 
when printed using other printer drivers.

Printing with the new method means that large polygons are now rendered as-is not broken into smaller polygons, as 
the older method does. Additionally, the new method uses different calls that specifically support drawing polygons 
with holes. The older method manipulates the polygon with holes to draw as a single polygon. This is what caused 
seams and gaps to appear in the PDF

Because this issue does not affect all users of MapInfo Professional who print maps, we continue to provide the 
original polygon drawing method. You can control which method to use by changing the registry setting 
PolygonMode=1 (default, renders using the new method), to PolygonMode=0 for the old method. This setting is 
located in the system registry under HKEY_LOCAL_MACHINE\SOFTWARE\MapInfo\MapInfo\Common.

PrintOSBM

This registry setting controls a new printing method that renders a print job to offscreen bitmaps prior to sending it to 
the printer or plotter. This is used when printing maps and layouts containing translucency and/or anti-alias content. 
For details, see Printing Maps with Translucency and Anti-Alias Smoothing.

Printing Maps with Translucency and Anti-Alias Smoothing

MapInfo Professional provides a new printing method for maps and layouts containing translucent content and anti-
alias settings. This method renders the map or layout “behind the scenes” to an offscreen bitmap prior to sending it to 
your printer or plotter. The use of offscreen bitmaps is invoked depending on the type of translucent content in the map 
and the enhanced rendering state of the window, as follows:

• Invoked when your map or layout contains translucent vectors (e.g., map layers, themes, or labels) and enhanced 
rendering has been enabled. 

• Invoked if your map contains images with either High or Low Quality smoothing enabled. 
• Invoked for translucent raster and grid images provided enhanced rendering is enabled. 

You cannot control this print method through the Print dialog, as you can with Direct to Device or Print to EMF. This is a 
registry setting called PrintOSBM, located under HKEY_LOCAL_MACHINE\SOFTWARE\MapInfo\MapInfo\Common. 
The values are dword:00000000 (auto) and dword:00000001 (forced on). Auto, the default, means that printing will use 
offscreen bitmaps only for the translucency and anti-alias conditions listed above. Forced on means printing will use 
offscreen bitmaps regardless of the translucency and anti-alias settings. 

For translucent raster and grid images, you can also print using EMF when enhanced rendering is not enabled. 

Note Direct printing to a printer or plotter does not support translucency. 
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EMF+ and EMF+Dual Export Formats

In order to take full advantage of enhanced rendering, MapInfo Professional provides two new image export formats: 
EMF+ and EMF+Dual. These are enhanced metafile vector image formats that support GDI+. Use these to save 
translucent maps instead of exporting to the older metafile formats (EMF and WMF). Older formats do not support 
translucency very well, which display images using translucency with a dithered, or speckled, appearance. 

Choose EMF+ if you expect to bring your maps into an application that supports EMF+, such as Microsoft Office 2007. 
Choose EMF+Dual (a combination of EMF and EMF+) if your maps may be used in applications that may or may not 
support EMF+, such as Microsoft’s Office 2003 and Office 2007. 

Note EMF+Dual format will produce a larger file than EMF+. But it provides better compatibility with older application 
that do not support EMF+.

MapInfo Professional Printing Guide Available in Help

Over the years, users have told us that the MapInfo Professional Printing Guide helps them print large or complex 
maps or layouts. You can now access the MapInfo Professional Printing Guide, which contains printing tips and tricks 
from our Quality Assurance department, in the Help System.

To access the Printing Guide in the Help System, choose Help > MapInfo Professional Help Topics > Productivity 
Aids > MapInfo Professional 9.5 Printing Guide.

MapInfo Professional 9.0

Printing Large and Complex Output 

If you have seen the Cannot Print error message when printing, you may be trying to print one or more of the 
following:

• Large format (large page size) maps or layouts containing raster or grid layers that may be translucent or 
transparent

In this case, many times the maps or layouts did not print at all, or if they did print, the translucent or transparent 
layers did not print properly.

• Maps made up of multiple pages that contain borders 

In this case multiple page maps with a border around the entire map would print with borders around each page 
instead.

• Maps that contained labels that span more than one page

In this case, the labels would not print at all or would not print properly.

Largely, these issues were caused by the demand these print requests placed on the system resources in your 
computer.

To resolve these issues we now offer an option that breaks down a print request into smaller blocks, which reduces the 
demand on your system’s resources. Each block is sent individually to the printer driver. This change may allow you to 
print large and complex images that you could not print in the past. We call this feature Subdivide Print. We limit the 
size of each block to 8192 x 8192 pixels.

Caveat

During testing we discovered that many printer drivers handled this new option properly. However we found that the 
output of some printer drivers resulted in gaps that display at the block boundaries. Therefore we did not enable this 
option by default. Since these gaps may affect the quality of your final output, we are giving you the ability to enable 
this option if or when you need it. At this time, we do not have a workaround to remove these gaps. 

Note: If you have both a postscript and a non-postscript version of your printer driver, we recommend you try both to 
see which version gives you better results.
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Enabling the Subdivided Printing Option

To use this new option, you need to add a registry key to your local machine. We have created an online Knowledge 
Base document that contains the registration (.reg) files inside a ZIP file that you can use to enable or disable this 
option automatically. You will need to save the ZIP file locally, open the ZIP file and double-click the appropriate 
registry file to add this option to the registry. Adding registry keys to your computer requires Administrator rights, or at 
least write access to your computer’s registry. If you do not have this type of access, we recommend you see your 
System Administrator for instructions.

Enabling the Subdivide Print Option Using Registration Files

To enable the Subdivide Print option using registration files in the Knowledge Base document:

1. Go to the MapInfo Knowledge Base entry. Click here to do this now or copy the following address to your browser:

http://testdrive.mapinfo.com/techsupp/miprod.nsf/kbase_by_product/
2F7C21FEAFF3145285257243005336AB

Note: If you do not have Internet access, see Enabling the Subdivide Print Option Manually for 
instructions.

2. Open or save the SubdividePrint.ZIP file and, using your ZIP utility, save the two registration files locally. Use 
Windows Explorer to navigate to the registration files. 

Note: We recommend you create a permanent directory in case you need to remove the registration option 
later.

3. Double-click the SubdividePrint.reg icon to add the new key to the registry. This option takes effect the next time 
you open MapInfo Professional.

Disabling the Subdivide Print Option Using Registration Files

If you try this option and you want to remove this functionality, you can disable the registry entry by following these 
instructions.

Note: We assume that you have downloaded the ZIP file that contains the registry files by following the instructions in 
Enabling the Subdivide Print Option Using Registration Files.

To disable the Subdivide Print option using the downloaded registration file:

1. Go to the directory that contains the registration (.reg) files you downloaded earlier.

2. To remove the Subdivide Print option, double-click the UndoSubdividePrint.reg icon. The registry entry is 
updated with the new value.

This option takes effect the next time you open MapInfo Professional.

Enabling the Subdivide Print Option Manually

If you do not have access to the Internet, or you want to add this option manually, follow these instructions.

To enable the Subdivide Print option by entering the registration key manually:

1. Choose Start > Run and type the command regedit. Click OK to display the Registry Editor window.

2. In the HKEY_LOCAL_MACHINE entry, navigate to Software > MapInfo > MapInfo > Common.

3. From the Edit menu, select New > DWORD Value. A new entry displays in the list.

4. Right-click the entry and select Rename. Rename the new entry SubdividePrinting and press Enter.

5. Double-click the new entry to display the Edit DWORD Value dialog box.
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6. To enable the Subdivide Print option, type 1 in the Value data field and click OK. 

To disable this option, return to this dialog box, type 0 in the Value data field and click OK.

This option takes effect the next time you open MapInfo Professional.

Note: You can also remove this regedit entry entirely to remove this option.

MapInfo Professional 8.5
There is a new anti-aliasing export filter in this version of MapInfo Professional. Anti-aliasing is a fairly common 
graphics filter operation that can make the jagged lines in your map and label images appear smoother, which may 
improve their look in a slide show presentation or on the Web. We suggest you experiment with this feature and its 
settings to see what anti-aliasing combinations work best for your images. Anti-aliasing is most effective when used 
with map images that contain many curved lines, irregular region areas and text objects.

The benefits of anti-aliasing can include:

• Make your fonts look smoother 
• Make jagged edges in maps look rounder 
• Can make text can be easier to read (for some) because it looks more like printed type
• Make maps look more visually attractive

The following are enhancements for printing, importing, and exporting in MapInfo Professional 8.5:

Setting Anti-Aliasing Options for Images

Setting Font Anti-Aliasing Options For Labels

Printing Large (D, E, and A0) Images Improved

Setting Anti-Aliasing Options for Images

Some customers have asked us to give them more control over the map images when exporting MapInfo Professional 
maps. This is particularly important when you are saving maps created in MapInfo Professional for use in other 
Windows-based applications, in particular in slide presentations or for web pages. 

We have added the ability to smooth or anti-alias images during the export process. You can use this capability with all 
types of windows such as Map windows, layouts, legends, and graphs. 

Note: You cannot anti-alias images you are exporting to .EMF or .WMF format, because these are not true raster 
formats.

There are three smoothing options you can use to customize your raster image: 

1. Smooth using a Filter value. You can set a flag that selects one of six filters that allow you to choose the direction 
the filter is applied to the image from.

2. Smooth using a Mask value. You can select a value that indicates the size of the area you want to smooth. For 
example, to create a 3x3 pixel mask value, you would enter a 3 in this field. This would limit the amount of change 
in the color of the pixels. Typically mask sizes would be 2-3 pixels when exporting at screen resolution. If you are 
exporting at a higher resolution, a larger mask might be appropriate.

3. Smooth using a Threshold value. You can select a threshold value to indicate which pixels to smooth. Each pixel 
in an image has a value based on its color. The smaller the pixel value, the darker the color. Select this option to 
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smooth all of the pixels above the threshold you enter in this field. When you set this value to 0, MapInfo 
Professional will smooth all of the pixels.

You must either set a global preference for these anti-aliasing options or set them locally during the export process 
(using the Advanced button).

To set the anti-aliasing preference for exporting images:

1. Choose Options > Preferences > Output Settings to display the Output Preferences dialog box.

2. Click the Exporting tab to display the anti-aliasing options.

3. To use anti-aliasing automatically, select the Use Anti-aliasing check box and select from these options:

Smooth using a Filter value
Choose a filter for the smoothing you want to use. Select from these filters:

• Vertically and Horizontally (Smooths the image vertically and horizontally)

• All Directions (1) (Smooths the image in all directions)

• All Directions (2) (Smooths the image in all directions using a different algorithm)

• Diagonally (Smooths the image diagonally)

• Horizontally (Smooths the image horizontally)

• Vertically (Smooths the image vertically)

Smooth using a Mask value
Choose the pixel size of the mask you want MapInfo Professional to use in this field. For example, to create a 
3x3 pixel mask value, you would enter a 3 in this field. This would limit the amount of change in the color of the 
pixels to the three pixels around the basic pixel.

Smooth using a Threshold value
Select a threshold value to indicate which pixels to smooth. Colors are 0 for black and 255 for white (in an 8 bit 
image). Entering a low number changes the look of your map by smoothing the darker colors and the lighter 
colors. Choosing a higher number changes the way the lighter colors display.

To set the anti-aliasing options locally during export:

1. When you have completed your work on a window, select the File > Save Window As menu option. The Save 
Window to File dialog box displays.

2. Type the name and indicate the path of the file you are saving in this dialog box. Click Save to continue. The Save 
Window As dialog box displays.

If you are exporting an EMF or WMF image, the Use Anti-Aliasing check box is disabled.

3. Select the Use Anti-aliasing check box and do one of the following:

• Click Save to use the anti-aliasing options you selected in the Output Preferences dialog box

• Click Advanced and choose new anti-aliasing options for this particular map. Click OK to return to the Save 
Window As dialog box. Click Save to save these settings and the file.

Note: If you do not select the Use Anti-aliasing check box, the anti-aliasing options in the Advanced 
Exporting Options dialog box are disabled.

The next few figures should give you an idea of the types of results you can expect using the different options. 
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Figure: Anti-Aliasing with Filter Vertical and Horizontal, Mask 2, Threshold 100

Figure: Anti-Aliasing with Filter Vertical and Horizontal, Mask 5, Threshold 100

Printing Large (D, E, and A0) Images Improved

Customers printing large images (such as destination page size D, E, or A0) have reported problems using MapInfo 
Professional. Some of the printing problems stemmed from a 28,000 pixel limitation that we addressed in MapInfo 
Professional version 8.5. We have removed this pixel limitation to allow users to print oversized plots that would have 
exceeded this limit in earlier versions of MapInfo Professional. MapInfo no longer supports the Windows 95, 98, or NT 
4 operating systems, which allowed us to remove this restriction.

Setting Font Anti-Aliasing Options For Labels

If you have ever noticed that the edges of your text is jagged and you want to smooth those lines, you can use your 
system’s anti-aliasing options to make this change. If you use the Windows 2003 Server, Windows XP, or Windows 
2000 operating systems, you already have the ability to anti-alias your text. 
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To set up the anti-aliasing capability in Windows XP or Windows 2003 Server:

1. Choose Start > Control Panel > Display > Appearance > Effects to display the Effects dialog box.

This anti-aliasing option affects the way fonts are rendered on your screen. In Windows 2000 this option 
is Smooth edges of screen fonts.

2. Select the Use the following method to smooth edges of screen fonts check box or the Smooth edges of 
screen fonts check box. Click OK to save this preference.

In Windows XP you have two anti-aliasing options, Standard and ClearType. The option you select in this drop-
down list should depend upon the kind of computer monitor you are using. 

• Select Standard if you are using a standard computer monitor. 

• Select ClearType for portable computer and other flat screen monitors. 

Note: If you select ClearType and you are using a desktop computer monitor, your text may appear slightly blurry. 

To set up the anti-aliasing capability in Windows 2000:

1. Choose Start > Settings > Control Panel > Display > Effects tab to display the effects options.

2. Select the Smooth edges of screen fonts check box. Click OK to save this preference.
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MapInfo Professional 8.0

Improved Control of WMS Image Quality When Printing

To improve your control of the image resolution for WMS map images, we have added the ability to globally and locally 
set the GetMap request pixel limits in MapInfo Professional. In this case, more pixels means higher resolution, but it 
also means slower access time. Because WMS servers are not required to specify pixel width and height limits in their 
capabilities documents, you will have to experiment with the pixel limits of a particular server to get the highest 
resolution you can. When you send a request that exceeds the server’s pixel limit, the server usually issues an error 
indicating the maximum allowable image size. This will help you adjust the pixel limits for the server.

You can set a Web Services preference to set the pixel limits for all WMS images and you can override these limits by 
setting the per-server limits on an individual image basis. These options allow you to control the resolution of the WMS 
maps and limit the size of the maps you receive.

Setting the GetMap Request Pixel Limit Globally

You can set the GetMap request pixel limit globally to affect the resolution of the WMS maps you receive. Remember 
that increasing the pixel limit also means the retrieval process will take longer, but will produce better quality images.

To set the GetMap request pixel limit globally:

1. Choose Options > Preferences > Web Services to display the Web Services Preferences dialog box.

2. Select the options in this dialog box according to your needs.

WMS GetMap Pixel Limits
The GetMap Pixel Limits option represents the maximum number of pixels (in width/height) that a map request 
is limited to. The GetMap request is designed to retrieve the highest resolution map image as is necessary to 
render the image on the screen, for a printer, or for an export file. This option prevents the request from going 
higher than the specified values. Different servers have different limits, so you can set the limit that works best 
for your environment. 

Note: You can set per-server defaults for GetMap Pixel Limits in the WFS Server Information dialog box.

Unfortunately, servers may not report their limits to us, so if the GetMap request fails, it means that you have 
entered a value that is too large for that server. Typically, large GetMap requests occur when you are printing  
or exporting windows containing WMS images. This happens because printing and exporting occurs at larger 
sizes and/or higher resolutions than on-screen display requires. 

Max Width
Max Width specifies the maximum number of pixels for a GetMap request in the X direction.

Max Height
Max Height represents the maximum number of pixels for a GetMap request in the Y direction.

3. When you have completed your selections, click OK to save them.

Note: The WMS GetMap Pixel limits listed in the Web Services Preferences dialog box can be overridden on  a per 
server basis in the WMS Server Information dialog box. 

Overriding Default GetMap Pixel Limits Locally

You can override the global settings for a particular server if the server’s limits are different than the values you set in 
the Web Services Preferences. If a particular server's limits are higher than the values you selected in the Preferences 
dialog box, you may want to increase the limits for that server to get higher quality images. If a particular server's limits 
are lower than the values set in Preferences, you can set lower per-server values locally to prevent errors during the 
GetMap request.

Remember, the server may not include the limits in its capabilities document so MapInfo Professional cannot help you 
determine this. You can only find these pixel limits on a trial and error basis.
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To override the default pixel limit values for a WMS server:

1. Do one of the following:

• Click the Open WMS button on the Main toolbar

• From the File menu select Open Web Service > Open WMS

2. Click the Servers button on the Open WMS Table dialog boxes to display the WMS Server Information dialog box. 

3. Double-click the server for which you want to change the default values from the list. The WMS Server Information 
dialog box displays.

4. Select the Override GetMap Pixel Limits check box to enter the new overrides (in pixels) for this particular server 
in the fields that display. 

5. Click OK to save these values. Then try to retrieve the WMS image you were looking for before.

MapInfo Professional 7.8

New Scale Choices when Printing Maps

In response to customer requests, we have created a new map window preference to allow you to set the scale options 
for map printing. You can now set the map scale to display in Cartographic Scale automatically or you can choose your 
own map scale using this preference. By default, the Use Cartographic Scale option will not be set.

Note: When you select this preference, MapInfo Professional will preset your map printing scale based on the 
distance scale of the Earth and set the scale for the Change View, Map Print Options and Frame Object dialog 
boxes.

To see the new map window preference:

1. Choose Options > Preferences > Map Window to display the Map Window Preferences dialog box.

2. Select the Use Cartographic Scale check box to display your maps in Cartographic Scale automatically.

When you make this change, the options that display in the Change View, Map Print Options and Frame Object dialog 
boxes use the cartographic scale on which the selected map is based. For example, the cartographic scale on which 
the selected map in the next figure is based is 1 : 24,630,000.

Figure: Change View (with the Use Cartographic Scale Selection in Preferences)

Printing a Window to a File

A MapInfo window can now be printed to a file. The PrintWin MapBasic command has been enhanced to make this 
possible. The change from the previous syntax is indicated in bold. 

PrintWin [Window  window_id]  [Interactive] [File output_filename]
[Overwrite] 

window_id is a window identifier

output_filename is a string representing the name of an output file. If the output file already exists, an error will 
occur, unless the Overwrite token is specified.

If the statement includes the optional Window clause, MapBasic prints the specified window; otherwise, MapBasic 
prints the active window. 
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The window_id parameter represents a window identifier; see the FrontWindow( ) and WindowInfo( ) functions for 
more information about obtaining window identifiers. 

If you include the Interactive keyword, MapInfo Professional displays the Print dialog box. If you omit the Interactive 
keyword, MapInfo Professional prints the window automatically, without displaying the dialog box. 

Example 1
Dim win_id As Integer
Open Table ”world” 
Map From world
win_id = FrontWindow()
’
’ knowing the ID of the Map window, 
’ the program could now print the map by 
’ issuing the statement: 
’
PrintWin Window win_id Interactive

Example 2
PrintWin Window FrontWindow() File "c:\output\file.plt"

MapInfo Professional 7.5

Setting the Print Options in MapInfo Professional

The discussion that follows assumes the following:

• The printer/plotter has been installed properly
• The printer/plotter drivers have been installed correctly
• The printer/plotter is connected to the computer or to the network properly
• There is sufficient memory (on the print device and on the computer) to print the files

Any of these issues can affect your ability to print/plot your MapInfo Professional output. Our Technical Support 
professionals may be able to identify the these difficulties, but they are not within their control.

Note: Whenever we use the terms print or printer we also mean plotter.

Setting Your Output Settings Preferences

Some of the controls that preset your printer options are in the Preferences dialog box. The Output Settings 
Preferences allow you to set display, printing, and export options for MapInfo Professional. The printers preferences 
are specific to your printer and allow you to set a separate MapInfo preferred printer from a Windows default printer. 
You can reset these options in the Print dialog box locally when you print to override the settings you select here.

Note: There are also two printer settings in the Startup Preferences dialog box that allow you to save printer 
information to workspaces and restore printer information from workspaces. These two check boxes are 
selected by default.

To set the Output Settings preferences:

1. Choose Options > Preferences > Output Settings to display the output preferences.

2. Select the desired preference settings and click OK to confirm them.

The entries below explain the display options, the printing options, and window export options in this dialog box. 
Some of the options appear in more than one tab so we have grouped all of the like explanations together.

Display Tab

Display Raster in True Color When Possible
Select this check box to display your 24-bit raster or grid file images in true color (make sure your display 
settings are set to greater than 256 colors). Clear this check box if you only want your images to display using 
256 colors. This box is selected by default.
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Dither Method
Dithering is a technique that blends pixels electronically to improve the look of an image. Select a dither method 
when you are converting a 24-bit image to 256 colors.

• Halftone dithering calculates a series of half tone differences in color between high- contrast elements in your 
image to create a smooth transition of color. This option is selected by default for display, print, and export 
options.

• Error diffusion dithering calculates an interim color between contrasting colors and shades the surrounding 
pixels to blend evenly toward that interim color.

Note: You can select dither method options in the display, printing, and exporting dialog boxes.

Printing Tab

Output Method/Print Directly to Device
Use this option to print your image file directly from MapInfo Professional. This is the default setting and is 
same printing from all versions before 6.0.

Output Method/Print Using Enhanced Metafile (EMF)
Use this option to generate an enhanced metafile of your MapInfo Professional image before sending it to the 
printer. This option takes advantage of current printer technology to shrink the spool size and print your file 
quicker without sacrificing quality.

Note: You must select this option if you are printing a map containing a translucent raster or grid layer. If you 
do not select this option, the image will not print translucently.

Print Border for Map Window
Select this check box to print a black border around the image you are printing. Clear this check box to leave 
the image unbordered. This check box is selected by default.

Internal Handling for Printing Transparent Vector Fills and Symbols
Special programming has been added to handle transparent fill patterns and bitmaps for vector images when 
printing or exporting. Select this check box to use this functionality or clear it to let Windows handle it. This 
check box is selected by default.

Note: The Scale Patterns check box does not affect transparent fill patterns. Transparent fill patterns are 
scaled for print and export when you select the Internal Handling... option.

Scale Patterns 
Select this check box to print non-transparent fill patterns that look like what you see on your screen. This check 
box is checked by default. Clear this check box to let the printer driver have exclusive control over rendering the 
pattern fills.

Note: The Scale Patterns check box does not affect transparent fill patterns because transparent fill patterns 
are always scaled.

Use ROP Method to Display Transparent Raster
Select this check box to allow the internal ROP (Raster Overlay by Pixel) to manage the transparent pixel 
display and printing in raster images. Since the ROP Method is largely a display method, not all printers, 
plotters, and export programs can use it. We recommend that you experiment with this setting until you get the 
results you want when printing raster images. This setting has no effect when printing vector layers. This check 
box is cleared by default.

Using the ROP method may not produce problems unless you print the metafile.

Print Raster in True Color When Possible
Select this check box to print and export your 24-bit raster or grid file images in true color (make sure your 
printer settings are set to greater than 256 colors). Clear this check box if you are not working with a color 
printer. This check box is selected by default.

Exporting Tab

Window Export/Export Border
Select this check box to include a black border on images you are exporting. Clear this check box to export the 
image without a border. This check box is selected by default.
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Use Anti-aliasing 
These options are new for MapInfo Professional 8.5. Select from these options:

Filter 
Choose a filter for the smoothing you want to use. Select from these filters:

• Vertically and Horizontally (Smooths the image vertically and horizontally)

• All Directions (1) (Smooths the image in all directions)

• All Directions (2) (Smooths the image in all directions using a different algorithm)

• Diagonally (Smooths the image diagonally)

• Horizontally (Smooths the image horizontally)

• Vertically (Smooths the image vertically)

Mask Size
Choose the pixel size of the mask you want MapInfo Professional to use in this field. For example, to create a 
3x3 pixel mask value, you would enter a 3 in this field. This would limit the amount of change in the color of the 
pixels to the three pixels around the basic pixel.

Threshold
Select a threshold value to indicate which pixels to smooth. Colors are 0 for black and 255 for white (in an 8 bit 
image). Numeric values for larger images are higher, but black is always 0. Entering a low number changes the 
look of your map by smoothing the darker colors and the lighter colors. Choosing a higher number changes the 
way the lighter colors display.

Setting Anti-Aliasing Options Locally during Window Export

To set the anti-aliasing options locally during export:

1. When you have completed your work on a window, select the File > Save Window As menu option. The Save 
Window to File dialog box displays.

2. Type the name and indicate the path of the file you are saving in this dialog box and click Save to continue. The 
Save Window As dialog box displays.

If you are exporting an EMF or WMF image, the Use Anti-Aliasing check box is disabled.

3. Select the Use Anti-aliasing check box and do one of the following:

• Click Save to use the anti-aliasing options you selected in the Output Preferences dialog box

• Click Advanced and choose new anti-aliasing options for this particular map. Click OK to return to the Save 
Window As dialog box and click Save to save these settings and the file.

Note: If you do not select the Use Anti-aliasing check box, the anti-aliasing options in the Advanced 
Exporting Options dialog box are disabled.

Setting Your Printer Preferences

You can use the printer preferences to select a printer for MapInfo Professional output, which can be separate from 
your default Windows printer.

1. Choose Options > Preferences > Printer to display the Printer Preferences dialog box.

2. Select the appropriate preferences using the descriptions in the following paragraphs to help you.

Windows Default
This entry displays the path to the default printer specified for your operating system. This button is selected by 
default.

MapInfo Preferred
Click this button to select a different default printer when printing while using MapInfo Professional. This can be 
a printer or a plotter. After you select this option you can specify the size of the paper that is appropriate for this 
printer. 
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Size
After you select a printer, this list prefills with the appropriate paper sizes available. Select the requested paper 
size from this drop-down list.

Orientation
After you select a printer, you can specify the direction that the paper faces. Portrait indicates that the paper is 
taller than it is wide (as shown in the previous figure); Landscape indicates that the paper is wider than it is tall.

Network
Click this button to locate the printer or plotter on the network that you want to set as the default. This button 
only displays for users running under Windows Windows 2000 and Windows XP Pro. The Connect to Printers 
dialog box displays.

3. Do one of the following:

• Select the path of the printer you want to use as your default MapInfo Professional printer and click OK,

• Double-click the printer in the list.

Using either method the Printer Preferences dialog box redisplays.

4. Click OK to confirm your selections and set your MapInfo Professional default printer options.

Note: If you selected the Save Printer Information to Workspaces button in the startup preferences, MapInfo 
Professional saves the printer information and settings to the workspace. To set this preference, choose 
Options > Preferences > Startup. If you are planning to share these workspaces with users running versions 
of MapInfo Professional earlier than 6.0, do not select this preference. Alternatively, turn it off if you have 
already activated it.
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