SMTP(8) SMTP(8)
[1mNAME[0m
smtp - Postfix remote delivery via SMTP
[1mSYNOPSIS[0m
[1msmtp [22m[generic Postfix daemon options]
[1mDESCRIPTION[0m
The SMTP client processes message delivery requests from the queue man-
ager. Each request specifies a queue file, a sender address, a domain
or host to deliver to, and recipient information. This program expects
to be run from the [1mmaster[22m(8) process manager.
The SMTP client updates the queue file and marks recipients as fin-
ished, or it informs the queue manager that delivery should be tried
again at a later time. Delivery status reports are sent to the
[1mbounce[22m(8), [1mdefer[22m(8) or [1mtrace[22m(8) daemon as appropriate.
The SMTP client looks up a list of mail exchanger addresses for the
destination host, sorts the list by preference, and connects to each
listed address until it finds a server that responds.
When a server is not reachable, or when mail delivery fails due to a
recoverable error condition, the SMTP client will try to deliver the
mail to an alternate host.
[1mSECURITY[0m
The SMTP client is moderately security-sensitive. It talks to SMTP
servers and to DNS servers on the network. The SMTP client can be run
chrooted at fixed low privilege.
[1mSTANDARDS[0m
RFC 821 (SMTP protocol)
RFC 822 (ARPA Internet Text Messages)
RFC 1651 (SMTP service extensions)
RFC 1652 (8bit-MIME transport)
RFC 1870 (Message Size Declaration)
RFC 2045 (MIME: Format of Internet Message Bodies)
RFC 2046 (MIME: Media Types)
RFC 2554 (AUTH command)
RFC 2821 (SMTP protocol)
RFC 2920 (SMTP Pipelining)
[1mDIAGNOSTICS[0m
Problems and transactions are logged to [1msyslogd[22m(8). Corrupted message
files are marked so that the queue manager can move them to the [1mcorrupt[0m
queue for further inspection.
Depending on the setting of the [1mnotify_classes [22mparameter, the postmas-
ter is notified of bounces, protocol problems, and of other trouble.
[1mCONFIGURATION PARAMETERS[0m
Changes to [1mmain.cf [22mare picked up automatically, as smtp(8) processes
run for only a limited amount of time. Use the command "[1mpostfix reload[22m"
to speed up a change.
The text below provides only a parameter summary. See postconf(5) for
more details including examples.
[1mCOMPATIBILITY CONTROLS[0m
[1mignore_mx_lookup_error (no)[0m
Ignore DNS MX lookups that produce no response.
[1msmtp_always_send_ehlo (yes)[0m
Always send EHLO at the start of an SMTP session.
[1msmtp_never_send_ehlo (no)[0m
Never send EHLO at the start of an SMTP session.
[1msmtp_defer_if_no_mx_address_found (no)[0m
Defer mail delivery when no MX record resolves to an IP address.
[1msmtp_line_length_limit (990)[0m
The maximal length of message header and body lines that Postfix
will send via SMTP.
[1msmtp_pix_workaround_delay_time (10s)[0m
How long the Postfix SMTP client pauses before sending
".<CR><LF>" in order to work around the PIX firewall
"<CR><LF>.<CR><LF>" bug.
[1msmtp_pix_workaround_threshold_time (500s)[0m
How long a message must be queued before the PIX firewall
"<CR><LF>.<CR><LF>" bug workaround is turned on.
[1msmtp_quote_rfc821_envelope (yes)[0m
Quote addresses in SMTP MAIL FROM and RCPT TO commands as
required by RFC 821.
[1msmtp_skip_5xx_greeting (yes)[0m
Skip SMTP servers that greet with a 5XX status code (go away, do
not try again later).
[1msmtp_skip_quit_response (yes)[0m
Do not wait for the response to the SMTP QUIT command.
[1msmtp_bind_address (empty)[0m
An optional numerical network address that the SMTP client
should bind to when making a connection.
[1msmtp_bind_address6 ()[0m
Numerical source network address (IPv6) to bind to when making a
connection.
Available in Postfix version 2.0 and earlier:
[1msmtp_skip_4xx_greeting (yes)[0m
Skip SMTP servers that greet with a 4XX status code (go away,
try again later).
[1mMIME PROCESSING CONTROLS[0m
Available in Postfix version 2.0 and later:
[1mdisable_mime_output_conversion (no)[0m
Disable the conversion of 8BITMIME format to 7BIT format.
[1mmime_boundary_length_limit (2048)[0m
The maximal length of MIME multipart boundary strings.
[1mmime_nesting_limit (100)[0m
The maximal nesting level of multipart mail that the MIME pro-
cessor will handle.
[1mEXTERNAL CONTENT INSPECTION CONTROLS[0m
Available in Postfix version 2.1 and later:
[1msmtp_send_xforward_command (no)[0m
Send the non-standard XFORWARD command when the Postfix SMTP
server EHLO response announces XFORWARD support.
[1mSASL AUTHENTICATION CONTROLS[0m
[1msmtp_sasl_auth_enable (no)[0m
Enable SASL authentication in the Postfix SMTP client.
[1msmtp_sasl_password_maps (empty)[0m
Optional SMTP client lookup tables with one username:password
entry per remote hostname or domain.
[1msmtp_sasl_security_options (noplaintext, noanonymous)[0m
What authentication mechanisms the Postfix SMTP client is
allowed to use.
[1msmtp_sasl_path (empty)[0m
The path where SASL will look for plugins. This is a colon sepa-
rated list of directories where the SASL plugins shared objects
are located. The default value is the null string, which will
use the path defined in the SASL library.
[1mRESOURCE AND RATE CONTROLS[0m
[1msmtp_destination_concurrency_limit ($default_destination_concur-[0m
[1mrency_limit)[0m
The maximal number of parallel deliveries to the same destina-
tion via the smtp message delivery transport.
[1msmtp_destination_recipient_limit ($default_destination_recipient_limit)[0m
The maximal number of recipients per delivery via the smtp mes-
sage delivery transport.
[1msmtp_connect_timeout (30s)[0m
The SMTP client time limit for completing a TCP connection, or
zero (use the operating system built-in time limit).
[1msmtp_helo_timeout (300s)[0m
The SMTP client time limit for sending the HELO or EHLO command,
and for receiving the initial server response.
[1msmtp_xforward_timeout (300s)[0m
The SMTP client time limit for sending the XFORWARD command, and
for receiving the server response.
[1msmtp_mail_timeout (300s)[0m
The SMTP client time limit for sending the MAIL FROM command,
and for receiving the server response.
[1msmtp_rcpt_timeout (300s)[0m
The SMTP client time limit for sending the SMTP RCPT TO command,
and for receiving the server response.
[1msmtp_data_init_timeout (120s)[0m
The SMTP client time limit for sending the SMTP DATA command,
and for receiving the server response.
[1msmtp_data_xfer_timeout (180s)[0m
The SMTP client time limit for sending the SMTP message content.
[1msmtp_data_done_timeout (600s)[0m
The SMTP client time limit for sending the SMTP ".", and for
receiving the server response.
[1msmtp_quit_timeout (300s)[0m
The SMTP client time limit for sending the QUIT command, and for
receiving the server response.
Available in Postfix version 2.1 and later:
[1msmtp_mx_address_limit (0)[0m
The maximal number of MX (mail exchanger) IP addresses that can
result from mail exchanger lookups, or zero (no limit).
[1msmtp_mx_session_limit (2)[0m
The maximal number of SMTP sessions per delivery request before
giving up or delivering to a fall-back relay host, or zero (no
limit).
[1msmtp_rset_timeout (120s)[0m
The SMTP client time limit for sending the RSET command, and for
receiving the server response.
[1mTROUBLE SHOOTING CONTROLS[0m
[1mdebug_peer_level (2)[0m
The increment in verbose logging level when a remote client or
server matches a pattern in the debug_peer_list parameter.
[1mdebug_peer_list (empty)[0m
Optional list of remote client or server hostname or network
address patterns that cause the verbose logging level to
increase by the amount specified in $debug_peer_level.
[1merror_notice_recipient (postmaster)[0m
The recipient of postmaster notifications about mail delivery
problems that are caused by policy, resource, software or proto-
col errors.
[1mnotify_classes (resource, software)[0m
The list of error classes that are reported to the postmaster.
[1mMISCELLANEOUS CONTROLS[0m
[1mbest_mx_transport (empty)[0m
Where the Postfix SMTP client should deliver mail when it
detects a "mail loops back to myself" error condition.
[1mconfig_directory (see 'postconf -d' output)[0m
The default location of the Postfix main.cf and master.cf con-
figuration files.
[1mdaemon_timeout (18000s)[0m
How much time a Postfix daemon process may take to handle a
request before it is terminated by a built-in watchdog timer.
[1mdisable_dns_lookups (no)[0m
Disable DNS lookups in the Postfix SMTP and LMTP clients.
[1mfallback_relay (empty)[0m
Optional list of relay hosts for SMTP destinations that can't be
found or that are unreachable.
[1minet_interfaces (all)[0m
The network interface addresses that this mail system receives
mail on.
[1mipc_timeout (3600s)[0m
The time limit for sending or receiving information over an
internal communication channel.
[1mmax_idle (100s)[0m
The maximum amount of time that an idle Postfix daemon process
waits for the next service request before exiting.
[1mmax_use (100)[0m
The maximal number of connection requests before a Postfix dae-
mon process terminates.
[1mprocess_id (read-only)[0m
The process ID of a Postfix command or daemon process.
[1mprocess_name (read-only)[0m
The process name of a Postfix command or daemon process.
[1mproxy_interfaces (empty)[0m
The network interface addresses that this mail system receives
mail on by way of a proxy or network address translation unit.
[1msmtp_bind_address (empty)[0m
An optional numerical network address that the SMTP client
should bind to when making a connection.
[1msmtp_helo_name ($myhostname)[0m
The hostname to send in the SMTP EHLO or HELO command.
[1msmtp_host_lookup (dns)[0m
What mechanisms when the SMTP client uses to look up a host's IP
address.
[1msmtp_randomize_addresses (yes)[0m
Randomize the order of equal-preference MX host addresses.
[1msyslog_facility (mail)[0m
The syslog facility of Postfix logging.
[1msyslog_name (postfix)[0m
The mail system name that is prepended to the process name in
syslog records, so that "smtpd" becomes, for example, "post-
fix/smtpd".
[1mSEE ALSO[0m
qmgr(8), queue manager
bounce(8), delivery status reports
postconf(5), configuration parameters
master(8), process manager
syslogd(8), system logging
[1mREADME FILES[0m
this information.
SASL_README, Postfix SASL howto
[1mLICENSE[0m
The Secure Mailer license must be distributed with this software.
[1mAUTHOR(S)[0m
Wietse Venema
IBM T.J. Watson Research
P.O. Box 704
Yorktown Heights, NY 10598, USA
SMTP(8)