2. Вычисления и моделирование

 Выберите в главном меню пункт Офис → OpenOffice.org Calc для запуска OpenOffice.org Calc.

2.1. Интерфейс электронной таблицы

Рисунок 3.2. Главное окно OpenOffice.org Calc


Панель форматирования.  Это стандартная панель форматирования, которая присутствует во всех приложениях пакета OpenOffice.org и позволяет менять шрифт, цвета, выравнивание и другие параметры текста.

Панель формул.  Используйте эту панель для ввода, правки и удаления формул из ячеек.

Рабочая область.  В эту область вводятся данные таблицы: числа, даты, формулы, изображения и так далее.

Выбрать все.  Щелчок по этой небольшой области в левом верхнем углу рабочей области выделяет все ячейки сразу. Это может пригодиться, если вам нужно выполнить какие-либо «глобальные» изменения в таблице. Например, когда нужно изменить размер шрифта во всех ячейках на 10 пунктов.

Кнопки и вкладки для навигации по таблице.  Электронные таблицы обычно содержат несколько листов. С помощью этих кнопок вы можете с легкостью переключаться между листами внутри таблицы. Кнопки обозначают следующее (слева направо): Перейти к первому листу, Перейти к предыдущему листу, Перейти к следующему листу и Перейти к последнему листу. Для переключения между листами можно также использовать вкладки.

2.2. Ввод данных

Для ввода данных в ячейку, выделите ее и введите нужную информацию, после чего нажмите Enter.

Автозаполнение упрощает создание «алгоритма» заполнения следующей ячейки на основе значения предыдущей ячейки. Это работает для любых типов данных, которые можно ассоциировать с упорядоченным диапазоном чисел.

Рисунок 3.3. Упрощение ввода данных при помощи автозаполнения

Упрощение ввода данных при помощи автозаполнения

Для использования автоматического заполнения подведите указатель мыши к «рукоятке» исходной ячейки (маленький квадратик в правом нижнем углу рамки ячейки), щелкните по ней и перетащите на пустую ячейку. Значения ячеек появятся во всплывающей подсказке. (см. Рисунок 3.3, «Упрощение ввода данных при помощи автозаполнения»). Отпустите кнопку мыши в тот момент, когда будет предложен правильный вариант автозаполнения.

Содержимое ячеек можно также отсортировать по разным параметрам. Выделите ячейки, которые вы хотите отсортировать и затем откройте диалог параметров сортировки, выбрав в меню пункт Данные → Сортировка. Укажите тип и порядок сортировки, дополнительные параметры и нажмите OK для сортировки ячеек.

[Подсказка] Подсказка

Убедитесь, что вы также выделили столбцы и строки, которые являются «заголовками» для данных, чтобы они тоже «участвовали» в сортировке.

2.3. Добавление формул

Формулы могут быть использованы для «автоматизации» содержимого таблицы. Например, вы можете произодить сложные вычисления. Внутри ячеек, формулы обозначаются данных с помощью знака = перед содержимым. Все остальное обрабатывается как «статичные» данные.

Действия оформляются при помощи стандартных алгебраических операций. Например, выражение =3*A25+4*(A20+C34/B34) делит значение ячейки C34 на значение из ячейки B34, затем прибавляет к результату значение из ячейки A20, после чего умножает то, что получилось на 4 и прибавляет к утроенному значению ячейки A25. Таким образом, можно делать сложные формулы на основе более простых блоков.

OpenOffice.org Calc имеет множество готовых функций, которые вы можете использовать в своих формулах. Просмотреть их можно, выбрав в меню пункт Вставка → Функция.

[Подсказка] Подсказка

  Вы также можете вызвать Мастер функций, который поможет составить формулу.

2.4. Диаграммы: простой способ пояснить данные

Когда электронная таблица наполняется большим объемом данных, становится сложно понимать отношения между различными элементами: цифр становится слишком много, а ясности — слишком мало. Лучшим способом оформить такие данные является диаграмма.

Как и для всех функций анализа данных, сперва вы должны выделить область, которая будет представлена в диаграмме. Поэтому выделите часть ячеек и затем выберите в меню пункт Вставка → Диаграмма, после чего появится окно мастера диаграмм.

Выберите тип диаграммы, стиль, заголовок, легенду, названия осей и прочее, затем нажмите кнопку Готово для вставки новой диаграммы в таблицу (см. Рисунок 3.4, «Вставка трехмерной диаграммы»).

Рисунок 3.4. Вставка трехмерной диаграммы

Вставка трехмерной диаграммы

[Подсказка] Подсказка

Диаграммы являются «динамическими» объектами таблицы, что означает автоматическое обновление диаграммы при изменении табличных данных, которые задействованы в ее построении.

[Подсказка] Подсказка

Двойной щелчок по диаграмме, а затем - щелчок правой кнопкой мыши вызывают меню, где можно настроить многие параметры диаграммы.